aboutsummaryrefslogtreecommitdiffstats
path: root/games/tome/files/pkg-deinstall.in
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-07-05 10:49:58 +0800
committeredwin <edwin@FreeBSD.org>2008-07-05 10:49:58 +0800
commit898f9e521f9472bfb81f987e5aab8958cbbc3ae6 (patch)
tree95e165827db43b95bfaba78fc0e4c20a46c02032 /games/tome/files/pkg-deinstall.in
parent55b25075bf2d91f313463d01a0c5cd12c3b6e36f (diff)
downloadfreebsd-ports-gnome-898f9e521f9472bfb81f987e5aab8958cbbc3ae6.tar.gz
freebsd-ports-gnome-898f9e521f9472bfb81f987e5aab8958cbbc3ae6.tar.zst
freebsd-ports-gnome-898f9e521f9472bfb81f987e5aab8958cbbc3ae6.zip
[patch] games/tome package-building is broken
The package by make package will install fine but it's not possible to start the game. make install runs T.o.M.Es own install script which changes file permissions. This is not done using the binary package. To fix this I have added the corresponding @exec directives to the pkg-plist. While here I added the creation of the plot directory which is not part of the binary package. While here I replaced @dirrm with @dirrmtry directives to make the deinstall less verbose. Problem is T.o.M.E spams the %%DATADIR%% so it won't deinstall cleanly. To make the user aware of this I added a pkg-deinstall script which will emit a corresponding message. PR: ports/125194 Submitted by: Tobias Rehbein <tobias.rehbein@web.de> Approved by: Peter Thoenen <peter.thoenen@yahoo.com>
Diffstat (limited to 'games/tome/files/pkg-deinstall.in')
-rw-r--r--games/tome/files/pkg-deinstall.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/games/tome/files/pkg-deinstall.in b/games/tome/files/pkg-deinstall.in
new file mode 100644
index 000000000000..cbcbd01bed90
--- /dev/null
+++ b/games/tome/files/pkg-deinstall.in
@@ -0,0 +1,12 @@
+#!/bin/sh
+# $FreeBSD$
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ echo ""
+ echo "If you are removing T.o.M.E permanently you should run"
+ echo "the following command:"
+ echo ""
+ echo " rm -rf %%DATADIR%%"
+ echo ""
+fi
+