aboutsummaryrefslogtreecommitdiffstats
path: root/games/toppler
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-02-01 02:35:27 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-02-01 02:35:27 +0800
commitc8cb175e50127fcf2cd4e52c072d3a2fe6b92671 (patch)
tree5e2c2cb121344b7c8ebbb9de34d8c6ba953cb544 /games/toppler
parentea3ed56f4c5a1322789ffb5132758aa3835f7fe6 (diff)
downloadfreebsd-ports-gnome-c8cb175e50127fcf2cd4e52c072d3a2fe6b92671.tar.gz
freebsd-ports-gnome-c8cb175e50127fcf2cd4e52c072d3a2fe6b92671.tar.zst
freebsd-ports-gnome-c8cb175e50127fcf2cd4e52c072d3a2fe6b92671.zip
- Update to 1.1.6
- Take maintainership - Fix LICENSE - Add LICENSE_FILE - Switch to USES=localbase - Update WWW
Diffstat (limited to 'games/toppler')
-rw-r--r--games/toppler/Makefile17
-rw-r--r--games/toppler/distinfo5
-rw-r--r--games/toppler/files/patch-main.cc12
-rw-r--r--games/toppler/pkg-descr2
-rw-r--r--games/toppler/pkg-plist8
5 files changed, 23 insertions, 21 deletions
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
index 5d66718fe0cf..ef312a97a9c5 100644
--- a/games/toppler/Makefile
+++ b/games/toppler/Makefile
@@ -2,29 +2,26 @@
# $FreeBSD$
PORTNAME= toppler
-PORTVERSION= 1.1.5
-PORTREVISION= 5
+PORTVERSION= 1.1.6
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
+MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Climb a tower and avoid monsters
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+USES= gettext gmake localbase
USE_SDL= mixer sdl
-USES= gettext gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/games
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
OPTIONS_DEFINE= DOCS
SCOREFILE= /var/games/toppler/toppler.hsc
post-install:
- ${MV} ${STAGEDIR}${SCOREFILE} ${STAGEDIR}${SCOREFILE}.sample
+ @${MV} ${STAGEDIR}${SCOREFILE} ${STAGEDIR}${SCOREFILE}.sample
.include <bsd.port.mk>
diff --git a/games/toppler/distinfo b/games/toppler/distinfo
index f4394e2d2b69..cebda3038a0f 100644
--- a/games/toppler/distinfo
+++ b/games/toppler/distinfo
@@ -1,2 +1,3 @@
-SHA256 (toppler-1.1.5.tar.gz) = 26cab477cfc427827fc4dc584271148ba4d14b5a5f12c1752e262b795d814167
-SIZE (toppler-1.1.5.tar.gz) = 2152897
+TIMESTAMP = 1485788372
+SHA256 (toppler-1.1.6.tar.gz) = 7dbc2905389c2adba0f8c459f3319cf04045ba53ed407e273a50a3a67564cc45
+SIZE (toppler-1.1.6.tar.gz) = 2117137
diff --git a/games/toppler/files/patch-main.cc b/games/toppler/files/patch-main.cc
new file mode 100644
index 000000000000..fcf7d9921954
--- /dev/null
+++ b/games/toppler/files/patch-main.cc
@@ -0,0 +1,12 @@
+--- main.cc.orig 2012-12-22 11:02:06 UTC
++++ main.cc
+@@ -96,7 +96,8 @@ int main(int argc, char *argv[]) {
+
+ DIR *dir = opendir("locale");
+ bindtextdomain("toppler", dir == NULL ? LOCALEDIR : "locale");
+- closedir(dir);
++ if (dir)
++ closedir(dir);
+ textdomain("toppler");
+ #endif
+
diff --git a/games/toppler/pkg-descr b/games/toppler/pkg-descr
index ecfa24259c1d..b2d1ff2d9008 100644
--- a/games/toppler/pkg-descr
+++ b/games/toppler/pkg-descr
@@ -12,4 +12,4 @@ The only weapon of defence you have is to throw a little snowball. But
most of the other creatures just don't care about this. So you must
avoid them.
-WWW: http://toppler.sf.net/
+WWW: http://toppler.sourceforge.net/
diff --git a/games/toppler/pkg-plist b/games/toppler/pkg-plist
index 8d1d116bcead..71e96b060090 100644
--- a/games/toppler/pkg-plist
+++ b/games/toppler/pkg-plist
@@ -13,14 +13,6 @@ share/locale/pt/LC_MESSAGES/toppler.mo
share/locale/ro/LC_MESSAGES/toppler.mo
share/locale/sv/LC_MESSAGES/toppler.mo
share/pixmaps/toppler.xpm
-%%DATADIR%%/abc.ttm
-%%DATADIR%%/ball1.ttm
-%%DATADIR%%/ball2.ttm
-%%DATADIR%%/ball3.ttm
-%%DATADIR%%/david1.ttm
-%%DATADIR%%/m1.ttm
-%%DATADIR%%/m2.ttm
-%%DATADIR%%/pasi2.ttm
%%DATADIR%%/toppler.dat
%%DATADIR%%/toppler.ogg
@sample(,games,664) /var/games/toppler/toppler.hsc.sample