aboutsummaryrefslogtreecommitdiffstats
path: root/games/traindirector/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-08 20:09:47 +0800
committeredwin <edwin@FreeBSD.org>2003-09-08 20:09:47 +0800
commit73cdbbff4964974f3dd568fa10f41f0af4d5ad84 (patch)
treee1b4df98b25d9e33923a41a5f80706c8bb4e299e /games/traindirector/Makefile
parent1804f620de6414ae4df760df356754a2092347c2 (diff)
downloadfreebsd-ports-gnome-73cdbbff4964974f3dd568fa10f41f0af4d5ad84.tar.gz
freebsd-ports-gnome-73cdbbff4964974f3dd568fa10f41f0af4d5ad84.tar.zst
freebsd-ports-gnome-73cdbbff4964974f3dd568fa10f41f0af4d5ad84.zip
[maintainer update] train director to 1.18e
upgrading the train director game port to 1.18e (received a request by email too) PR: ports/56589 Submitted by: Guido Falsi <mad@madpilot.net>
Diffstat (limited to 'games/traindirector/Makefile')
-rw-r--r--games/traindirector/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/games/traindirector/Makefile b/games/traindirector/Makefile
index 08180a2ee51a..279bf87ab7a2 100644
--- a/games/traindirector/Makefile
+++ b/games/traindirector/Makefile
@@ -1,37 +1,37 @@
-# New ports collection makefile for: oneko
-# Date created: 15/11/2002
+# New ports collection makefile for: traindirector
+# Date created: 09/08/2003
# Whom: Guido Falsi <mad@madpilot.net>
#
# $FreeBSD$
#
PORTNAME= tdir
-PORTVERSION= 1.17f
+PORTVERSION= 1.18e
CATEGORIES= games
-MASTER_SITES= http://www.backerstreet.com/traindir/
-DISTNAME= tdir117s
+MASTER_SITES= http://xtsl.free.fr/118e/
+DISTNAME= traindir-${PORTVERSION}-src
+WRKSRC= ${WRKDIR}/traindir-${PORTVERSION}
MAINTAINER= mad@madpilot.net
COMMENT= Train controller simulation
-USE_ZIP= yes
+USE_GMAKE= yes
USE_XLIB= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12 glib12
USE_REINPLACE= yes
-NO_WRKSUBDIR= yes
-
post-extract:
- ${REINPLACE_CMD} -e 's/ //' ${WRKSRC}/*
+.for file in Makefile field.c loadsave.c run.c setup_trdir.sh tgraph.c track.c track1.c trsim.c
+ @${TR} -d '\015' < ${WRKSRC}/${file} > ${WRKDIR}/xxxx
+ @${MV} ${WRKDIR}/xxxx ${WRKSRC}/${file}
+.endfor
post-patch:
- @ cd ${WRKSRC} ; ${LN} MAKEFILE Makefile ; \
- ${MV} Gdialog.c gdialog.c ; ${MV} Gtkopen.c gtkopen.c ; \
- ${MV} Gtkopen.h gtkopen.h ; ${MV} Html.c html.c ; \
- ${MV} Html.h html.h
+ ${REINPLACE_CMD} -e 's#PREFIX#$(PREFIX)#' $(WRKSRC)/setup_trdir.sh
post-configure:
${REINPLACE_CMD} -e 's,\#include \<malloc.h\>,/* include malloc.h */,' \
${WRKSRC}/gdialog.c
+
.include <bsd.port.mk>