aboutsummaryrefslogtreecommitdiffstats
path: root/games/tycho
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-11-30 20:56:41 +0800
committerbapt <bapt@FreeBSD.org>2012-11-30 20:56:41 +0800
commitb33e9e2af01d61948aa10756f0b297676f4c19eb (patch)
tree3260c5893f8ec434cf701bcd0fd0c49c7a8aae30 /games/tycho
parentff0fbbb8ad5bed87e504d1e7127ec10cdef27a61 (diff)
downloadfreebsd-ports-gnome-b33e9e2af01d61948aa10756f0b297676f4c19eb.tar.gz
freebsd-ports-gnome-b33e9e2af01d61948aa10756f0b297676f4c19eb.tar.zst
freebsd-ports-gnome-b33e9e2af01d61948aa10756f0b297676f4c19eb.zip
Fix build with clang removing -O4 which means LTO for clang
Feature safe: yes
Diffstat (limited to 'games/tycho')
-rw-r--r--games/tycho/Makefile6
-rw-r--r--games/tycho/files/patch-Makefile10
2 files changed, 7 insertions, 9 deletions
diff --git a/games/tycho/Makefile b/games/tycho/Makefile
index 4190f913ac6b..f1d6dd78137e 100644
--- a/games/tycho/Makefile
+++ b/games/tycho/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tycho
-# Date created: 2008-01-16
-# Whom: alepulver
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tycho
PORTVERSION= 0.1
diff --git a/games/tycho/files/patch-Makefile b/games/tycho/files/patch-Makefile
index ca9defdd35d0..e5d2ea454634 100644
--- a/games/tycho/files/patch-Makefile
+++ b/games/tycho/files/patch-Makefile
@@ -1,12 +1,14 @@
---- ./Makefile.orig Thu Sep 4 12:44:24 2003
-+++ ./Makefile Wed Jan 16 19:36:13 2008
-@@ -1,7 +1,7 @@
+--- Makefile.orig 2003-09-04 17:44:24.000000000 +0200
++++ Makefile 2012-11-30 13:54:33.684116105 +0100
+@@ -1,8 +1,8 @@
# $Id: Makefile,v 1.3 2003/09/04 15:44:24 varfar Exp $
-CC = gcc
-CFLAGS = ${OPT} ${DBG} -DSIM_STRIP_FLAGS=1
+-OPT = -O4 -fomit-frame-pointer
+CC ?= gcc
+CFLAGS += ${OPT} ${DBG} -DSIM_STRIP_FLAGS=1
- OPT = -O4 -fomit-frame-pointer
++OPT = -fomit-frame-pointer
#DBG = -g -DDEBUG=2
+ # Recommended extra options for gcc: