aboutsummaryrefslogtreecommitdiffstats
path: root/games/unnethack
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2007-08-26 02:09:49 +0800
committerglewis <glewis@FreeBSD.org>2007-08-26 02:09:49 +0800
commitac390279b0c5f8bb1f2bf4c45f07d9f47bcd0982 (patch)
treec86ed67978fed4e9d797530c7472b8e707cbb492 /games/unnethack
parent35b13106fb80478f92790b850eeb1f3eabd1e05a (diff)
downloadfreebsd-ports-gnome-ac390279b0c5f8bb1f2bf4c45f07d9f47bcd0982.tar.gz
freebsd-ports-gnome-ac390279b0c5f8bb1f2bf4c45f07d9f47bcd0982.tar.zst
freebsd-ports-gnome-ac390279b0c5f8bb1f2bf4c45f07d9f47bcd0982.zip
. Use ${DATADIR} consistently instead fo sometimes using
${PREFIX}/share/slashem Submitted by: sat@ (although this is a slightly different implementation)
Diffstat (limited to 'games/unnethack')
-rw-r--r--games/unnethack/Makefile3
-rw-r--r--games/unnethack/files/patch-config.h2
-rw-r--r--games/unnethack/files/patch-makefile.top2
3 files changed, 4 insertions, 3 deletions
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index 43a93079554a..664a84cdd5b0 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -22,10 +22,11 @@ SUB_FILES+= pkg-deinstall
MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
+MAKE_ENV+= DATADIR="${DATADIR}"
post-patch:
${REINPLACE_CMD} -e \
- "s@%%PREFIX%%@${PREFIX}@g" ${WRKSRC}/include/config.h
+ "s@%%DATADIR%%@${DATADIR}@g" ${WRKSRC}/include/config.h
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
diff --git a/games/unnethack/files/patch-config.h b/games/unnethack/files/patch-config.h
index 1d9ceca5348d..aeae766ed175 100644
--- a/games/unnethack/files/patch-config.h
+++ b/games/unnethack/files/patch-config.h
@@ -33,7 +33,7 @@ $FreeBSD$
# define HACKDIR "nethackdir" /* nethack directory */
# else
-# define HACKDIR "."
-+# define HACKDIR "%%PREFIX%%/share/slashem" /* nethack directory */
++# define HACKDIR "%%DATADIR%%" /* nethack directory */
# endif
# endif
diff --git a/games/unnethack/files/patch-makefile.top b/games/unnethack/files/patch-makefile.top
index b832d5afe042..1e365b96c6c0 100644
--- a/games/unnethack/files/patch-makefile.top
+++ b/games/unnethack/files/patch-makefile.top
@@ -32,7 +32,7 @@ $FreeBSD$
# Defs. for non file areas support.
-GAMEDIR = $(PREFIX)/local/slashemdir
-+GAMEDIR = $(PREFIX)/share/${GAME}
++GAMEDIR = $(DATADIR)
VARDIR = $(GAMEDIR)
FILE_AREA_VAR = $(VARDIR)
FILE_AREA_SAVE = $(VARDIR)/save