aboutsummaryrefslogtreecommitdiffstats
path: root/games/violetland
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-12-01 03:34:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-12-01 03:34:41 +0800
commit7a4fbce8572d7cbb18dd13ef1d2cede4cd6fdd13 (patch)
tree684168150171aaab3a20c4ceb1c1ce02d42de99e /games/violetland
parenta6d2674a2683726796cdfa251597e69d671df8ed (diff)
downloadfreebsd-ports-gnome-7a4fbce8572d7cbb18dd13ef1d2cede4cd6fdd13.tar.gz
freebsd-ports-gnome-7a4fbce8572d7cbb18dd13ef1d2cede4cd6fdd13.tar.zst
freebsd-ports-gnome-7a4fbce8572d7cbb18dd13ef1d2cede4cd6fdd13.zip
- Update to 0.2.4
Diffstat (limited to 'games/violetland')
-rw-r--r--games/violetland/Makefile5
-rw-r--r--games/violetland/distinfo6
-rw-r--r--games/violetland/files/patch-src-program.cpp28
-rw-r--r--games/violetland/pkg-plist28
4 files changed, 31 insertions, 36 deletions
diff --git a/games/violetland/Makefile b/games/violetland/Makefile
index f38fc2cff80a..bfd5a27a8fac 100644
--- a/games/violetland/Makefile
+++ b/games/violetland/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= violetland
-PORTVERSION= 0.2.2
+PORTVERSION= 0.2.4
CATEGORIES= games
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}-v${PORTVERSION}-src
@@ -20,12 +20,13 @@ USE_GL= gl glu
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
CMAKE_USE_PTHREAD=yes
+CMAKE_ARGS= -DDATA_INSTALL_DIR="${DATADIR}"
WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}
DESKTOP_ENTRIES="Violetland" \
"Top-down survival shoot 'em up" \
- "" \
+ "${DATADIR}/icon-light.png" \
"violetland" \
"Game;ArcadeGame;" \
false
diff --git a/games/violetland/distinfo b/games/violetland/distinfo
index ead0e98995f4..a6873baedb53 100644
--- a/games/violetland/distinfo
+++ b/games/violetland/distinfo
@@ -1,3 +1,3 @@
-MD5 (violetland-v0.2.2-src.zip) = 933cc7f6be0e45ff39e67129c8e731c9
-SHA256 (violetland-v0.2.2-src.zip) = 6ed5abd0537a7b95273ad454220b004e9eca09950c552eafc77b373f99c33671
-SIZE (violetland-v0.2.2-src.zip) = 7408939
+MD5 (violetland-v0.2.4-src.zip) = b33d61afd2e28b29127cdaff23c06b48
+SHA256 (violetland-v0.2.4-src.zip) = 95a9a5e0c268c0d210532bb4bcd7ad732a41d41ff82c492246a14780df51c035
+SIZE (violetland-v0.2.4-src.zip) = 7657490
diff --git a/games/violetland/files/patch-src-program.cpp b/games/violetland/files/patch-src-program.cpp
deleted file mode 100644
index 6c86bf2e4f66..000000000000
--- a/games/violetland/files/patch-src-program.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/program.cpp.orig 2009-11-05 01:13:34.000000000 +0300
-+++ src/program.cpp 2009-11-07 03:32:21.000000000 +0300
-@@ -1302,16 +1302,20 @@
-
- void drawWindows() {
- if (!windows.empty()) {
-- std::map<std::string, Window*>::const_iterator win;
-+ std::map<std::string, Window*>::iterator win, victim;
- for (win = windows.begin(); win != windows.end(); ++win) {
- Window* w = win->second;
- w->draw();
- w->process(input);
- }
-- for (win = windows.begin(); win != windows.end(); ++win) {
-- Window* w = win->second;
-- if (w->CloseFlag)
-- windows.erase(win->first);
-+ win = windows.begin();
-+ while (win != windows.end()) {
-+ if (win->second->CloseFlag) {
-+ victim = win++;
-+ windows.erase(victim);
-+ } else {
-+ win++;
-+ }
- }
- }
- }
diff --git a/games/violetland/pkg-plist b/games/violetland/pkg-plist
index ec6bb5b4115c..391e4bf598ec 100644
--- a/games/violetland/pkg-plist
+++ b/games/violetland/pkg-plist
@@ -18,6 +18,18 @@ bin/violetland
%%DATADIR%%/images/anima/bleed/bleed-7.png
%%DATADIR%%/images/anima/bleed/bleed-8.png
%%DATADIR%%/images/anima/bleed/bleed-9.png
+%%DATADIR%%/images/anima/grenade/0.png
+%%DATADIR%%/images/anima/grenade/1.png
+%%DATADIR%%/images/anima/grenade/10.png
+%%DATADIR%%/images/anima/grenade/11.png
+%%DATADIR%%/images/anima/grenade/2.png
+%%DATADIR%%/images/anima/grenade/3.png
+%%DATADIR%%/images/anima/grenade/4.png
+%%DATADIR%%/images/anima/grenade/5.png
+%%DATADIR%%/images/anima/grenade/6.png
+%%DATADIR%%/images/anima/grenade/7.png
+%%DATADIR%%/images/anima/grenade/8.png
+%%DATADIR%%/images/anima/grenade/9.png
%%DATADIR%%/images/anima/monsters/0/move-0.png
%%DATADIR%%/images/anima/monsters/0/move-1.png
%%DATADIR%%/images/anima/monsters/0/move-10.png
@@ -96,7 +108,11 @@ bin/violetland
%%DATADIR%%/images/blood_0.png
%%DATADIR%%/images/blood_1.png
%%DATADIR%%/images/blood_2.png
+%%DATADIR%%/images/expl_0.png
+%%DATADIR%%/images/expl_1.png
+%%DATADIR%%/images/grenade.png
%%DATADIR%%/images/laser.png
+%%DATADIR%%/images/m32.png
%%DATADIR%%/images/medikit.png
%%DATADIR%%/images/player_top.png
%%DATADIR%%/images/pm.png
@@ -117,13 +133,18 @@ bin/violetland
%%DATADIR%%/images/terrain/base_2.png
%%DATADIR%%/images/terrain/base_3.png
%%DATADIR%%/images/uzi.png
-%%DATADIR%%/music/dzaibatsu.ogg
-%%DATADIR%%/music/morning.ogg
-%%DATADIR%%/music/space-crusader.ogg
+%%DATADIR%%/music/01.ogg
+%%DATADIR%%/music/02.ogg
+%%DATADIR%%/music/03.ogg
+%%DATADIR%%/music/04.ogg
+%%DATADIR%%/music/05.ogg
%%DATADIR%%/sounds/ak-47_reload.ogg
%%DATADIR%%/sounds/ak-47_shot.ogg
+%%DATADIR%%/sounds/explode-0.ogg
+%%DATADIR%%/sounds/explode-1.ogg
%%DATADIR%%/sounds/laser_reload.ogg
%%DATADIR%%/sounds/laser_shot.ogg
+%%DATADIR%%/sounds/m32_shot.ogg
%%DATADIR%%/sounds/player_hit_0.ogg
%%DATADIR%%/sounds/player_hit_1.ogg
%%DATADIR%%/sounds/player_hit_2.ogg
@@ -148,6 +169,7 @@ bin/violetland
@dirrm %%DATADIR%%/images/anima/monsters/1
@dirrm %%DATADIR%%/images/anima/monsters/0
@dirrm %%DATADIR%%/images/anima/monsters
+@dirrm %%DATADIR%%/images/anima/grenade
@dirrm %%DATADIR%%/images/anima/bleed
@dirrm %%DATADIR%%/images/anima
@dirrm %%DATADIR%%/images