aboutsummaryrefslogtreecommitdiffstats
path: root/games/wargus
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-17 07:56:53 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-17 07:56:53 +0800
commit2cccdfd2e9c25e298fb7d75c22f3c1712096e6c2 (patch)
treeec2b33897679532fcbedaeae39aca1ca0a9da963 /games/wargus
parenta545597690cc68e2a490b2a6f3ad4f4840318144 (diff)
downloadfreebsd-ports-gnome-2cccdfd2e9c25e298fb7d75c22f3c1712096e6c2.tar.gz
freebsd-ports-gnome-2cccdfd2e9c25e298fb7d75c22f3c1712096e6c2.tar.zst
freebsd-ports-gnome-2cccdfd2e9c25e298fb7d75c22f3c1712096e6c2.zip
- Support staging
- Fix build with clang
Diffstat (limited to 'games/wargus')
-rw-r--r--games/wargus/Makefile24
-rw-r--r--games/wargus/files/patch-wargus.c11
2 files changed, 18 insertions, 17 deletions
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index 4ce59f69c04d..ed15d06a5980 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -12,33 +12,23 @@ EXTRACT_SUFX= .orig.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Warcraft 2 mod that allows you to play Warcraft 2 with Stratagus
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
RUN_DEPENDS= stratagus:${PORTSDIR}/games/stratagus
-LICENSE= GPLv2
NOT_FOR_ARCHS= sparc64
USES= pathfix gmake pkgconfig
-USE_CSTD= gnu89
USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SUB_FILES= ${PORTNAME} pkg-message
MAKE_ARGS+= CFLAGS+="-I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15" LDFLAGS+=-L${LOCALBASE}/lib
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- cd ${WRKSRC} && \
- ${FIND} campaigns contrib maps scripts -type d \
- -exec ${MKDIR} "${DATADIR}/{}" \; && \
- ${FIND} campaigns contrib maps scripts -type f \
- -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
- ${INSTALL_PROGRAM} ${WRKSRC}/wartool ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/build.sh ${DATADIR}
-
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "campaigns contrib maps scripts" ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/wartool ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/build.sh ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/games/wargus/files/patch-wargus.c b/games/wargus/files/patch-wargus.c
new file mode 100644
index 000000000000..c0f1bf089431
--- /dev/null
+++ b/games/wargus/files/patch-wargus.c
@@ -0,0 +1,11 @@
+--- wargus.c.orig 2010-11-22 03:07:16.000000000 +0300
++++ wargus.c 2014-05-16 20:50:55.007540700 +0400
+@@ -86,7 +86,7 @@
+ int ConsoleMode = 0;
+ #endif
+
+-inline void error(char * title, char * text) {
++void error(char * title, char * text) {
+
+ #ifdef WIN32
+ MessageBox(NULL, text, title, MB_OK | MB_ICONERROR);