aboutsummaryrefslogtreecommitdiffstats
path: root/games/warsow
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2009-12-05 23:04:34 +0800
committerdanfe <danfe@FreeBSD.org>2009-12-05 23:04:34 +0800
commit1612633752f5e2f3088b9e12a5fb4176afe0f507 (patch)
treedd5ef66186219ff328ec0125ae1a9796d6d5aa43 /games/warsow
parentdcb881c96ad043348c750cdf29be63b201860d36 (diff)
downloadfreebsd-ports-gnome-1612633752f5e2f3088b9e12a5fb4176afe0f507.tar.gz
freebsd-ports-gnome-1612633752f5e2f3088b9e12a5fb4176afe0f507.tar.zst
freebsd-ports-gnome-1612633752f5e2f3088b9e12a5fb4176afe0f507.zip
- Belatedly update to version 0.5
- Offer to install community map pack (on by default) - Convert one patch file to simple inplace editing
Diffstat (limited to 'games/warsow')
-rw-r--r--games/warsow/Makefile19
-rw-r--r--games/warsow/distinfo6
-rw-r--r--games/warsow/files/patch-Makefile31
-rw-r--r--games/warsow/files/patch-game+q_shared.h42
4 files changed, 26 insertions, 72 deletions
diff --git a/games/warsow/Makefile b/games/warsow/Makefile
index a0f7320b0a9b..788f941a57b6 100644
--- a/games/warsow/Makefile
+++ b/games/warsow/Makefile
@@ -6,11 +6,14 @@
#
PORTNAME= warsow
-PORTVERSION= 0.42
-PORTREVISION= 3
+PORTVERSION= 0.5
CATEGORIES= games
-MASTER_SITES= http://data.rodix.free.fr/warsow/files/ \
- http://88.191.19.21/wsw/
+MASTER_SITES= http://woe.crying-wolves.net/ \
+ http://www.derchris.eu/warsow/ \
+ http://warsow.hangy.de/ \
+ http://static.warsow.net/release/ \
+ http://rewq.de/scratch/wsw05/ \
+ http://weseo.de/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_sdk
DIST_SUBDIR= ${PORTNAME}
@@ -18,14 +21,13 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= A fast paced first person shooter game
LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
-RUN_DEPENDS= ${DATADIR}/basewsw/data0.pk3:${PORTSDIR}/games/warsow-data
+RUN_DEPENDS= ${DATADIR}/basewsw/data0_05.pk3:${PORTSDIR}/games/warsow-data
ONLY_FOR_ARCHS= i386 amd64
USE_GMAKE= yes
USE_ZIP= yes
-USE_DOS2UNIX= game/q_shared.h
-WRKSRC= ${WRKDIR}/${DISTNAME:S/sdk/src/}/source
+WRKSRC= ${WRKDIR}/source
ALL_TARGET= game
MAKE_ARGS= PTHREAD_LIBS="${PTHREAD_LIBS}"
RELEASEDIR= ${WRKSRC}/release
@@ -117,6 +119,9 @@ post-patch: .SILENT
# FreeBSD does not use stupid `64' suffix for 64-bit readdir(3)
${REINPLACE_CMD} -e 's/FILE64_SOURCE)/& || defined(__FreeBSD__)/' \
${WRKSRC}/unix/unix_fs.c
+# Adjust architecture names, get rid of ``freebsd_'' prefix
+ ${REINPLACE_CMD} -e 's/x86_64/amd64/ ; s/freebsd_//' \
+ ${WRKSRC}/gameshared/q_arch.h
do-install:
.for b in ${WSWBIN}
diff --git a/games/warsow/distinfo b/games/warsow/distinfo
index 1dfc4d51c59b..86ea789ccf48 100644
--- a/games/warsow/distinfo
+++ b/games/warsow/distinfo
@@ -1,3 +1,3 @@
-MD5 (warsow/warsow_0.42_sdk.zip) = 94c9bb2a48ac6f2687b38809e003f3b9
-SHA256 (warsow/warsow_0.42_sdk.zip) = 6c3c4cf161472646501c53672792e123787e5fef9f3dac60e70f1235525e9278
-SIZE (warsow/warsow_0.42_sdk.zip) = 16601262
+MD5 (warsow/warsow_0.5_sdk.zip) = acd0244435cc63967b0eb3468c21c454
+SHA256 (warsow/warsow_0.5_sdk.zip) = 35cc937b4b38659df803d84f6b3fd6e9d5a5480ecadb4b642d991b99e3401f05
+SIZE (warsow/warsow_0.5_sdk.zip) = 34213675
diff --git a/games/warsow/files/patch-Makefile b/games/warsow/files/patch-Makefile
index bf817c08763e..1df4f1a2be90 100644
--- a/games/warsow/files/patch-Makefile
+++ b/games/warsow/files/patch-Makefile
@@ -1,8 +1,8 @@
---- Makefile.orig 2006-06-08 22:44:02.000000000 +0200
-+++ Makefile 2008-04-11 13:18:40.000000000 +0200
-@@ -34,19 +34,12 @@
- CC=i586-mingw32msvc-gcc
- LD=i586-mingw32msvc-gcc
+--- Makefile.orig
++++ Makefile
+@@ -51,19 +51,12 @@
+ #CC=gcc
+ #LD=gcc
else
-CC?=gcc
-LD=gcc
@@ -23,7 +23,7 @@
SHARED_LIBRARY_EXTENSION=so
endif
-@@ -134,7 +127,7 @@
+@@ -161,7 +154,7 @@
LIB=lib
endif
@@ -32,25 +32,16 @@
LDFLAGS_DED=-lz $(shell curl-config --libs)
LDFLAGS_MODULE=-shared
LDFLAGS_TV_SERVER=-lz
-@@ -149,11 +142,7 @@
-
- # sdl
- ifeq ($(BUILD_SND_QF),YES)
--ifeq ($(OS),FreeBSD)
--SDL_CONFIG?=sdl11-config
--else
- SDL_CONFIG?=sdl-config
--endif
-
- CFLAGS_SDL=$(shell $(SDL_CONFIG) --cflags)
- LDFLAGS_QF=$(shell $(SDL_CONFIG) --libs) -lvorbisfile
-@@ -193,8 +182,7 @@
+@@ -217,10 +210,8 @@
######################################################################################################
# Helper functions
######################################################################################################
-DO_CC=echo " > Compiling $<" && \
- $(CC) $(CFLAGS_COMMON) -c $< -o $@
+-DO_CXX=echo " > Compiling (c++) $<" && \
+- $(CXX) $(CFLAGS_COMMON) $(CXXFLAGS_COMMON) -c $< -o $@
+DO_CC=$(CC) $(CFLAGS_COMMON) -c $< -o $@
++DO_CXX=$(CXX) $(CFLAGS_COMMON) $(CXXFLAGS_COMMON) -c $< -o $@
+
DO_CC_CLIENT=$(DO_CC) $(CFLAGS_CLIENT)
- DO_CC_DED=$(DO_CC) $(CFLAGS_DED)
diff --git a/games/warsow/files/patch-game+q_shared.h b/games/warsow/files/patch-game+q_shared.h
deleted file mode 100644
index f5d6e16df096..000000000000
--- a/games/warsow/files/patch-game+q_shared.h
+++ /dev/null
@@ -1,42 +0,0 @@
---- game/q_shared.h.orig 2008-07-24 05:38:24.000000000 +0700
-+++ game/q_shared.h 2008-07-24 05:41:08.000000000 +0700
-@@ -98,15 +98,15 @@
- #ifdef _M_IX86
- #if defined __FreeBSD__
- #define CPUSTRING "i386"
--#define ARCH "freebsd_i386"
-+#define ARCH "i386"
- #else
- #define CPUSTRING "x86"
- #define ARCH "x86"
- #endif
- #elif defined ( _M_AMD64 )
- #if defined __FreeBSD__
--#define CPUSTRING "x86_64"
--#define ARCH "freebsd_x86_64"
-+#define CPUSTRING "amd64"
-+#define ARCH "amd64"
- #else
- #define CPUSTRING "x64"
- #define ARCH "x64"
-@@ -162,17 +162,12 @@
- #endif
-
- #ifdef __i386__
--#if defined __FreeBSD__
--#define ARCH "freebsd_i386"
--#define CPUSTRING "i386"
--#else
- #define ARCH "i386"
- #define CPUSTRING "i386"
--#endif
--#elif defined ( __x86_64__ )
-+#elif defined ( __x86_64__ ) || defined( __amd64__ )
- #if defined __FreeBSD__
--#define ARCH "freebsd_x86_64"
--#define CPUSTRING "x86_64"
-+#define ARCH "amd64"
-+#define CPUSTRING "amd64"
- #else
- #define ARCH "x86_64"
- #define CPUSTRING "x86_64"