aboutsummaryrefslogtreecommitdiffstats
path: root/games/warzone/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-04-23 18:14:30 +0800
committeroliver <oliver@FreeBSD.org>2006-04-23 18:14:30 +0800
commita1afb15bc3ca23d864c38bb5aa46770398e443e0 (patch)
tree61d0b5cff39b644111399fd6d81cc02dadc4b0ed /games/warzone/Makefile
parentf85495f88f996a09638af8e00a215073a46b55ad (diff)
downloadfreebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.tar.gz
freebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.tar.zst
freebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.zip
update to openal 20060211 [1]
fix dependant ports [2] PR: ports/96172 [1] ports/95192 [2] Submitted by: maintainer [1] oliver [2] Approved by: maintainer
Diffstat (limited to 'games/warzone/Makefile')
-rw-r--r--games/warzone/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/warzone/Makefile b/games/warzone/Makefile
index f908871c370c..1f970e95ced2 100644
--- a/games/warzone/Makefile
+++ b/games/warzone/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
mad.2:${PORTSDIR}/audio/libmad \
ogg.5:${PORTSDIR}/audio/libogg \
openal.0:${PORTSDIR}/audio/openal \
- vorbis.3:${PORTSDIR}/audio/libvorbis
+ vorbis.3:${PORTSDIR}/audio/libvorbis \
+ alut.0:${PORTSDIR}/audio/freealut
USE_BZIP2= yes
USE_REINPLACE= yes
@@ -43,7 +44,9 @@ post-patch:
.for f in configure *.c *.h
@${FIND} ${WRKSRC} -type f -name "${f}" -print0 | \
${XARGS} -0 ${REINPLACE_CMD} -e \
- 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
+ 's|\(#include.*\)SDL/\(SDL.*\)|\1\2| ; \
+ s|-lopenal |&-lalut|g ; \
+ s|"-lalut|"-lopenal -lalut|'
.endfor
do-install: