aboutsummaryrefslogtreecommitdiffstats
path: root/games/wormux
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-06-15 02:25:59 +0800
committermakc <makc@FreeBSD.org>2010-06-15 02:25:59 +0800
commit01ae6692974ba58b92c2c8ff23c81c05b7922978 (patch)
tree81d724f7a68ef7898b8709cf6e3a9f49bfed33ff /games/wormux
parentf74ee2e39d2ece37dbc54bdc21c488ea06040428 (diff)
downloadfreebsd-ports-gnome-01ae6692974ba58b92c2c8ff23c81c05b7922978.tar.gz
freebsd-ports-gnome-01ae6692974ba58b92c2c8ff23c81c05b7922978.tar.zst
freebsd-ports-gnome-01ae6692974ba58b92c2c8ff23c81c05b7922978.zip
Add OPTIONS:
FRIBIDI - bi-directional unicode support SERVER - build the index and game servers PR: ports/147733 Submitted by: Demelier David <demelier.david at gmail.com>
Diffstat (limited to 'games/wormux')
-rw-r--r--games/wormux/Makefile20
-rw-r--r--games/wormux/pkg-plist2
2 files changed, 22 insertions, 0 deletions
diff --git a/games/wormux/Makefile b/games/wormux/Makefile
index 91dbac2963c0..88170ef8dea1 100644
--- a/games/wormux/Makefile
+++ b/games/wormux/Makefile
@@ -28,6 +28,12 @@ USE_DOS2UNIX= fixed_class.h
MANCOMPRESSED= no
MAN6= wormux.6
+OPTIONS+= NLS "Native Language Support via gettext utilities" on \
+ FRIBIDI "Enable bi-directional unicode support" off \
+ SERVER "Enable dedicated server" off
+
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/Makefile.in \
${WRKSRC}/src/Makefile.in
@@ -43,4 +49,18 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.if defined(WITH_SERVER)
+PLIST_SUB+= SERVER=""
+CONFIGURE_ARGS+= --enable-servers
+.else
+PLIST_SUB+= SERVER="@comment "
+.endif
+
+.if defined(WITH_FRIBIDI)
+LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+CONFIGURE_ARGS+= --enable-fribidi
+.else
+CONFIGURE_ARGS+= --disable-fribidi
+.endif
+
.include <bsd.port.mk>
diff --git a/games/wormux/pkg-plist b/games/wormux/pkg-plist
index a8c153e19e82..09b686026baf 100644
--- a/games/wormux/pkg-plist
+++ b/games/wormux/pkg-plist
@@ -1,5 +1,7 @@
bin/wormux
+%%SERVER%%bin/wormux-index-server
bin/wormux-list-games
+%%SERVER%%bin/wormux-server
share/applications/wormux.desktop
%%NLS%%share/locale/bg/LC_MESSAGES/wormux.mo
%%NLS%%share/locale/bs/LC_MESSAGES/wormux.mo