aboutsummaryrefslogtreecommitdiffstats
path: root/games/xbomb/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-08-16 14:06:40 +0800
committerkris <kris@FreeBSD.org>2000-08-16 14:06:40 +0800
commit1f8618d2ed396e3b643e335d5a5ab7de289f61ee (patch)
tree899c4b43a7dffbfa48fd98bba973a32b3dbf189f /games/xbomb/Makefile
parentfb631780885b5f74d8227a8b6ab8ca456100549c (diff)
downloadfreebsd-ports-gnome-1f8618d2ed396e3b643e335d5a5ab7de289f61ee.tar.gz
freebsd-ports-gnome-1f8618d2ed396e3b643e335d5a5ab7de289f61ee.tar.zst
freebsd-ports-gnome-1f8618d2ed396e3b643e335d5a5ab7de289f61ee.zip
Remove world-writable score files by making the game binary setgid games
and the score file root:games mode 664. Since the games group has (should have) no permissions other than to write to game data files, it doesn't really matter if this is "insecure" (lots of other things which are setgid games already are).
Diffstat (limited to 'games/xbomb/Makefile')
-rw-r--r--games/xbomb/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/xbomb/Makefile b/games/xbomb/Makefile
index d5a756ddadbf..1d8aa33ad1fc 100644
--- a/games/xbomb/Makefile
+++ b/games/xbomb/Makefile
@@ -21,6 +21,9 @@ post-install:
@${TOUCH} ${PREFIX}/lib/X11/xbomb/xbomb3.hi
@${TOUCH} ${PREFIX}/lib/X11/xbomb/xbomb4.hi
@${TOUCH} ${PREFIX}/lib/X11/xbomb/xbomb6.hi
- @${CHMOD} 666 ${PREFIX}/lib/X11/xbomb/xbomb?.hi
+ @${CHOWN} root:games ${PREFIX}/lib/X11/xbomb/xbomb?.hi
+ @${CHMOD} 664 ${PREFIX}/lib/X11/xbomb/xbomb?.hi
+ @${CHOWN} root:games ${PREFIX}/bin/xbomb
+ @${CHMOD} 2755 ${PREFIX}/bin/xbomb
.include <bsd.port.mk>