aboutsummaryrefslogtreecommitdiffstats
path: root/games/xemeraldia
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-03-25 12:30:54 +0800
committerSatoshi Asami <asami@FreeBSD.org>1995-03-25 12:30:54 +0800
commitb7bb39814db29f77a6ac0c8af5497ad2741bdeb0 (patch)
tree167a85931aef51b6d5875253a023a83d542ebf3e /games/xemeraldia
parent56d69001266589ad1a75ad7c95b43342bd716144 (diff)
downloadfreebsd-ports-gnome-b7bb39814db29f77a6ac0c8af5497ad2741bdeb0.tar.gz
freebsd-ports-gnome-b7bb39814db29f77a6ac0c8af5497ad2741bdeb0.tar.zst
freebsd-ports-gnome-b7bb39814db29f77a6ac0c8af5497ad2741bdeb0.zip
Don't uudecode if the .tar.gz file is already there.
Pointed-out by: Anthony Chan <yeehang@netcom.com>
Diffstat (limited to 'games/xemeraldia')
-rw-r--r--games/xemeraldia/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/xemeraldia/Makefile b/games/xemeraldia/Makefile
index 4f6ac5ec7afe..fbe18342ae5e 100644
--- a/games/xemeraldia/Makefile
+++ b/games/xemeraldia/Makefile
@@ -19,7 +19,10 @@ extract: fetch ${EXTRACT_COOKIE}
${EXTRACT_COOKIE}:
@${MAKE} ${.MAKEFLAGS} checksum pre-extract
@echo "===> Extracting for ${DISTNAME}"
- @(cd ${DISTDIR}; zcat ${DISTFILES} | uudecode)
+ @(cd ${DISTDIR}; \
+ if [ ! -f ${DISTNAME}.tar.gz ]; then \
+ zcat ${DISTFILES} | uudecode; \
+ fi)
@rm -rf ${WRKDIR}
@mkdir -p ${WRKDIR}
@(cd ${WRKDIR}; tar -xzf \