aboutsummaryrefslogtreecommitdiffstats
path: root/games/xmoto/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-05-22 22:31:42 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-05-22 22:31:42 +0800
commit21bf8c1b3e12b8ff939c0762ffa9448c0afccfeb (patch)
tree7e72aa5624ee2b8b7b25da4b212d4d9c86e456e4 /games/xmoto/Makefile
parent5e38db3ae5ca1771632507ba4d5f2aa852a6d871 (diff)
downloadfreebsd-ports-gnome-21bf8c1b3e12b8ff939c0762ffa9448c0afccfeb.tar.gz
freebsd-ports-gnome-21bf8c1b3e12b8ff939c0762ffa9448c0afccfeb.tar.zst
freebsd-ports-gnome-21bf8c1b3e12b8ff939c0762ffa9448c0afccfeb.zip
Update to 0.1.14
PR: 97509 Submitted by: Dmitry Marakasov <amdmi3@mail.ru> (maintainer)
Diffstat (limited to 'games/xmoto/Makefile')
-rw-r--r--games/xmoto/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index f64ea62eabbf..a2f2be782087 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmoto
-PORTVERSION= 0.1.12
+PORTVERSION= 0.1.14
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -36,11 +36,22 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= README ChangeLog
+OPTIONS= CURL "Online high-scores and new levels download support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CURL)
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/VCommon.h
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/image/tim_memory_crt.cpp
@${REINPLACE_CMD} -e 's|endian.h|sys/endian.h|' ${WRKSRC}/src/VCommon.h
@${REINPLACE_CMD} -e '/LIBS/ s|\(-lSDL_mixer\)|\1 `${SDL_CONFIG} --libs`|' ${WRKSRC}/configure
+.if !defined(WITH_CURL)
+ @${REINPLACE_CMD} -e 's|test $$ac_cv_lib_curl_curl_easy_init = yes|false|' ${WRKSRC}/configure
+.endif
.if !defined(NOPORTDOCS)
post-install:
@@ -50,4 +61,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>