aboutsummaryrefslogtreecommitdiffstats
path: root/games/xpacman
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2008-03-11 03:58:36 +0800
committerjoerg <joerg@FreeBSD.org>2008-03-11 03:58:36 +0800
commitf2a5569a1b219bf979ed08abba80d0ade9f3975c (patch)
tree0149f77133222a8f2bf6698ea169af496d94392c /games/xpacman
parent1cbfb64beb9885166d0e1763899adf6afd137342 (diff)
downloadfreebsd-ports-gnome-f2a5569a1b219bf979ed08abba80d0ade9f3975c.tar.gz
freebsd-ports-gnome-f2a5569a1b219bf979ed08abba80d0ade9f3975c.tar.zst
freebsd-ports-gnome-f2a5569a1b219bf979ed08abba80d0ade9f3975c.zip
Fix a logic error and an unitialized pointer that caused the game to
blow up when malloc_options were set to AJ.
Diffstat (limited to 'games/xpacman')
-rw-r--r--games/xpacman/Makefile2
-rw-r--r--games/xpacman/files/patch-board.cc19
-rw-r--r--games/xpacman/pkg-descr2
3 files changed, 21 insertions, 2 deletions
diff --git a/games/xpacman/Makefile b/games/xpacman/Makefile
index 3b6db685614f..801045ede5ea 100644
--- a/games/xpacman/Makefile
+++ b/games/xpacman/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xpacman
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ftp://ftp.nvg.unit.no/pub/pacman/
DISTNAME= pacman10
diff --git a/games/xpacman/files/patch-board.cc b/games/xpacman/files/patch-board.cc
new file mode 100644
index 000000000000..65c431e4a272
--- /dev/null
+++ b/games/xpacman/files/patch-board.cc
@@ -0,0 +1,19 @@
+--- board.cc.orig Tue Jul 18 11:03:22 1995
++++ board.cc Mon Mar 10 20:52:04 2008
+@@ -119,7 +119,7 @@
+ oldtemp=oldlist;
+ while (oldtemp) { //delete elements in the now previous sprite list
+ oldnext=oldtemp->next;
+- delete oldnext;
++ delete oldtemp;
+ oldtemp=oldnext;
+ }
+ if (zero && oldlist) { //personal thingie used for debug, not useful
+@@ -157,6 +157,7 @@
+ void Board::sprite(DynamicElement *g) { //let dynamicelement be a sprite
+ liststruct *temp=0,*last=0; //resets to null
+ liststruct *ny=new liststruct; //get a new liststruct
++ ny->next = 0;
+ ny->g=g; //get pointer to element
+ ny->gid=g->getgid(); //get it's grafical id
+ g->getxy(&ny->x,&ny->y); //and coordinates
diff --git a/games/xpacman/pkg-descr b/games/xpacman/pkg-descr
index a59f9f981de7..4079cca872d3 100644
--- a/games/xpacman/pkg-descr
+++ b/games/xpacman/pkg-descr
@@ -7,4 +7,4 @@ is also bonus available, for a limited amount of time. An
X gives just points, but a little pacman gives an extra
life.
-Author of this implementation: Roar Thronęs, roart@nvg.unit.no
+Author of this implementation: Roar Thronaes, roart@nvg.unit.no