aboutsummaryrefslogtreecommitdiffstats
path: root/games/xpanex
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-15 05:25:36 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-15 05:25:36 +0800
commit2e4eb58af14aed84e6c51d82c70d2601fe8ee78f (patch)
treebb41f60fb70a718c9b19b8db8cc14b5f523604bd /games/xpanex
parent23c05b64b35695a47b8704c0ee141324e33cba4f (diff)
downloadfreebsd-ports-gnome-2e4eb58af14aed84e6c51d82c70d2601fe8ee78f.tar.gz
freebsd-ports-gnome-2e4eb58af14aed84e6c51d82c70d2601fe8ee78f.tar.zst
freebsd-ports-gnome-2e4eb58af14aed84e6c51d82c70d2601fe8ee78f.zip
- Add stage support
- Use PLIST_FILES instead of pkg-plist
Diffstat (limited to 'games/xpanex')
-rw-r--r--games/xpanex/Makefile14
-rw-r--r--games/xpanex/pkg-plist2
2 files changed, 7 insertions, 9 deletions
diff --git a/games/xpanex/Makefile b/games/xpanex/Makefile
index 82019bf31010..c553c8f55cdf 100644
--- a/games/xpanex/Makefile
+++ b/games/xpanex/Makefile
@@ -14,14 +14,14 @@ COMMENT= Panex puzzle for X Window System
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= imake
USE_XORG= x11 xext xt sm ice
-MAN1= xpanex.1
-MANCOMPRESSED= no
-XFREE86_HTML_MAN= no
-NO_STAGE= yes
+PLIST_FILES= bin/xpanex \
+ man/man1/xpanex.1.gz \
+ lib/X11/app-defaults/Panex
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xpanex ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/Panex.ad ${PREFIX}/lib/X11/app-defaults/Panex
- ${INSTALL_MAN} ${WRKSRC}/xpanex.man ${MANPREFIX}/man/man1/xpanex.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/xpanex ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/Panex.ad ${STAGEDIR}${PREFIX}/lib/X11/app-defaults/Panex
+ ${INSTALL_MAN} ${WRKSRC}/xpanex.man ${STAGEDIR}${MANPREFIX}/man/man1/xpanex.1
.include <bsd.port.mk>
diff --git a/games/xpanex/pkg-plist b/games/xpanex/pkg-plist
deleted file mode 100644
index 467f556476bb..000000000000
--- a/games/xpanex/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/xpanex
-lib/X11/app-defaults/Panex