aboutsummaryrefslogtreecommitdiffstats
path: root/games/xpilot-ng-server
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-15 09:17:05 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-15 09:17:05 +0800
commit05e2b17b18c2731496a1adaaaecc62ec4b1b26cf (patch)
tree4d357698b9275525d196d78d4de9a16e985f2b25 /games/xpilot-ng-server
parentb4494eed6a4ee6b558efad4e353be6108881aaae (diff)
downloadfreebsd-ports-gnome-05e2b17b18c2731496a1adaaaecc62ec4b1b26cf.tar.gz
freebsd-ports-gnome-05e2b17b18c2731496a1adaaaecc62ec4b1b26cf.tar.zst
freebsd-ports-gnome-05e2b17b18c2731496a1adaaaecc62ec4b1b26cf.zip
- Split into -client and -server
- Update to 4.7.1 PR: ports/66762 Submitted by: myself
Diffstat (limited to 'games/xpilot-ng-server')
-rw-r--r--games/xpilot-ng-server/Makefile105
-rw-r--r--games/xpilot-ng-server/distinfo4
-rw-r--r--games/xpilot-ng-server/pkg-descr.client (renamed from games/xpilot-ng-server/pkg-descr)2
-rw-r--r--games/xpilot-ng-server/pkg-descr.server18
-rw-r--r--games/xpilot-ng-server/pkg-plist.client (renamed from games/xpilot-ng-server/pkg-plist)50
-rw-r--r--games/xpilot-ng-server/pkg-plist.server21
6 files changed, 162 insertions, 38 deletions
diff --git a/games/xpilot-ng-server/Makefile b/games/xpilot-ng-server/Makefile
index 7a0e61aa7f5e..e3aa0948eb07 100644
--- a/games/xpilot-ng-server/Makefile
+++ b/games/xpilot-ng-server/Makefile
@@ -5,45 +5,102 @@
# $FreeBSD$
#
-PORTNAME= xpilot-ng
-PORTVERSION= 4.6.4
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTNAME= xpilot-ng
+PORTVERSION= 4.7.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xpilot
+PKGNAMESUFFIX?= -server
-MAINTAINER= jylefort@FreeBSD.org
-COMMENT= An enhanced version of XPilot
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT?= An enhanced version of XPilot (server program)
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
-USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-MAN6= xpilot-ng-replay.6 \
- xpilot-ng-sdl.6 \
- xpilot-ng-server.6 \
- xpilot-ng-x11.6
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --program-prefix=""
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --program-prefix=""
-OPTIONS= SDL "SDL/OpenGL client" on
+UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
+
+PKGFILESUFFIX= ${PKGNAMESUFFIX:S/-/./}
+DESCR= ${PKGDIR}/pkg-descr${PKGFILESUFFIX}
+PLIST= ${PKGDIR}/pkg-plist${PKGFILESUFFIX}
+
+.if ${PKGNAMESUFFIX} == "-server"
+MAN6= xpilot-ng-server.6
+
+CONFIGURE_ARGS+=--disable-replay \
+ --disable-xp-mapedit \
+ --disable-x11-client \
+ --disable-sdl-client
+.else # client
+MAN6= xpilot-ng-replay.6 \
+ xpilot-ng-x11.6 \
+ xpilot-ng-xp-mapedit.6
+
+USE_X_PREFIX= yes
+
+CPPFLAGS+= -I${X11BASE}/include
+LDFLAGS+= -I${X11BASE}/include
+
+OPTIONS= SDL "SDL/OpenGL client" on \
+ SOUND "Sound" off
+.endif
.include <bsd.port.pre.mk>
+.if ${PKGNAMESUFFIX} == "-server"
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|xpilot-ng-sdl\.man||; \
+ s|xpilot-ng-x11\.man||; \
+ s|xpilot-ng-replay\.man||; \
+ s|xpilot-ng-xp-mapedit\.man||' ${WRKSRC}/doc/man/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's| fonts||; s| textures||; s| shipshapes\.txt||' \
+ ${WRKSRC}/lib/Makefile.in
+.else # client
.if defined(WITH_SDL)
-USE_SDL= image sdl ttf
-CONFIGURE_ARGS+= --enable-sdl-client
-PLIST_SUB+= WITH_SDL=""
-USE_GCC= 3.2
+USE_SDL= image sdl ttf
+USE_GL= yes
+PLIST_SUB+= SDL=""
+USE_GCC= 3.4+
+MAN6+= xpilot-ng-sdl.6
+.else
+CONFIGURE_ARGS+=--disable-sdl-client
+PLIST_SUB+= SDL="@comment "
+.endif
+
+.if defined(WITH_SOUND)
+LIB_DEPENDS+= openal:${PORTSDIR}/audio/openal
+CONFIGURE_ARGS+=--enable-sound
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+PLIST_SUB+= SOUND=""
.else
-PLIST_SUB+= WITH_SDL="@comment "
+PLIST_SUB+= SOUND="@comment "
.endif
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's,#include "SDL/,#include "SDL11/,g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|mapconvert\.py||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|xpilot-ng-server\.man||' \
+ ${WRKSRC}/doc/man/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's| maps||; s|defaults\.txt password\.txt robots\.txt||' \
+ ${WRKSRC}/lib/Makefile.in
+ @${REINPLACE_CMD} -e 's| server||' ${WRKSRC}/src/Makefile.in
+.if defined(WITHOUT_SDL)
+ @${REINPLACE_CMD} -e 's|xpilot-ng-sdl\.man||' \
+ ${WRKSRC}/doc/man/Makefile.in
+.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/games/xpilot-ng-server/distinfo b/games/xpilot-ng-server/distinfo
index 4288f3b0ffb5..2bcb66ade86c 100644
--- a/games/xpilot-ng-server/distinfo
+++ b/games/xpilot-ng-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (xpilot-ng-4.6.4.tar.gz) = 23e4495c755251f72d5dd525e8dfa420
-SIZE (xpilot-ng-4.6.4.tar.gz) = 1662416
+MD5 (xpilot-ng-4.7.1.tar.gz) = c3ea1f7da347c15c9ecde75b695e82c8
+SIZE (xpilot-ng-4.7.1.tar.gz) = 2817377
diff --git a/games/xpilot-ng-server/pkg-descr b/games/xpilot-ng-server/pkg-descr.client
index 8501ea876a9f..f05c1e8dfcf2 100644
--- a/games/xpilot-ng-server/pkg-descr
+++ b/games/xpilot-ng-server/pkg-descr.client
@@ -10,6 +10,8 @@ The aim of the game is to score points and to have a lot of fun.
See http://xpilot.sourceforge.net/about.html for differences between
standard XPilot and this version.
+This port contains the client program.
+
WWW: http://xpilot.sourceforge.net/
- Jean-Yves Lefort
diff --git a/games/xpilot-ng-server/pkg-descr.server b/games/xpilot-ng-server/pkg-descr.server
new file mode 100644
index 000000000000..601d3ed893d7
--- /dev/null
+++ b/games/xpilot-ng-server/pkg-descr.server
@@ -0,0 +1,18 @@
+XPilot is a multi-player tactical manouvring game for X and Unix workstations.
+Players have a fighter which they move along in an artificial world
+and shoot each other using various kinds of weapons like bullets, mines,
+smart missiles, heat seekers and so on. It is a fast paced game with
+a lot of tactics. There are also robots flying around shooting players
+and other robots. Players can pickup special bonuses to improve the
+possibilities of their ship like more engine power or special weapons.
+The aim of the game is to score points and to have a lot of fun.
+
+See http://xpilot.sourceforge.net/about.html for differences between
+standard XPilot and this version.
+
+This port contains the server program.
+
+WWW: http://xpilot.sourceforge.net/
+
+- Jean-Yves Lefort
+jylefort@FreeBSD.org
diff --git a/games/xpilot-ng-server/pkg-plist b/games/xpilot-ng-server/pkg-plist.client
index f9b1960e307e..199f12513803 100644
--- a/games/xpilot-ng-server/pkg-plist
+++ b/games/xpilot-ng-server/pkg-plist.client
@@ -1,18 +1,40 @@
bin/xpilot-ng-replay
-%%WITH_SDL%%bin/xpilot-ng-sdl
-bin/xpilot-ng-server
+%%SDL%%bin/xpilot-ng-sdl
bin/xpilot-ng-x11
-share/xpilot-ng/defaults.txt
+bin/xpilot-ng-xp-mapedit
share/xpilot-ng/fonts/ConsoleFont.bmp
share/xpilot-ng/fonts/FreeSansBoldOblique.ttf
share/xpilot-ng/fonts/VeraMoBd.ttf
-share/xpilot-ng/mapconvert.py
-share/xpilot-ng/maps/polybloods.xp2
-share/xpilot-ng/maps/sadistic_bastard_v2.xp2
-share/xpilot-ng/maps/teamcup.xp
-share/xpilot-ng/password.txt
-share/xpilot-ng/robots.txt
-share/xpilot-ng/sounds.txt
+share/xpilot-ng/shipshapes.txt
+%%SOUND%%share/xpilot-ng/sound/Drop01.wav
+%%SOUND%%share/xpilot-ng/sound/MusicaDefault.wav
+%%SOUND%%share/xpilot-ng/sound/RobotzDefault.wav
+%%SOUND%%share/xpilot-ng/sound/RobotzQuestion.wav
+%%SOUND%%share/xpilot-ng/sound/UtopiaClose.wav
+%%SOUND%%share/xpilot-ng/sound/bfire.wav
+%%SOUND%%share/xpilot-ng/sound/bloop.wav
+%%SOUND%%share/xpilot-ng/sound/buzzer.wav
+%%SOUND%%share/xpilot-ng/sound/confirm.wav
+%%SOUND%%share/xpilot-ng/sound/corkpop.wav
+%%SOUND%%share/xpilot-ng/sound/done.wav
+%%SOUND%%share/xpilot-ng/sound/doorchimes.wav
+%%SOUND%%share/xpilot-ng/sound/explo2.wav
+%%SOUND%%share/xpilot-ng/sound/failure.wav
+%%SOUND%%share/xpilot-ng/sound/finished.wav
+%%SOUND%%share/xpilot-ng/sound/flare.wav
+%%SOUND%%share/xpilot-ng/sound/gundead.wav
+%%SOUND%%share/xpilot-ng/sound/launch1.18.wav
+%%SOUND%%share/xpilot-ng/sound/lboom.wav
+%%SOUND%%share/xpilot-ng/sound/magic.wav
+%%SOUND%%share/xpilot-ng/sound/popclick.wav
+%%SOUND%%share/xpilot-ng/sound/sboom.wav
+%%SOUND%%share/xpilot-ng/sound/sbounce.wav
+%%SOUND%%share/xpilot-ng/sound/sounds.txt
+%%SOUND%%share/xpilot-ng/sound/sstart.wav
+%%SOUND%%share/xpilot-ng/sound/success.wav
+%%SOUND%%share/xpilot-ng/sound/thrust.wav
+%%SOUND%%share/xpilot-ng/sound/waiting.wav
+%%SOUND%%share/xpilot-ng/sound/zap.wav
share/xpilot-ng/textures/acwise_grav.ppm
share/xpilot-ng/textures/allitems.ppm
share/xpilot-ng/textures/asteroid.ppm
@@ -40,6 +62,7 @@ share/xpilot-ng/textures/fuel2.ppm
share/xpilot-ng/textures/fuelcell.ppm
share/xpilot-ng/textures/holder1.ppm
share/xpilot-ng/textures/holder2.ppm
+share/xpilot-ng/textures/huditems.ppm
share/xpilot-ng/textures/logo.ppm
share/xpilot-ng/textures/metabtndown.png
share/xpilot-ng/textures/metabtnup.png
@@ -61,10 +84,13 @@ share/xpilot-ng/textures/sdlmetabg.png
share/xpilot-ng/textures/shield.ppm
share/xpilot-ng/textures/ship.ppm
share/xpilot-ng/textures/ship_blue.ppm
+share/xpilot-ng/textures/ship_enemy.ppm
+share/xpilot-ng/textures/ship_friend.ppm
share/xpilot-ng/textures/ship_red.ppm
share/xpilot-ng/textures/ship_red2.ppm
share/xpilot-ng/textures/ship_red3.ppm
share/xpilot-ng/textures/sparks.ppm
+share/xpilot-ng/textures/target.ppm
share/xpilot-ng/textures/volcanic.ppm
share/xpilot-ng/textures/wall_bottom.ppm
share/xpilot-ng/textures/wall_dl.ppm
@@ -78,7 +104,7 @@ share/xpilot-ng/textures/wall_ull.ppm
share/xpilot-ng/textures/wall_ur.ppm
share/xpilot-ng/textures/wall_url.ppm
share/xpilot-ng/textures/wormhole.ppm
-@dirrm share/xpilot-ng/textures
-@dirrm share/xpilot-ng/maps
@dirrm share/xpilot-ng/fonts
+%%SOUND%%@dirrm share/xpilot-ng/sound
+@dirrm share/xpilot-ng/textures
@dirrm share/xpilot-ng
diff --git a/games/xpilot-ng-server/pkg-plist.server b/games/xpilot-ng-server/pkg-plist.server
new file mode 100644
index 000000000000..f4bfe99a1950
--- /dev/null
+++ b/games/xpilot-ng-server/pkg-plist.server
@@ -0,0 +1,21 @@
+bin/xpilot-ng-server
+share/xpilot-ng/defaults.txt
+share/xpilot-ng/mapconvert.py
+share/xpilot-ng/maps/blood-music.xp2
+share/xpilot-ng/maps/circle2.xp2
+share/xpilot-ng/maps/dodgers-legacy.xp2
+share/xpilot-ng/maps/dodgers-robots.xp2
+share/xpilot-ng/maps/dragon-1.0.xp2
+share/xpilot-ng/maps/ndh.xp2
+share/xpilot-ng/maps/ndh.xpd
+share/xpilot-ng/maps/polybloods.xp2
+share/xpilot-ng/maps/polybloods7.xp2
+share/xpilot-ng/maps/sadistic_bastard_v2.xp2
+share/xpilot-ng/maps/spaceball-0.1.xp2
+share/xpilot-ng/maps/spaceball-0.2.xp2
+share/xpilot-ng/maps/teamcup.xp
+share/xpilot-ng/maps/tourmination.xp2
+share/xpilot-ng/password.txt
+share/xpilot-ng/robots.txt
+@dirrm share/xpilot-ng/maps
+@dirrm share/xpilot-ng