aboutsummaryrefslogtreecommitdiffstats
path: root/games/yace/Makefile
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2008-01-30 11:58:10 +0800
committeralepulver <alepulver@FreeBSD.org>2008-01-30 11:58:10 +0800
commitbc7130df382151f8d0cd1b763a3dd4053a188cf6 (patch)
tree35f1377feed2c601b83b7ae270743df11213d354 /games/yace/Makefile
parent588cabf48e537939e29fc0e9d3394ae42241e571 (diff)
downloadfreebsd-ports-gnome-bc7130df382151f8d0cd1b763a3dd4053a188cf6.tar.gz
freebsd-ports-gnome-bc7130df382151f8d0cd1b763a3dd4053a188cf6.tar.zst
freebsd-ports-gnome-bc7130df382151f8d0cd1b763a3dd4053a188cf6.zip
Here you can find Yace, which is a program that automatically creates
corewar-warriors, using a genetic algorithm. Yace was a modified version of ga_war.c, another corewar evolver (many thanks to Jason Boer), but in the latest release there is not much code left from ga_war. I also want to thank M Joonas Pihlaja for his Corewar Simulator exhaust, which is released under the GPL. WWW: http://corewar.co.uk/ankerl/yace.htm
Diffstat (limited to 'games/yace/Makefile')
-rw-r--r--games/yace/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/yace/Makefile b/games/yace/Makefile
new file mode 100644
index 000000000000..7f12559e6ff1
--- /dev/null
+++ b/games/yace/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: yace
+# Date created: 2008-01-15
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= yace
+PORTVERSION= 1.2
+CATEGORIES= games
+MASTER_SITES= http://corewar.co.uk/ankerl/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Yet Another Corewars Evolver
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+NO_WRKSUBDIR= yes
+BUILD_WRKSRC= ${WRKDIR}/src
+MAKEFILE= makefile
+ALL_TARGET= #
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|CCFLAGS =|& ${CFLAGS}|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/bin && ${CP} -r bench testset yace.cfg ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>