aboutsummaryrefslogtreecommitdiffstats
path: root/games/yahtzee
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-09-09 19:03:36 +0800
committerkris <kris@FreeBSD.org>2000-09-09 19:03:36 +0800
commit744786352dc2de46a1fa181782d8e416248b2ccb (patch)
treea2ec862b748aa3c887da15ca3950598a1a309a19 /games/yahtzee
parentc5f336e0c40f12a3cae3c6fef534cfbb5f5ed60d (diff)
downloadfreebsd-ports-gnome-744786352dc2de46a1fa181782d8e416248b2ccb.tar.gz
freebsd-ports-gnome-744786352dc2de46a1fa181782d8e416248b2ccb.tar.zst
freebsd-ports-gnome-744786352dc2de46a1fa181782d8e416248b2ccb.zip
Install setgid games
Diffstat (limited to 'games/yahtzee')
-rw-r--r--games/yahtzee/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/yahtzee/Makefile b/games/yahtzee/Makefile
index 26cf6e0207ce..dbeffb2ef690 100644
--- a/games/yahtzee/Makefile
+++ b/games/yahtzee/Makefile
@@ -20,9 +20,9 @@ WRKSRC= ${WRKDIR}/yahtzee
# Distribution does not include an install target. So here it is.
#
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/yahtzee ${PREFIX}/bin/
- ${MKDIR} -m 0777 ${PREFIX}/lib/yahtzee/
- ${INSTALL_DATA} -m 0777 /dev/null ${PREFIX}/lib/yahtzee/yahtzee.sco
+ ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/yahtzee ${PREFIX}/bin/
+ ${MKDIR} -m 0755 ${PREFIX}/lib/yahtzee/
+ ${INSTALL_DATA} -m 0664 -o root -g games /dev/null ${PREFIX}/lib/yahtzee/yahtzee.sco
.include <bsd.port.mk>