aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-11 23:31:46 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-11 23:31:46 +0800
commit56dc32204bad654a33f748f15525ae2478dda76c (patch)
tree3937ab3f9e452769dfc3da529bc9b040b4183bc3 /games
parent169df2917434face98111a403e13db5d03f78444 (diff)
downloadfreebsd-ports-gnome-56dc32204bad654a33f748f15525ae2478dda76c.tar.gz
freebsd-ports-gnome-56dc32204bad654a33f748f15525ae2478dda76c.tar.zst
freebsd-ports-gnome-56dc32204bad654a33f748f15525ae2478dda76c.zip
Use USE_REINPLACE.
Diffstat (limited to 'games')
-rw-r--r--games/atomix/Makefile9
-rw-r--r--games/bombermaze/Makefile9
2 files changed, 10 insertions, 8 deletions
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index 2b72b4855221..72176a1441eb 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -14,15 +14,16 @@ MAINTAINER= gnome@FreeBSD.org
USE_X_PREFIX= yes
USE_GNOME= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>
diff --git a/games/bombermaze/Makefile b/games/bombermaze/Makefile
index 61135f12babc..cb8a2ef933d4 100644
--- a/games/bombermaze/Makefile
+++ b/games/bombermaze/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -23,10 +24,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS+= -fpermissive
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>
omms?id=ef125b2d6b642aa4397d22b05b3dc0b30e322c23'>Set {WANT,USE}_GNOME correctly to make these ports compatible with the newmarcus2004-02-041-0/+2 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-0427-2/+27 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-1/+1 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-044-8/+9 * Fix build on AMD64arved2004-01-311-1/+1 * Should have read all my mail before committing.pav2004-01-291-1/+2 * - Update MASTER_SITESpav2004-01-291-1/+1 * SIZEify.trevor2004-01-2916-0/+16 * - Update to 0.6.4.1pav2004-01-272-3/+3 * Upgrade to version 2.5jmz2004-01-243-15/+2 * Now gettext 0.12.1 is gettext-old.trevor2004-01-244-4/+4 * Grig is a graphical front-end to the Ham Radio librariespav2004-01-235-0/+50 * Gpredict is a satellite tracking and prediction applicationpav2004-01-235-0/+87 * - Update to 2.0pav2004-01-224-5/+15 * Use the new ghostscript options.marcus2004-01-211-6/+1 * A better fix for the buffer overflow problem.jmz2004-01-202-2/+2 * - Update to 0.92.0, now with FreeBSD Bluetooth stack supportpav2004-01-144-6/+6 * Fix a buffer overflow problem.jmz2004-01-132-1/+2 * Reset maintainer from me@FreeBSD.org to ports@FreeBSD.org. Apparentlylinimon2004-01-121-1/+1 * update to 4.1.8mharo2004-01-112-2/+2 * Nitpicks for the comms/qpage portedwin2004-01-104-0/+50 * - Update to 0.5.8 [1]sergei2004-01-096-79/+15 * Add port for py-lirc 0.0.4,perky2004-01-075-0/+38 * The port did not build on many systems due to conflicting and missinglinimon2003-12-297-8/+78 * Fix build on 5.x.linimon2003-12-293-7/+49 * Add p5-Image-Size to RUN_DEPENDS.linimon2003-12-291-1/+2 * - Update to 0.91.0pav2003-12-266-16/+6 * - Restore Date created: and Whom: lines in the port Makefile headersergei2003-12-211-2/+2 * add working MASTER_SITESmharo2003-12-171-1/+3 * - Update to 0.5.7pav2003-12-173-23/+3 * - Fix build when older version is already installed. This will preferpav2003-12-161-1/+1 * - Fix INDEX.pav2003-12-142-2/+2 * Add gammu, a command-line program to communicate with Nokia cell phonespav2003-12-1419-0/+505 * - Use native threading librarypav2003-12-131-5/+4 * Add comms/qtpcr, software that controls the ICOM PCR-1000 Receiver.linimon2003-12-125-0/+64 * Upgrade to 8.0.9 (bugfix).kuriyama2003-12-112-3/+2 * Clean up historical baggage, and move the old local distfiles thatjoerg2003-12-101-1/+1 * Mark as broken on 5.x. Informed maintainer.linimon2003-12-081-1/+7 * Mark as broken on 5.x. Maintainer's address currently bounces.linimon2003-12-071-0/+4 * Per redirect response when sending mail to maintainer, update maintainer'slinimon2003-12-071-1/+1 * Make the sample config file correct for FreeBSD.obrien2003-12-072-0/+17 * Add py-bulksms, python client for BulkSMS.co.uk's HTTP API for sendingpav2003-12-065-0/+56 * Add hamfax, a Qt/X11 application for sending and receiving facsimilespav2003-12-067-0/+64 * Upgrade to 8.0.8.kuriyama2003-12-052-2/+2 * - Update to 0.5.6pav2003-12-059-46/+208 * - Fix MASTER_SITESdinoex2003-12-041-2/+1 * - AMD64 has no APMarved2003-11-261-3/+3 * Mark as broken on 5.x. The assumptions that the Makefiles make here,linimon2003-11-221-1/+7 * Change BROKEN to IGNORE in the case of configurations that will neverlinimon2003-11-221-1/+1 * - Fix pkg-plist vodafone_autralia -> vodafone_australiakrion2003-11-212-6/+13 * Reset unreachable MAINTAINERs to ports@FreeBSD.orgeik2003-11-201-1/+1 * Upgrade to 8.0.6.kuriyama2003-11-192-2/+2 * Fix build process on sparc64 and alpha systems.osa2003-11-182-4/+34 * - take maintainershipdinoex2003-11-181-1/+1 * unPERLify by using REINPLACE_CMD where appropriate.marcus2003-11-162-9/+11 * Fix build if bison is installed.fjoe2003-11-141-3/+11 * Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.trevor2003-11-133-4/+4 * Update to 2.0perky2003-11-102-2/+2 * Add sites to fetch distfile from.cy2003-11-091-1/+3 * As announced on Aug 7, remove this broken port.kris2003-11-088-330/+0 * Reset maintainer to ports@FreeBSD.org. Requested by: kris.linimon2003-11-031-1/+1 * Reset maintainer of ports owned by inactive committers who were just retired.kris2003-11-031-1/+1 * Fix build on non-intel archs.osa2003-11-031-3/+20 * ports with possibly unreachable MAINTAINERsedwin2003-11-021-1/+1 * Upgrade to 8.0.5 (minor bugfixes).kuriyama2003-11-012-2/+2 * Per distfile survey, remove old mastersites. All I could find onlinimon2003-10-261-2/+4 * Per distfile survey, remove mastersite that expired in October 2002.linimon2003-10-261-1/+2 * Update to 8.0.4.kuriyama2003-10-255-24/+40 * utilize SITE_PERLijliao2003-10-243-8/+6 * Cosmetic fix: use %%DOCSDIR%% macro.osa2003-10-2213-89/+89 * Unbreak build by use WANT_AUTOMAKE_VER=15.osa2003-10-211-1/+1 * Pass gnokii maintainership to ports@. I only passively use gnokii for SMSanders2003-10-201-1/+1 * Before committing the previous BROKEN changes I carefully checked the statuskris2003-10-161-7/+1 * BROKEN on 5.x: does not compilekris2003-10-161-1/+7 * Unbreak port by adding dependency on autoconf.edwin2003-10-131-2/+1 * BROKEN: Broken pkg-plistkris2003-10-131-0/+2 * Add USE_XLIB to the ports Makefileedwin2003-10-131-0/+1 * unbreak build on CURRENToliver2003-10-122-0/+12 * - use DOCSDIRdinoex2003-10-121-5/+5 * New port for libirman 0.4.2edwin2003-10-108-0/+82 * new port: comms/gscmxx 0.4.1 - gtk-frontend for scmxxedwin2003-10-085-0/+78 * New port: comms/lirc: Linux Infared Remote Controledwin2003-10-0610-0/+237 * Add garmin-utils 1.93, utilities for Garmin GPS receivers.oliver2003-10-065-0/+29 * Fix the -pthread problem in case the option gets removed again. Thiswill2003-10-042-3/+2 * - dependency update: intl.4 -> intl.5oliver2003-10-042-2/+4 * IA64s do not have apm.arved2003-09-301-2/+2 * Fix exit status passing in vgetty for external shells.jmz2003-09-292-1/+31 * javax.comm ports should use USE_JAVAedwin2003-09-294-12/+17 * lrz in lrzsz-0.12.20(comms/lrzsz) sets invalid timestampedwin2003-09-292-0/+16 * [Port fix] comms/hylafax 4.1.7 (bin/faxrcvd)edwin2003-09-292-1/+14 * Update to 0.20perky2003-09-272-2/+2 * ECHO -> ECHO_MSGedwin2003-09-272-4/+4 * Fix build on current by adjusting includes to use dev/pci/... instead ofjhb2003-09-261-13/+32 * Update to -> 1.1.1mich2003-09-253-6/+7 * - Update to version 0.6.4krion2003-09-243-15/+15 * - Fix build package and honor PREFIXkrion2003-09-232-0/+21 * Upgrade to Qt 3.2.1 / KDE 3.1.4. See x11/kde3/Makefile rev 1.64 for details.will2003-09-181-1/+1 * Chase libintl shlib version number.adamw2003-09-161-1/+1 * Convert spaces to tabs. This should fix INDEX build.erwin2003-09-091-6/+6 * [new port] TiLP: TI calculator link programedwin2003-09-0810-0/+267 * cleanup portlint warnings.edwin2003-09-081-3/+3 * [new port] libticables: TI calculator link cablesedwin2003-09-086-0/+81 * Make the tty locking compatible to the FreeBSD convention (10 digitsjoerg2003-09-072-2/+11 * Mark IGNORE for perl < 5.6.xerwin2003-09-051-1/+7 * Remove stdio buffering even when not on a tty or pty: this preventspb2003-09-042-1/+12 * make port more localbase cleanedwin2003-09-041-2/+3 * Resolve a build error that recently became apparent where thisjoerg2003-09-012-6/+1625 * [PATCH] comms/tkhylafax: enable choose of ghostscript interpreteredwin2003-08-311-1/+7 * Bump the PORTREVISION for the ports directly affected by the gettext upgrade.marcus2003-08-272-0/+2 * o Upgrade to 7.2.7.kuriyama2003-08-255-29/+14 * Chase the libintl.so shared lib version.marcus2003-08-252-2/+2 * maintenance update to 2.0.8naddy2003-08-232-2/+2 * o Main modificationnork2003-08-191-1/+2 * fix the "duplicated post-patch" problem.leeym2003-08-171-12/+1 * Updates comms/hylafax 4.1.6 to 4.1.7.leeym2003-08-163-4/+9 * Let be hohest: I really don't have a time now to properly maintain allsobomax2003-07-292-2/+2 * Update KDE to the latest official release, KDE 3.1.3lofi2003-07-294-1/+11 * Add kallers, A KDE applet that shows caller ID informationarved2003-07-285-0/+47 * Add Device::Modem, a Perl module to talk to AT compliant devices viaanders2003-07-235-0/+49 * Update to 2.1.anders2003-07-236-119/+106 * Unbreak for GCC 3.3 by converting to stdarg.h and eliminatingkan2003-07-182-0/+63 * Fix build with gcc 3.3kris2003-07-181-0/+10 * Bump PORTREVISION due to previous fix.pb2003-07-161-0/+1 * Patch to fix illegal post-free() access (causes crash on -current).pb2003-07-161-0/+22 * get rid of libgnugetopt dependency for -CURRENT,sf2003-07-141-2/+3 * o Change library name from libgd to libgd1.nork2003-07-121-1/+1 * The sparc64 package machines need to have /dev/tty[ab] added to thensayer2003-07-111-1/+1 * Update to version 1.5.5.bsd2003-07-10