aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-13 22:45:08 +0800
committertrevor <trevor@FreeBSD.org>2003-11-13 22:45:08 +0800
commit98d7950e05980253d33259a6aafcd5e3b6547fdb (patch)
tree1cbd7ce2d9411420b33e9f045481bd24f68ef920 /comms
parenta959d36850b787f6723176962c2985587b2936cb (diff)
downloadfreebsd-ports-graphics-98d7950e05980253d33259a6aafcd5e3b6547fdb.tar.gz
freebsd-ports-graphics-98d7950e05980253d33259a6aafcd5e3b6547fdb.tar.zst
freebsd-ports-graphics-98d7950e05980253d33259a6aafcd5e3b6547fdb.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Diffstat (limited to 'comms')
-rw-r--r--comms/ghfaxviewer/Makefile2
-rw-r--r--comms/tkscanfax/Makefile2
-rw-r--r--comms/vpb2/Makefile4
3 files changed, 4 insertions, 4 deletions
diff --git a/comms/ghfaxviewer/Makefile b/comms/ghfaxviewer/Makefile
index 7b8c1362ee8..18158e09d88 100644
--- a/comms/ghfaxviewer/Makefile
+++ b/comms/ghfaxviewer/Makefile
@@ -31,7 +31,7 @@ MAN1= halifax.1 ghfaxviewer.1
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/comms/tkscanfax/Makefile b/comms/tkscanfax/Makefile
index 9d9e565d925..6b4e0aa73bb 100644
--- a/comms/tkscanfax/Makefile
+++ b/comms/tkscanfax/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= YES
post-extract:
- find ${WRKSRC} -name '*~' -delete
+ ${FIND} ${WRKSRC} -name '*~' -delete
do-install:
(\
diff --git a/comms/vpb2/Makefile b/comms/vpb2/Makefile
index 9d08f1fb09f..3429ca6bf2a 100644
--- a/comms/vpb2/Makefile
+++ b/comms/vpb2/Makefile
@@ -25,7 +25,7 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
post-extract:
- @find ${WRKSRC} -name "Makefile.in" | \
- xargs ${REINPLACE_CMD} -e 's|-release \$$\(LT_RELEASE\)||g'
+ @${FIND} ${WRKSRC} -name "Makefile.in" | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|-release \$$\(LT_RELEASE\)||g'
.include <bsd.port.mk>