aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-31 01:47:33 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-31 01:47:33 +0800
commit00c2d5a5c266ea27e804d1d5e9097fec41499afc (patch)
tree82268ab0965ef78031dc62a773b242b54385d209 /games
parent6595e676862ecbee5430b2dbac3c7d5e5d3e3881 (diff)
downloadfreebsd-ports-gnome-00c2d5a5c266ea27e804d1d5e9097fec41499afc.tar.gz
freebsd-ports-gnome-00c2d5a5c266ea27e804d1d5e9097fec41499afc.tar.zst
freebsd-ports-gnome-00c2d5a5c266ea27e804d1d5e9097fec41499afc.zip
- fix build for jpeg-8
PR: 145204
Diffstat (limited to 'games')
-rw-r--r--games/alienarena/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 88f53477cec5..695ed9527193 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -45,9 +45,11 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.include <bsd.port.pre.mk>
.if defined(WITH_CLIENT)
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png.6:${PORTSDIR}/graphics/png \
+ vorbis.4:${PORTSDIR}/audio/libvorbis
USE_GL= yes
USE_OPENAL= soft alut
USE_XORG= xxf86dga
@@ -82,6 +84,9 @@ MAKE_ENV+= OPTIMIZED_CFLAGS=no
post-patch:
@${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/client/snd_openal.c
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/Makefile
+# Resolve name collision with jpeg-8
+ ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
+ ${WRKSRC}/ref_gl/r_image.c
do-install:
${MKDIR} ${LIBDIR}/arena ${LIBDIR}/data1