aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2000-04-01 09:02:31 +0800
committermharo <mharo@FreeBSD.org>2000-04-01 09:02:31 +0800
commit0213dc5cd8a8ded46e9c2a92b013d4bf151df61b (patch)
treec0ad9caea623cd4a5a768a87ce382b51914033dd /games
parent25f6661f847e041edd7a932a73e94367cd6e654f (diff)
downloadfreebsd-ports-gnome-0213dc5cd8a8ded46e9c2a92b013d4bf151df61b.tar.gz
freebsd-ports-gnome-0213dc5cd8a8ded46e9c2a92b013d4bf151df61b.tar.zst
freebsd-ports-gnome-0213dc5cd8a8ded46e9c2a92b013d4bf151df61b.zip
- Fix MASTER_SITES
- Remove redundant LIB_DEPENDS - Support CC/CFLAGS properly PR: 17165 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'games')
-rw-r--r--games/xvmines/Makefile15
-rw-r--r--games/xvmines/files/patch-aa21
2 files changed, 24 insertions, 12 deletions
diff --git a/games/xvmines/Makefile b/games/xvmines/Makefile
index 67532a6a57dc..9cf4e2d71b20 100644
--- a/games/xvmines/Makefile
+++ b/games/xvmines/Makefile
@@ -9,23 +9,22 @@
DISTNAME= xvmines-1.0
CATEGORIES= games
MASTER_SITES= ftp://ftp.csd.uch.gr/pub/X11/games/ \
- ftp://ftp.cdrom.com/pub/X11/R5contrib/ \
- ftp://ftp.gwdg.de/pub/x11/x.org/R5contrib/
+ ftp://ftp.x.org/R5contrib/ \
+ ftp://ftp.freesoftware.com/pub/X11/R5contrib/
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview \
- olgx.3:${PORTSDIR}/x11-toolkits/xview
+LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
USE_IMAKE= yes
MAN6= xvmines.6
MANCOMPRESSED= no
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/xvmines ${PREFIX}/bin
- @ ${INSTALL_DATA} ${WRKSRC}/xvmines.man ${PREFIX}/man/man6/xvmines.6
- @ ${MKDIR} ${PREFIX}/share/doc/xvmines
- @ ${INSTALL_DATA} ${WRKSRC}/Copyright ${PREFIX}/share/doc/xvmines
+ ${INSTALL_PROGRAM} ${WRKSRC}/xvmines ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xvmines.man ${PREFIX}/man/man6/xvmines.6
+ @${MKDIR} ${PREFIX}/share/doc/xvmines
+ ${INSTALL_DATA} ${WRKSRC}/Copyright ${PREFIX}/share/doc/xvmines
.include <bsd.port.mk>
diff --git a/games/xvmines/files/patch-aa b/games/xvmines/files/patch-aa
index 1875df00d25a..0e79ce313c41 100644
--- a/games/xvmines/files/patch-aa
+++ b/games/xvmines/files/patch-aa
@@ -1,9 +1,22 @@
---- Imakefile Sun Jun 27 10:05:51 1993
-+++ /home/andy/tmp/wrk/Imakefile Fri Mar 20 00:45:31 1998
-@@ -1,4 +1,5 @@
+--- Imakefile.orig Sun Jun 27 19:05:51 1993
++++ Imakefile Fri Mar 3 08:07:52 2000
+@@ -1,7 +1,8 @@
-WHERE :sh = (tmp=`echo /usr/openwin`;echo ${OPENWINHOME:=$tmp})
+#WHERE :sh = (tmp=`echo /usr/openwin`;echo ${OPENWINHOME:=$tmp})
+WHERE=${X11BASE}
#CC = gcc
- CC = cc
+-CC = cc
++XCOMM CC = cc
+ INCLUDES = -I${WHERE}/include
+ LOCAL_LIBRARIES = -L${WHERE}/lib
+
+@@ -14,7 +15,7 @@
+ OBJS = xvmines.o play.o
+
+ #CDEBUGFLAGS = -g
+-CDEBUGFLAGS = -O4
++XCOMM CDEBUGFLAGS = -O4
+
+ ComplexProgramTarget(xvmines)
+