aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-11-06 04:34:17 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-11-06 04:34:17 +0800
commit03ffa295fc4d6ede153bf2336e9cf943a9850e05 (patch)
tree3d944d8f84b096707c4ea3ad4516e864176fd884 /games
parentc9fea575fd627e9025a46172f88e4023c288caa8 (diff)
downloadfreebsd-ports-gnome-03ffa295fc4d6ede153bf2336e9cf943a9850e05.tar.gz
freebsd-ports-gnome-03ffa295fc4d6ede153bf2336e9cf943a9850e05.tar.zst
freebsd-ports-gnome-03ffa295fc4d6ede153bf2336e9cf943a9850e05.zip
- Fix build with TEST enabled
Approved by: portmgr blanket
Diffstat (limited to 'games')
-rw-r--r--games/wesnoth/Makefile1
-rw-r--r--games/wesnoth/files/patch-src_tests_test__util.cpp11
-rw-r--r--games/wesnoth/pkg-plist1
3 files changed, 11 insertions, 2 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 4d599b6e3a06..8ca482d3e85a 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -69,7 +69,6 @@ RAWSOCKETS_CFLAGS=-DNETWORK_USE_RAW_SOCKETS
SERVER_DESC= Server
SERVER_CMAKE_OFF=-DENABLE_SERVER=off
TEST_CMAKE_ON= -DENABLE_TESTS=on
-TEST_BROKEN= Does not compile with TEST option enabled
TOOLS_DESC= Extra tools for artists and translators
TOOLS_CMAKE_ON= -DENABLE_TOOLS=on
diff --git a/games/wesnoth/files/patch-src_tests_test__util.cpp b/games/wesnoth/files/patch-src_tests_test__util.cpp
new file mode 100644
index 000000000000..30d71d1161f5
--- /dev/null
+++ b/games/wesnoth/files/patch-src_tests_test__util.cpp
@@ -0,0 +1,11 @@
+--- src/tests/test_util.cpp.orig 2015-06-25 23:08:11 UTC
++++ src/tests/test_util.cpp
+@@ -89,7 +89,7 @@ BOOST_AUTO_TEST_CASE( test_count_leading
+ BOOST_CHECK( count_leading_ones(static_cast<boost::uint8_t>(0xFF)) == 8 );
+ BOOST_CHECK( count_leading_ones(static_cast<boost::uint16_t>(0xFFFF)) == 16 );
+ BOOST_CHECK( count_leading_ones(static_cast<boost::uint32_t>(0xFFFFFFFF)) == 32 );
+- BOOST_CHECK( count_leading_ones(static_cast<boost::uint64_t>(0xFFFFFFFFFFFFFFFF))
++ BOOST_CHECK( count_leading_ones(static_cast<boost::uint64_t>(0xFFFFFFFFFFFFFFFFULL))
+ == 64 );
+ BOOST_CHECK( count_leading_ones(static_cast<boost::uint8_t>(0xF8)) == 5 );
+ BOOST_CHECK( count_leading_ones(static_cast<boost::uint16_t>(54321)) == 2 );
diff --git a/games/wesnoth/pkg-plist b/games/wesnoth/pkg-plist
index 8296353f7d28..8afaa800ff76 100644
--- a/games/wesnoth/pkg-plist
+++ b/games/wesnoth/pkg-plist
@@ -13,7 +13,6 @@ bin/wesnoth
%%TOOLS%%bin/schema_generator
%%TOOLS%%bin/schema_validator
%%TOOLS%%bin/wesmage
-%%TEST%%bin/wesnoth_test
%%SERVER%%bin/wesnothd
share/applications/wesnoth.desktop
share/applications/wesnoth_editor.desktop