aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-12-02 08:10:19 +0800
committerJason Helfman <jgh@FreeBSD.org>2012-12-02 08:10:19 +0800
commit0821a742f937e0c2420d533f38b6f2c03c3beb8c (patch)
tree036eded3bbad4168ddcafce28b6941c511b57fb4 /games
parentb2c05cf1654c10bfcfd1d484c482955182137059 (diff)
downloadfreebsd-ports-gnome-0821a742f937e0c2420d533f38b6f2c03c3beb8c.tar.gz
freebsd-ports-gnome-0821a742f937e0c2420d533f38b6f2c03c3beb8c.tar.zst
freebsd-ports-gnome-0821a742f937e0c2420d533f38b6f2c03c3beb8c.zip
add new port: games/tuxfighter
Was the first visible part of The Python Game Book project. TuxFighter is a little Asteroids-like Shooter game, written around 2006. The game support modding. You control Tux, the penguin (with mouse or keyboard) and shoot down rectangular enemies (to make points). Shots may reflect from the screen border, and self-shooting result in negative points. In the game, you can pick up one of those power-up's and enjoy different effects. WWW: http://thepythongamebook.com/en:resources:games:tuxfighter PR: 169893 Submitted by: nemysis@gmx.ch Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/tuxfighter/Makefile59
-rw-r--r--games/tuxfighter/distinfo4
-rw-r--r--games/tuxfighter/files/tuxfighter.in7
-rw-r--r--games/tuxfighter/pkg-descr11
-rw-r--r--games/tuxfighter/pkg-message11
-rw-r--r--games/tuxfighter/pkg-plist68
7 files changed, 161 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index fa328c3e57e7..4270a7f0bd5c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -924,6 +924,7 @@
SUBDIR += ttraffic
SUBDIR += ttt
SUBDIR += tux-aqfh
+ SUBDIR += tuxfighter
SUBDIR += tuxkart
SUBDIR += tuxmath
SUBDIR += tuxpaint
diff --git a/games/tuxfighter/Makefile b/games/tuxfighter/Makefile
new file mode 100644
index 000000000000..c8c6ad2ba1f3
--- /dev/null
+++ b/games/tuxfighter/Makefile
@@ -0,0 +1,59 @@
+# Created by: nemysis@gmx.ch
+#
+# $FreeBSD$
+
+PORTNAME= tuxfighter
+PORTVERSION= 54
+CATEGORIES= games python
+MASTER_SITES= SF/pygamebook/TuxFighter/TuxFighter${PORTVERSION}_source/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= TuxFighter${DISTVERSION}.tar.gz \
+ ${PORTNAME}_icons.tar.gz:icons
+DIST_SUBDIR= python
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Little Asteroids-like Shooter game
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYGAME}
+
+WRKSRC= ${WRKDIR}
+
+FETCH_ARGS?= -Fpr
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PORTDOCS= readme_TuxFighter54.txt
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 48x48 64x64 72x72 96x96
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="TuxFighter" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR}
+
+post-install:
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/tuxfighter/distinfo b/games/tuxfighter/distinfo
new file mode 100644
index 000000000000..ec21bc96c922
--- /dev/null
+++ b/games/tuxfighter/distinfo
@@ -0,0 +1,4 @@
+SHA256 (python/TuxFighter54.tar.gz) = ba9ed46da8d2196cf1c90b67f0cb57f33b92f54be4b3867bd0af5d214d267154
+SIZE (python/TuxFighter54.tar.gz) = 336573
+SHA256 (python/tuxfighter_icons.tar.gz) = 1ef2f0a887d9b35fa2b4b58a60aa5f1b987a47bd3e3800a08afa13b1e57d246c
+SIZE (python/tuxfighter_icons.tar.gz) = 24576
diff --git a/games/tuxfighter/files/tuxfighter.in b/games/tuxfighter/files/tuxfighter.in
new file mode 100644
index 000000000000..1e97cfc238eb
--- /dev/null
+++ b/games/tuxfighter/files/tuxfighter.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec ./TuxFighter54.py "${@}"
diff --git a/games/tuxfighter/pkg-descr b/games/tuxfighter/pkg-descr
new file mode 100644
index 000000000000..6f1c59fc0004
--- /dev/null
+++ b/games/tuxfighter/pkg-descr
@@ -0,0 +1,11 @@
+Was the first visible part of The Python Game Book project.
+TuxFighter is a little Asteroids-like Shooter game, written around 2006.
+The game support modding. You control Tux, the penguin (with mouse or keyboard)
+and shoot down rectangular enemies (to make points).
+Shots may reflect from the screen border, and self-shooting result
+in negative points.
+
+In the game, you can pick up one of those power-up's and enjoy
+different effects.
+
+WWW: http://thepythongamebook.com/en:resources:games:tuxfighter
diff --git a/games/tuxfighter/pkg-message b/games/tuxfighter/pkg-message
new file mode 100644
index 000000000000..be810559a420
--- /dev/null
+++ b/games/tuxfighter/pkg-message
@@ -0,0 +1,11 @@
+========================================================================
+Tuxfighter has been installed.
+
+Python errors will result in the first run of this game.
+Restart, and enjoy.
+
+This issue is currently being resolved with upstream developers.
+
+All options are in the config file if you've made changes in the GUI.
+ ~/.TuxFighter/TuxFighter.ini
+========================================================================
diff --git a/games/tuxfighter/pkg-plist b/games/tuxfighter/pkg-plist
new file mode 100644
index 000000000000..d161e12de14d
--- /dev/null
+++ b/games/tuxfighter/pkg-plist
@@ -0,0 +1,68 @@
+bin/tuxfighter
+share/icons/hicolor/48x48/apps/tuxfighter.png
+share/icons/hicolor/64x64/apps/tuxfighter.png
+share/icons/hicolor/72x72/apps/tuxfighter.png
+share/icons/hicolor/96x96/apps/tuxfighter.png
+share/pixmaps/tuxfighter.png
+%%DATADIR%%/TuxFighter54.py
+%%DATADIR%%/TuxFighter_modding.py
+%%DATADIR%%/data/babytux1.png
+%%DATADIR%%/data/babytux2.png
+%%DATADIR%%/data/babytux3.png
+%%DATADIR%%/data/babytux4.png
+%%DATADIR%%/data/babytux5.png
+%%DATADIR%%/data/babytux6.png
+%%DATADIR%%/data/background.jpg
+%%DATADIR%%/data/boom.wav
+%%DATADIR%%/data/bounce.wav
+%%DATADIR%%/data/car_door.wav
+%%DATADIR%%/data/cash.wav
+%%DATADIR%%/data/debian.png
+%%DATADIR%%/data/dope.png
+%%DATADIR%%/data/dope_shot.wav
+%%DATADIR%%/data/dope_small.png
+%%DATADIR%%/data/empty.wav
+%%DATADIR%%/data/ex1.png
+%%DATADIR%%/data/ex1_small.png
+%%DATADIR%%/data/ex2.png
+%%DATADIR%%/data/ex2_small.png
+%%DATADIR%%/data/ex3.png
+%%DATADIR%%/data/ex3_small.png
+%%DATADIR%%/data/freesansbold.ttf
+%%DATADIR%%/data/mampf.wav
+%%DATADIR%%/data/player_explsion.wav
+%%DATADIR%%/data/rakete.png
+%%DATADIR%%/data/rakete2.png
+%%DATADIR%%/data/rakete3.png
+%%DATADIR%%/data/self_shot.wav
+%%DATADIR%%/data/surprise.png
+%%DATADIR%%/data/trommel.wav
+%%DATADIR%%/data/tux0.png
+%%DATADIR%%/data/tux0red.png
+%%DATADIR%%/data/tux1.png
+%%DATADIR%%/data/tux1red.png
+%%DATADIR%%/data/tux2.png
+%%DATADIR%%/data/tux2red.png
+%%DATADIR%%/data/tux3.png
+%%DATADIR%%/data/tux3red.png
+%%DATADIR%%/data/tux4.png
+%%DATADIR%%/data/tux4red.png
+%%DATADIR%%/data/ubuntulogo.png
+%%DATADIR%%/data/ubuntulogo_small.png
+%%DATADIR%%/data/wall.wav
+%%DATADIR%%/data/wine.gif
+%%DATADIR%%/data/winlogoh1.png
+%%DATADIR%%/data/winlogoh2.png
+%%DATADIR%%/data/winlogoh3.png
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons