aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-30 04:24:04 +0800
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-30 04:24:04 +0800
commit08cf7bbcc736a5007c258575d09e5bf975013eb4 (patch)
tree1ba3394f15839c2c4d2216c1646cff813585859c /games
parent89bb73f8360c30034dcbd03d12990fee4facf3fd (diff)
downloadfreebsd-ports-gnome-08cf7bbcc736a5007c258575d09e5bf975013eb4.tar.gz
freebsd-ports-gnome-08cf7bbcc736a5007c258575d09e5bf975013eb4.tar.zst
freebsd-ports-gnome-08cf7bbcc736a5007c258575d09e5bf975013eb4.zip
- Add stage support
- Convert USE_GMAKE to USES
Diffstat (limited to 'games')
-rw-r--r--games/annelid/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/games/annelid/Makefile b/games/annelid/Makefile
index c58cebe35c3a..a8a55ec5869e 100644
--- a/games/annelid/Makefile
+++ b/games/annelid/Makefile
@@ -14,8 +14,8 @@ COMMENT= Remake of the ubiquitous "Snake" and "Worm" games
RESTRICTED= No redistribution allowed
+USES= gmake
USE_ZIP= yes
-USE_GMAKE= yes
USE_SDL= sdl
USE_GL= gl
NO_WRKSUBDIR= yes
@@ -30,7 +30,6 @@ DATAFILES= annelid.dat apple.tga apple.wav backd.tga backn.tga font.dat \
score.wav segment.tga shrink.wav slow.wav speed.wav title.tga \
vortex.wav
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -50,16 +49,11 @@ post-patch:
.endif
do-install:
-# Script.
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${PREFIX}/bin/${PORTNAME}
-
-# Program.
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/libexec
-
-# Data.
- ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/libexec
+ @${MKDIR} ${STAGEDIR}${DATADIR}
.for f in ${DATAFILES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}
.endfor
.include <bsd.port.mk>