aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-11-15 18:12:08 +0800
committertobik <tobik@FreeBSD.org>2019-11-15 18:12:08 +0800
commit09db1a7016227e21bd4cd755390185cbd2585518 (patch)
tree4ec74f3dd744ca8054cce78df35237dd5b189528 /games
parentc0947f367dc13fcb9006d703426aea1f91b8e735 (diff)
downloadfreebsd-ports-gnome-09db1a7016227e21bd4cd755390185cbd2585518.tar.gz
freebsd-ports-gnome-09db1a7016227e21bd4cd755390185cbd2585518.tar.zst
freebsd-ports-gnome-09db1a7016227e21bd4cd755390185cbd2585518.zip
Move remaining USE_MYSQL, WANT_MYSQL_VER to USES=mysql
Diffstat (limited to 'games')
-rw-r--r--games/ldmud/Makefile2
-rw-r--r--games/pvpgn/Makefile2
-rw-r--r--games/quetoo/Makefile2
-rw-r--r--games/scorched3d/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/games/ldmud/Makefile b/games/ldmud/Makefile
index a8deaa0b6cc4..a3f73922cd06 100644
--- a/games/ldmud/Makefile
+++ b/games/ldmud/Makefile
@@ -36,7 +36,7 @@ OPTIONS_SINGLE_MUDLIB= LPMUD DEMOLIB
OPTIONS_SUB= yes
LPMUD_DESC= Install default mudlib (LP-245)
IPV6_CONFIGURE_ENABLE= use-ipv6
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
MYSQL_CONFIGURE_ENABLE= use-mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= use-pgsql
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index 6e837b348b06..3875f09311c1 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -44,7 +44,7 @@ OPTIONS_SUB= yes
D2_DESC= Diablo II server (D2CS/D2DBS)
D2_CONFIGURE_ENABLE= d2cs d2dbs
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
PGSQL_USES= pgsql
diff --git a/games/quetoo/Makefile b/games/quetoo/Makefile
index 1824136c7cf3..c23a2b5fc919 100644
--- a/games/quetoo/Makefile
+++ b/games/quetoo/Makefile
@@ -69,7 +69,7 @@ PLIST_SUB+= VANCTF="@comment "
.endif
.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
+USES+= mysql
CONFIGURE_ARGS+= --with-mysql
CONFIGURE_ENV+= MYSQL_LIBS="-L${LOCALBASE}/lib/mysql -lmysqlclient" \
MYSQL_CFLAGS="-I${LOCALBASE}/include"
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index bc1d1a1dfd4b..21e53098fc1e 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -41,7 +41,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
SCORCH_VERSION= 43.3d
SCORCH_REVISION= # none
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql
PLIST_FILES= bin/scorched3d \