aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-06-27 22:53:49 +0800
committerShaun Amott <shaun@FreeBSD.org>2006-06-27 22:53:49 +0800
commit0bb8337607b589426e065a0ed7a1f124519d31c1 (patch)
treeacc37d567bb18be7afe08c0bf8c4c8f624db4bef /games
parent8b37787361b8c84433a600b3cfe79d272cebed24 (diff)
downloadfreebsd-ports-gnome-0bb8337607b589426e065a0ed7a1f124519d31c1.tar.gz
freebsd-ports-gnome-0bb8337607b589426e065a0ed7a1f124519d31c1.tar.zst
freebsd-ports-gnome-0bb8337607b589426e065a0ed7a1f124519d31c1.zip
- Upgrade to 1.1.4
- Fix build on 4.x Approved by: ahze (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/xbl/Makefile8
-rw-r--r--games/xbl/distinfo6
-rw-r--r--games/xbl/files/patch-bl.c20
3 files changed, 24 insertions, 10 deletions
diff --git a/games/xbl/Makefile b/games/xbl/Makefile
index aa34627328ca..b3722a57f29e 100644
--- a/games/xbl/Makefile
+++ b/games/xbl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xbl
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.4
CATEGORIES= games
MASTER_SITES= http://www710.univ-lyon1.fr/~exco/XBL/ \
${MASTER_SITE_GENTOO}
@@ -21,10 +21,4 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
MAN1= xbl.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
.include <bsd.port.post.mk>
diff --git a/games/xbl/distinfo b/games/xbl/distinfo
index 7d6900926246..32ed93621ba2 100644
--- a/games/xbl/distinfo
+++ b/games/xbl/distinfo
@@ -1,3 +1,3 @@
-MD5 (xbl-1.1.3.tar.gz) = 2fcada6f23e1f4bb3c4a33481bfefb80
-SHA256 (xbl-1.1.3.tar.gz) = c6752a59ceef9f28b2df36df7da5c8018edc1be4cb977ca74558865620284e85
-SIZE (xbl-1.1.3.tar.gz) = 136411
+MD5 (xbl-1.1.4.tar.gz) = 767ea5b713221452c026fac89b1415f4
+SHA256 (xbl-1.1.4.tar.gz) = b51a371f0808fbfad7487b9f396eea394ad85b01e89ee51179db041fa33b3fab
+SIZE (xbl-1.1.4.tar.gz) = 136445
diff --git a/games/xbl/files/patch-bl.c b/games/xbl/files/patch-bl.c
new file mode 100644
index 000000000000..467ebd2cac42
--- /dev/null
+++ b/games/xbl/files/patch-bl.c
@@ -0,0 +1,20 @@
+--- bl.c.orig Sat Feb 4 20:13:23 2006
++++ bl.c Tue Jun 27 02:07:43 2006
+@@ -452,6 +452,8 @@
+ int i ;
+ XEvent event ;
+
++ double fps;
++
+ fprintf(stderr,"THIS TEST WILL TAKE SOME TIME\n") ;
+
+ blo->opt.wx = blo->opt.wy = blo->opt.wz = 6 ;
+@@ -485,7 +487,7 @@
+ }
+ gettimeofday(&currenttime, &tz) ;
+
+- double fps = (1000000. * i )
++ fps = (1000000. * i )
+ / ( (currenttime.tv_sec - starttime.tv_sec)*1000000
+ + currenttime.tv_usec - starttime.tv_usec ) ;
+ printf("%.2f frames/sec buffering=%d %s clearline=%d\n",