aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-15 23:37:44 +0800
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-15 23:37:44 +0800
commit0cc4859332281daf5bf0492567a8566d0f06ed3a (patch)
tree01aef5cb7540adfd6d56270c823d0e8992735067 /games
parent88cdfe844e3f82b54aaaefa85d9f8d40e5b3ed42 (diff)
downloadfreebsd-ports-gnome-0cc4859332281daf5bf0492567a8566d0f06ed3a.tar.gz
freebsd-ports-gnome-0cc4859332281daf5bf0492567a8566d0f06ed3a.tar.zst
freebsd-ports-gnome-0cc4859332281daf5bf0492567a8566d0f06ed3a.zip
Stagify.
Approved by: portmgr@
Diffstat (limited to 'games')
-rw-r--r--games/mkgichessclub/Makefile25
1 files changed, 7 insertions, 18 deletions
diff --git a/games/mkgichessclub/Makefile b/games/mkgichessclub/Makefile
index 2db772163aad..96fd04c84199 100644
--- a/games/mkgichessclub/Makefile
+++ b/games/mkgichessclub/Makefile
@@ -24,32 +24,21 @@ SUB_FILES= pkg-message
USE_MYSQL= server
USE_PHP= mysql pcre session
USE_PYTHON= yes
+GNUCHESS_RUN_DEPENDS= gnuchess:${PORTSDIR}/games/gnuchess
+PHALANX_RUN_DEPENDS= phalanx:${PORTSDIR}/games/phalanx
WRKSRC= ${WRKDIR}/MKGIChessClub-${PORTVERSION}
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-install:
- ${MKDIR} ${DATADIR}; cd ${WRKSRC}; \
- ${INSTALL_DATA} database/* ${DATADIR}; \
- ${MKDIR} ${WWWDIR}; cd www; ${CP} -R . ${WWWDIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}; cd ${WRKSRC}; \
+ ${INSTALL_DATA} database/* ${STAGEDIR}${DATADIR}; \
+ ${MKDIR} ${STAGEDIR}${WWWDIR}; cd www; ${CP} -R . ${STAGEDIR}${WWWDIR}
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}; \
- ${INSTALL_DATA} ${WRKSRC}/README.INSTALL ${DOCSDIR}
-.endif
-
-# pkg-message taken from www/b2evolution
-post-install:
- ${CAT} ${PKGMESSAGE}
-
-.if ${PORT_OPTIONS:MGNUCHESS}
-RUN_DEPENDS+= gnuchess:${PORTSDIR}/games/gnuchess
-.endif
-
-.if ${PORT_OPTIONS:MPHALANX}
-RUN_DEPENDS+= phalanx:${PORTSDIR}/games/phalanx
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/README.INSTALL ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>