aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-09-23 20:54:30 +0800
committerJason E. Hale <jhale@FreeBSD.org>2014-09-23 20:54:30 +0800
commit11a5d6f1d0a68a0edd0db322116173452426eab9 (patch)
treeeb743c9f9f705de7c38891043e137f18686282d4 /games
parent1cdf78746b056e35c2e512677c8d067f57d76a5d (diff)
downloadfreebsd-ports-gnome-11a5d6f1d0a68a0edd0db322116173452426eab9.tar.gz
freebsd-ports-gnome-11a5d6f1d0a68a0edd0db322116173452426eab9.tar.zst
freebsd-ports-gnome-11a5d6f1d0a68a0edd0db322116173452426eab9.zip
- Simplify pkg-plist
While here: - Set special permissions in plist, not Makefile - Drop trailing slashes from install commands - Move PLIST_SUB down to fix a portlint(1) warning PR: 193853 Submitted by: Nikolai Lifanov <lifanov@mail.lifanov.com> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/tome4/Makefile8
-rw-r--r--games/tome4/pkg-plist49
2 files changed, 4 insertions, 53 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index 694bc5339462..6f9fa7f9eddb 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -10,7 +10,6 @@ MASTER_SITES= http://te4.org/dl/t-engine/ \
DISTFILES= t-engine4-src-${PORTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
EXTRACT_ONLY= t-engine4-src-${PORTVERSION}${EXTRACT_SUFX}
-PLIST_SUB= PORTVERSION=${PORTVERSION}
MAINTAINER= lifanov@mail.lifanov.com
COMMENT= Epic tactical turn-based roguelike adventure
@@ -23,6 +22,7 @@ LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
DESKTOP_ENTRIES="ToME 4" "" "${PORTNAME}" \
"${PORTNAME}" "Game;RolePlaying;" ""
+PLIST_SUB= PORTVERSION=${PORTVERSION}
WRKSRC= ${WRKDIR}/t-engine4-src-${PORTVERSION}
MAKE_ARGS+= config=release verbose=yes ARCH=""
USES= gmake openal:al tar:bzip2
@@ -40,12 +40,10 @@ pre-build:
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
-
${INSTALL_PROGRAM} ${WRKSRC}/t-engine ${STAGEDIR}${DATADIR}
- ${INSTALL} -m 0755 ${WRKDIR}/tome4 ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/tome4 ${STAGEDIR}${PREFIX}/bin
(cd ${WRKSRC}; ${COPYTREE_SHARE} "bootstrap game" ${STAGEDIR}${DATADIR})
-
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>
diff --git a/games/tome4/pkg-plist b/games/tome4/pkg-plist
index 08e07784dc11..0f31fc1bfdaf 100644
--- a/games/tome4/pkg-plist
+++ b/games/tome4/pkg-plist
@@ -1,4 +1,4 @@
-bin/tome4
+@(,,0755) bin/tome4
share/pixmaps/tome4.png
%%DATADIR%%/bootstrap/boot.lua
%%DATADIR%%/game/addons/tome-addon-dev.teaa
@@ -177,50 +177,3 @@ share/pixmaps/tome4.png
%%DATADIR%%/game/thirdparty/socket/url.lua
%%DATADIR%%/game/thirdparty/tween.lua
%%DATADIR%%/t-engine
-@dirrm %%DATADIR%%/bootstrap
-@dirrm %%DATADIR%%/game/addons
-@dirrm %%DATADIR%%/game/engines
-@dirrm %%DATADIR%%/game/loader
-@dirrm %%DATADIR%%/game/modules/example/class/interface
-@dirrm %%DATADIR%%/game/modules/example/class
-@dirrm %%DATADIR%%/game/modules/example/data/birth
-@dirrm %%DATADIR%%/game/modules/example/data/general/grids
-@dirrm %%DATADIR%%/game/modules/example/data/general/npcs
-@dirrm %%DATADIR%%/game/modules/example/data/general
-@dirrm %%DATADIR%%/game/modules/example/data/gfx/particles
-@dirrm %%DATADIR%%/game/modules/example/data/gfx
-@dirrm %%DATADIR%%/game/modules/example/data/rooms
-@dirrm %%DATADIR%%/game/modules/example/data/zones/dungeon
-@dirrm %%DATADIR%%/game/modules/example/data/zones
-@dirrm %%DATADIR%%/game/modules/example/data
-@dirrm %%DATADIR%%/game/modules/example/dialogs
-@dirrm %%DATADIR%%/game/modules/example
-@dirrm %%DATADIR%%/game/modules/example_realtime/class/interface
-@dirrm %%DATADIR%%/game/modules/example_realtime/class
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/birth
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/general/grids
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/general/npcs
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/general
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/gfx/particles
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/gfx
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/rooms
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/zones/dungeon
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/zones
-@dirrm %%DATADIR%%/game/modules/example_realtime/data
-@dirrm %%DATADIR%%/game/modules/example_realtime/dialogs
-@dirrm %%DATADIR%%/game/modules/example_realtime
-@dirrm %%DATADIR%%/game/modules
-@dirrm %%DATADIR%%/game/profile-thread
-@dirrm %%DATADIR%%/game/thirdparty/cef3/locales
-@dirrm %%DATADIR%%/game/thirdparty/cef3
-@dirrm %%DATADIR%%/game/thirdparty/jit
-@dirrm %%DATADIR%%/game/thirdparty/licenses
-@dirrm %%DATADIR%%/game/thirdparty/lpeg
-@dirrm %%DATADIR%%/game/thirdparty/lxp
-@dirrm %%DATADIR%%/game/thirdparty/moonscript/compile
-@dirrm %%DATADIR%%/game/thirdparty/moonscript
-@dirrm %%DATADIR%%/game/thirdparty/remdebug
-@dirrm %%DATADIR%%/game/thirdparty/socket
-@dirrm %%DATADIR%%/game/thirdparty
-@dirrm %%DATADIR%%/game
-@dirrm %%DATADIR%%