aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-01-16 14:30:38 +0800
committeracm <acm@FreeBSD.org>2009-01-16 14:30:38 +0800
commit131ad470588dc19d14f823907c25420f08301608 (patch)
treeb2d18a8f596f1e85a10a2f2079ed04e9a500241e /games
parent818328e3885fd1a03d016a591e7fb2c872725c3c (diff)
downloadfreebsd-ports-gnome-131ad470588dc19d14f823907c25420f08301608.tar.gz
freebsd-ports-gnome-131ad470588dc19d14f823907c25420f08301608.tar.zst
freebsd-ports-gnome-131ad470588dc19d14f823907c25420f08301608.zip
- Update to 20080508
Diffstat (limited to 'games')
-rw-r--r--games/vdrift-data/Makefile33
-rw-r--r--games/vdrift-data/distinfo9
-rw-r--r--games/vdrift/Makefile17
-rw-r--r--games/vdrift/distinfo6
-rw-r--r--games/vdrift/files/patch-SConstruct46
-rw-r--r--games/vdrift/files/patch-include_physics.h11
-rw-r--r--games/vdrift/files/patch-po_SConscript11
-rw-r--r--games/vdrift/files/patch-src_SConscript20
-rw-r--r--games/vdrift/files/patch-src_sound.cpp14
-rw-r--r--games/vdrift/pkg-plist4
10 files changed, 108 insertions, 63 deletions
diff --git a/games/vdrift-data/Makefile b/games/vdrift-data/Makefile
index f2979236162a..90293d920d70 100644
--- a/games/vdrift-data/Makefile
+++ b/games/vdrift-data/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= data
-PORTVERSION= 20070323
+PORTVERSION= 20080805
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= vdrift
PKGNAMEPREFIX= vdrift-
-DISTFILES= #
+DISTNAME= ${PKGNAMEPREFIX}2008-08-05-src
DIST_SUBDIR= vdrift
MAINTAINER= acm@FreeBSD.org
@@ -21,30 +21,7 @@ USE_BZIP2= yes
NO_BUILD= yes
DATADIR= ${PREFIX}/share/vdrift
PLIST= ${WRKDIR}/pkg-plist
-WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}2007-03-23-src
-
-OPTIONS= MINIMAL "Install minimal requerimients of data files" off \
- FULL "Install all data files" on
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_FULL) && defined(WITH_MINIMAL)
-pre-everything::
- @${ECHO_CMD} "##############################################################"
- @${ECHO_CMD} ""
- @${ECHO_CMD} " * Please only select one option, try \"make config\" again"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "##############################################################"
- @${FALSE}
-.endif
-
-.if defined(WITH_MINIMAL)
-DISTFILES+= ${PKGNAMEPREFIX}2007-03-23-${PORTNAME}-minimal.tar.bz2
-.endif
-
-.if defined(WITH_FULL)
-DISTFILES+= ${PKGNAMEPREFIX}2007-03-23-${PORTNAME}-full.tar.bz2
-.endif
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}08-05-08
post-extract:
@cd ${WRKSRC}/data && \
@@ -59,7 +36,7 @@ pre-install:
@cd ${WRKSRC}/data && \
${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
- @${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
+ @${ECHO_CMD} "@dirrmtry %%DATADIR%%" >> ${PLIST}
do-install:
${MKDIR} ${DATADIR}
@@ -67,4 +44,4 @@ do-install:
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/vdrift-data/distinfo b/games/vdrift-data/distinfo
index 7e8f2c6fc464..203928f92c62 100644
--- a/games/vdrift-data/distinfo
+++ b/games/vdrift-data/distinfo
@@ -1,6 +1,3 @@
-MD5 (vdrift/vdrift-2007-03-23-data-full.tar.bz2) = 2136ce2e347a018f2400e3f114e005fd
-SHA256 (vdrift/vdrift-2007-03-23-data-full.tar.bz2) = 52ff3e5cfd84bc1a958b9fee60a902d13b2154b39ff1e9c07987280894b2eb34
-SIZE (vdrift/vdrift-2007-03-23-data-full.tar.bz2) = 230921162
-MD5 (vdrift/vdrift-2007-03-23-data-minimal.tar.bz2) = c9d326bbe887402801a6c8f14505a8d7
-SHA256 (vdrift/vdrift-2007-03-23-data-minimal.tar.bz2) = 2c1dc6f46d015051d3b47d10b69b857fc5d0debc28cb3249bf53648fd6734d97
-SIZE (vdrift/vdrift-2007-03-23-data-minimal.tar.bz2) = 14647572
+MD5 (vdrift/vdrift-2008-08-05-src.tar.bz2) = 9e3e3c91960146354c2a9fb65da3bd97
+SHA256 (vdrift/vdrift-2008-08-05-src.tar.bz2) = 79f91995a5a5b2c07e825d6ed8d3a034cc974b83a181d866347c8e837a1f649e
+SIZE (vdrift/vdrift-2008-08-05-src.tar.bz2) = 287073224
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index 0aecfe06fc66..3b6e8e6442e8 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -6,20 +6,17 @@
#
PORTNAME= vdrift
-PORTVERSION= 20070323
-PORTREVISION= 4
+PORTVERSION= 20080508
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-2007-03-23-src
+DISTNAME= ${PORTNAME}-08-05-08
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
COMMENT= Open source driving simulation
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
-LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- alut.1:${PORTSDIR}/audio/freealut
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/settings/VDrift.config:${PORTSDIR}/games/vdrift-data
USE_BZIP2= yes
@@ -30,7 +27,7 @@ SCONS_ARGS= prefix=${PREFIX} \
datadir=share/${PORTNAME} \
bindir=bin \
use_binreloc=0
-WRKSRC= ${WRKDIR}/build/${DISTNAME}
+WRKSRC= ${WRKDIR}/${DISTNAME}
SUB_FILES= pkg-message
@@ -59,7 +56,6 @@ BROKEN= Does not compile on sparc64
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/SConstruct
- @${REINPLACE_CMD} -e "s|'openal'|'openal','alut'|g" ${WRKSRC}/SConstruct
@${REINPLACE_CMD} -e 's|^os.system.*||g' ${WRKSRC}/src/SConscript
@${REINPLACE_CMD} -e 's|GLvoid|void|g' ${WRKSRC}/src/main.cpp
@@ -70,10 +66,9 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/vdrift ${PREFIX}/bin
.if defined(FLAG_NLS)
-. for DIRE in nl
- @cd ${WRKSRC}/po/share/locale/${DIRE}/LC_MESSAGES && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" ${PREFIX}/share/locale/${DIRE}/LC_MESSAGES \;
-. endfor
+ @${MKDIR} ${DATADIR}/po
+ @cd ${WRKSRC}/po && \
+ ${FIND} * -type f -name "*.po" -exec ${INSTALL_DATA} "{}" "${DATADIR}/po/{}" \;
.endif
.if !defined(NOPORTDOCS)
diff --git a/games/vdrift/distinfo b/games/vdrift/distinfo
index 94cf45eed31a..8ba908d09f7f 100644
--- a/games/vdrift/distinfo
+++ b/games/vdrift/distinfo
@@ -1,3 +1,3 @@
-MD5 (vdrift/vdrift-2007-03-23-src.tar.bz2) = efc5c3c409923382035738798a6392e8
-SHA256 (vdrift/vdrift-2007-03-23-src.tar.bz2) = ed2d7d80663781604f56e307f9a77c19f255110673ad57e3ba917ea6c93c802a
-SIZE (vdrift/vdrift-2007-03-23-src.tar.bz2) = 1232857
+MD5 (vdrift/vdrift-08-05-08.tar.bz2) = c8460bbec35bee252effac3dd3bf4b36
+SHA256 (vdrift/vdrift-08-05-08.tar.bz2) = 64a8560525892e799592647f941500f6ed1e6f81987abe35a2cb2c5366577bf7
+SIZE (vdrift/vdrift-08-05-08.tar.bz2) = 4935528
diff --git a/games/vdrift/files/patch-SConstruct b/games/vdrift/files/patch-SConstruct
new file mode 100644
index 000000000000..79fa2f2c14f2
--- /dev/null
+++ b/games/vdrift/files/patch-SConstruct
@@ -0,0 +1,46 @@
+--- SConstruct 2009-01-15 23:59:59.000000000 -0500
++++ SConstruct 2009-01-16 00:01:12.000000000 -0500
+@@ -6,26 +6,26 @@
+ # Build Options #
+ #---------------#
+
+-opts = Options('vdrift.conf', ARGUMENTS)
++opts = Variables('vdrift.conf', ARGUMENTS)
+ opts.Add('destdir', 'Staging area to install VDrift to. Useful for packagers. ', '')
+ opts.Add('localedir', 'Path suffix were vdrift locales (.mo files) will be installed', "share/locale")
+ opts.Add('arch', 'Target architecture to compile vdrift for (x86, 686, p4, axp, a64)', 'x86')
+-opts.Add(BoolOption('minimal', 'Only install minimal data (3 cars and 2 tracks)', 0))
+-opts.Add(BoolOption('cache', 'Cache options in vdrift.conf', 1))
+-opts.Add(BoolOption('release', 'Turn off debug option during build', 0))
+-opts.Add(BoolOption('use_gcc_32', 'Set this to 1 if the game runs fine but the cars bounce around (gcc4 bug).', 0))
+-opts.Add(BoolOption('use_gcc_33', 'Set this to 1 if the game runs fine but the cars bounce around (gcc4 bug).', 0))
+-opts.Add(BoolOption('use_gcc_34', 'Set this to 1 if the game runs fine but the cars bounce around (gcc4 bug).', 0))
+-opts.Add(BoolOption('use_apbuild', 'Set this to 1 if you want to compile with apgcc to create an autopackage', 0))
+-opts.Add(BoolOption('use_binreloc', 'Set this to 1 if you want to compile with Binary Relocation support', 1))
+-opts.Add(BoolOption('os_cc', 'Set this to 1 if you want to use the operating system\'s C compiler environment variable.', 0))
+-opts.Add(BoolOption('os_cxx', 'Set this to 1 if you want to use the operating system\'s C++ compiler environment variable.', 0))
+-opts.Add(BoolOption('os_cxxflags', 'Set this to 1 if you want to use the operating system\'s C++ compiler flags environment variable.', 0))
+-opts.Add(BoolOption('NLS', 'Set this to 1 to turn on i18n support', 1))
+-opts.Add(BoolOption('force_feedback', 'Enable force-feedback support', 0))
+-opts.Add(BoolOption('profiling', 'Turn on profiling output', 0))
+-opts.Add(BoolOption('efficiency', 'Turn on compile-time efficiency warnings', 0))
+-opts.Add(BoolOption('opcode', 'Set this to one if you have ode compiled with opcode', 0))
++opts.Add(BoolVariable('minimal', 'Only install minimal data (3 cars and 2 tracks)', 0))
++opts.Add(BoolVariable('cache', 'Cache options in vdrift.conf', 1))
++opts.Add(BoolVariable('release', 'Turn off debug option during build', 0))
++opts.Add(BoolVariable('use_gcc_32', 'Set this to 1 if the game runs fine but the cars bounce around (gcc4 bug).', 0))
++opts.Add(BoolVariable('use_gcc_33', 'Set this to 1 if the game runs fine but the cars bounce around (gcc4 bug).', 0))
++opts.Add(BoolVariable('use_gcc_34', 'Set this to 1 if the game runs fine but the cars bounce around (gcc4 bug).', 0))
++opts.Add(BoolVariable('use_apbuild', 'Set this to 1 if you want to compile with apgcc to create an autopackage', 0))
++opts.Add(BoolVariable('use_binreloc', 'Set this to 1 if you want to compile with Binary Relocation support', 1))
++opts.Add(BoolVariable('os_cc', 'Set this to 1 if you want to use the operating system\'s C compiler environment variable.', 0))
++opts.Add(BoolVariable('os_cxx', 'Set this to 1 if you want to use the operating system\'s C++ compiler environment variable.', 0))
++opts.Add(BoolVariable('os_cxxflags', 'Set this to 1 if you want to use the operating system\'s C++ compiler flags environment variable.', 0))
++opts.Add(BoolVariable('NLS', 'Set this to 1 to turn on i18n support', 1))
++opts.Add(BoolVariable('force_feedback', 'Enable force-feedback support', 0))
++opts.Add(BoolVariable('profiling', 'Turn on profiling output', 0))
++opts.Add(BoolVariable('efficiency', 'Turn on compile-time efficiency warnings', 0))
++opts.Add(BoolVariable('opcode', 'Set this to one if you have ode compiled with opcode', 0))
+
+
+ #--------------------------#
diff --git a/games/vdrift/files/patch-include_physics.h b/games/vdrift/files/patch-include_physics.h
new file mode 100644
index 000000000000..3d203c465be0
--- /dev/null
+++ b/games/vdrift/files/patch-include_physics.h
@@ -0,0 +1,11 @@
+--- include/physics.h 2009-01-15 23:50:36.000000000 -0500
++++ include/physics.h 2009-01-15 23:50:53.000000000 -0500
+@@ -36,7 +36,7 @@
+
+ list <btCollisionWorld::LocalRayResult> results;
+
+- virtual btScalar AddSingleResult(btCollisionWorld::LocalRayResult& rayResult,bool normalInWorldSpace)
++ virtual btScalar addSingleResult(btCollisionWorld::LocalRayResult& rayResult,bool normalInWorldSpace)
+ {
+ m_closestHitFraction = rayResult.m_hitFraction;
+ results.push_back(rayResult);
diff --git a/games/vdrift/files/patch-po_SConscript b/games/vdrift/files/patch-po_SConscript
new file mode 100644
index 000000000000..4662eeaf8dfc
--- /dev/null
+++ b/games/vdrift/files/patch-po_SConscript
@@ -0,0 +1,11 @@
+--- po/SConscript 2009-01-16 00:02:30.000000000 -0500
++++ po/SConscript 2009-01-16 00:02:38.000000000 -0500
+@@ -164,7 +164,7 @@
+
+
+
+-environ = env.Copy()
++environ = env.Clone()
+ domain = 'VDrift'
+ environ.Append(PACKAGE=domain)
+ environ.Append(POTFILE=domain + '.pot')
diff --git a/games/vdrift/files/patch-src_SConscript b/games/vdrift/files/patch-src_SConscript
new file mode 100644
index 000000000000..b3b8b7957bcf
--- /dev/null
+++ b/games/vdrift/files/patch-src_SConscript
@@ -0,0 +1,20 @@
+--- src/SConscript 2009-01-16 00:05:24.000000000 -0500
++++ src/SConscript 2009-01-16 00:06:11.000000000 -0500
+@@ -61,7 +61,7 @@
+ #------------------------#
+ # Copy Build Environment #
+ #------------------------#
+-local_env = env.Copy()
++local_env = env.Clone()
+ SConsignFile()
+
+ #--------------------------#
+@@ -152,7 +152,7 @@
+
+ if not ( 'win32' == sys.platform or 'cygwin' == sys.platform ):
+ #for now this seems to break windows build so disabling for win
+- wrapper_build_env = local_env.Copy()
++ wrapper_build_env = local_env.Clone()
+
+ pybase = 'python%s' % sys.version[0:3]
+ wrapper_build_env.Append(CPPPATH=[os.path.join(sys.prefix, 'include', pybase)],
diff --git a/games/vdrift/files/patch-src_sound.cpp b/games/vdrift/files/patch-src_sound.cpp
deleted file mode 100644
index 8819c41a060a..000000000000
--- a/games/vdrift/files/patch-src_sound.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/sound.cpp.orig Tue Sep 12 19:39:38 2006
-+++ src/sound.cpp Tue Sep 12 19:41:19 2006
-@@ -282,9 +282,9 @@
- alutLoadWAVFile((ALbyte*)(filename).c_str(), &format, &data, &size, &freq);
- #else
- #ifdef OLD_OPENAL
-- alutLoadWAVFile((ALbyte*)(filename).c_str(), &format, &data, &size, &freq, &loop);
-+ alutLoadWAVFile(filename.c_str(), &format, &data, &size, &freq, &loop);
- #else
-- data = alutLoadMemoryFromFile((ALbyte*)(filename).c_str(), &format, &size, &freq);
-+ data = alutLoadMemoryFromFile(filename.c_str(), &format, &size, &freq);
- #endif
- #endif
- //bool err = LoadWave(filename, &format, &data, &size, &freq, &loop);
diff --git a/games/vdrift/pkg-plist b/games/vdrift/pkg-plist
index c2ee0712b629..a88e2c74d1b1 100644
--- a/games/vdrift/pkg-plist
+++ b/games/vdrift/pkg-plist
@@ -1,5 +1,7 @@
bin/vdrift
-%%NLS%%share/locale/nl/LC_MESSAGES/VDrift.mo
+%%NLS%%%%DATADIR%%/po/nl.po
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%NLS%%@dirrm %%DATADIR%%/po
+%%NLS%%@dirrmtry %%DATADIR%%