aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-07 13:57:31 +0800
committerkris <kris@FreeBSD.org>2004-03-07 13:57:31 +0800
commit13a952ff278c2dfc1f9980b0622e4f52100c474a (patch)
tree4f97f35632752bb3324970c810d305e2262af39d /games
parent9294fb1b2cbb4faf6aac8580c91d44abe9e56873 (diff)
downloadfreebsd-ports-gnome-13a952ff278c2dfc1f9980b0622e4f52100c474a.tar.gz
freebsd-ports-gnome-13a952ff278c2dfc1f9980b0622e4f52100c474a.tar.zst
freebsd-ports-gnome-13a952ff278c2dfc1f9980b0622e4f52100c474a.zip
BROKEN on alpha 5.x: Does not compile
Diffstat (limited to 'games')
-rw-r--r--games/heroes/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index 9b3de82b2048..004a565695e9 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -49,6 +49,12 @@ INFO= heroes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -lsmpeg ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+BROKEN= "Does not compile on alpha >=5.x"
+.endif
+
post-patch:
@for dir in ${DATASRC} ${SOUNDSRC} ${MUSICSRC}; do \
${FIND} $${dir} -name "Makefile*" | ${XARGS} ${RM}; \
@@ -66,4 +72,4 @@ post-install:
${MKDIR} ${DATADIR}/mod
${INSTALL_DATA} ${MUSICSRC}/*.xm ${MUSICSRC}/sound.conf ${DATADIR}/mod
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>