aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-02-19 23:22:17 +0800
committerJohn Marino <marino@FreeBSD.org>2014-02-19 23:22:17 +0800
commit1464e9ef598a4e3df9c402e7b646174ebcd7faa6 (patch)
treebeebfe1d5b3208f0dda529a2b14714609e6c02bd /games
parentdd0b32d0a8ebe4126df8cd5664c62162bf46377a (diff)
downloadfreebsd-ports-gnome-1464e9ef598a4e3df9c402e7b646174ebcd7faa6.tar.gz
freebsd-ports-gnome-1464e9ef598a4e3df9c402e7b646174ebcd7faa6.tar.zst
freebsd-ports-gnome-1464e9ef598a4e3df9c402e7b646174ebcd7faa6.zip
games/ggz-client-libs: Unbreak build on modern binutils
Something happened with the libtool change that removed some library linkage handling. Explicitly state libexpat and internal libggzcore are required for the build (unbreaks on DragonFly, tested in poudriere).
Diffstat (limited to 'games')
-rw-r--r--games/ggz-client-libs/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/games/ggz-client-libs/Makefile b/games/ggz-client-libs/Makefile
index b053bc757c40..0aa39f22b4bd 100644
--- a/games/ggz-client-libs/Makefile
+++ b/games/ggz-client-libs/Makefile
@@ -20,7 +20,7 @@ USE_GGZ= core
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
+LDFLAGS+= -L${LOCALBASE}/lib -pthread -lexpat
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
@@ -30,7 +30,11 @@ NLS_CONFIGURE_ARGS= --disable-nls
post-patch:
@${REINPLACE_CMD} -e 's|libggz.la|libggz.so|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|#!/bin/bash|#!/bin/sh|' ${WRKSRC}/ggz-wrapper/ggz
+ @${REINPLACE_CMD} -e 's|#!/bin/bash|#!/bin/sh|' \
+ ${WRKSRC}/ggz-wrapper/ggz
+ @${REINPLACE_CMD} -e \
+ 's|@LIB_GGZ@|@LIB_GGZ@ ../ggzcore/.libs/libggzcore.so|' \
+ ${WRKSRC}/ggzwrap/Makefile.in
.include "${.CURDIR}/../libggz/bsd.ggz.mk"
.include <bsd.port.mk>