aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-24 08:13:17 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-24 08:13:17 +0800
commit18d9fefe14b9761c8ac7cc1f5219e2cf1d21b4cd (patch)
tree7cbf85da1d815157eefe83fc8661512472f87571 /games
parentcc980bd4256bfc2fb8ade73b846ab3540d988851 (diff)
downloadfreebsd-ports-gnome-18d9fefe14b9761c8ac7cc1f5219e2cf1d21b4cd.tar.gz
freebsd-ports-gnome-18d9fefe14b9761c8ac7cc1f5219e2cf1d21b4cd.tar.zst
freebsd-ports-gnome-18d9fefe14b9761c8ac7cc1f5219e2cf1d21b4cd.zip
- Improve COMMENT
- Add stage support
Diffstat (limited to 'games')
-rw-r--r--games/linux-enemyterritory-etpro/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/games/linux-enemyterritory-etpro/Makefile b/games/linux-enemyterritory-etpro/Makefile
index 15d03d429663..9721074ccee7 100644
--- a/games/linux-enemyterritory-etpro/Makefile
+++ b/games/linux-enemyterritory-etpro/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= linux-enemyterritory-
DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
-COMMENT= ET Pro - The Enemy Territory Competition Mod
+COMMENT= ET Pro - Enemy Territory Competition Mod
RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
@@ -27,7 +27,6 @@ DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
PLIST_SUB= VERSION="${PORTVERSION:S/./_/g}"
-NO_STAGE= yes
do-build:
.for f in et etded
@(${ECHO} "#!/bin/sh"; \
@@ -37,9 +36,9 @@ do-build:
do-install:
.for f in et etded
- ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/${PORTNAME}/* ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${CP} -R ${WRKSRC}/${PORTNAME}/* ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>