aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-03 07:25:58 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-03 07:25:58 +0800
commit1c4ccc75ddb64647cbcad87ccc68f28b2d0b04c6 (patch)
treeb97e42fec4b1ef8d0c4f4e64c833543ca6fef6f7 /games
parentc2f0d50fcb346a053232a772766bae44a851a14a (diff)
downloadfreebsd-ports-gnome-1c4ccc75ddb64647cbcad87ccc68f28b2d0b04c6.tar.gz
freebsd-ports-gnome-1c4ccc75ddb64647cbcad87ccc68f28b2d0b04c6.tar.zst
freebsd-ports-gnome-1c4ccc75ddb64647cbcad87ccc68f28b2d0b04c6.zip
- Convert LIB_DEPENDS to new syntax
- Add stage support - Use options helpers
Diffstat (limited to 'games')
-rw-r--r--games/kuklomenos/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/games/kuklomenos/Makefile b/games/kuklomenos/Makefile
index db6fb0e39c46..01fc9f1e3f4f 100644
--- a/games/kuklomenos/Makefile
+++ b/games/kuklomenos/Makefile
@@ -12,10 +12,11 @@ COMMENT= Simple but challenging abstract shoot-em-up game
LICENSE= GPLv3
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
OPTIONS_DEFINE= VORBIS
OPTIONS_DEFAULT= VORBIS
+OPTIONS_SUB= yes
USE_SDL= sdl
GNU_CONFIGURE= yes
@@ -23,16 +24,8 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHEAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
-PLIST_SUB+= VORBIS=""
-.else
-CONFIGURE_ARGS+=--disable-sound
-PLIST_SUB+= VORBIS="@comment "
-.endif
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
+VORBIS_CONFIGURE_ENABLE= sound
post-patch:
@${REINPLACE_CMD} -e \