aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-14 18:48:08 +0800
committergarga <garga@FreeBSD.org>2005-10-14 18:48:08 +0800
commit1fcaf4d0570f817d484b05acf33542c6fda93323 (patch)
tree082e83bca232d41ba9b6640c4a10a88ba61fdf8a /games
parentbb1ffe6d8bf3a0ad9434508f41a10d7f8c7d9f0f (diff)
downloadfreebsd-ports-gnome-1fcaf4d0570f817d484b05acf33542c6fda93323.tar.gz
freebsd-ports-gnome-1fcaf4d0570f817d484b05acf33542c6fda93323.tar.zst
freebsd-ports-gnome-1fcaf4d0570f817d484b05acf33542c6fda93323.zip
o Fix a problem that happens when wxWindows 2.4 and 2.6 are both installed. [1]
o Remove unecessary patches and use REINPLACE_CMD instead. [2] PR: ports/87367 [1] Submitted by: Sven Berkvens-Matthijsse <sven@ilse.net> [1], garga [2] Approved by: maintainer [1] [2]
Diffstat (limited to 'games')
-rw-r--r--games/scorched3d/Makefile34
-rw-r--r--games/scorched3d/files/patch-configure.ac32
-rw-r--r--games/scorched3d/files/patch-src-3dsparse-aseFile.tab.cpp15
-rw-r--r--games/scorched3d/files/patch-src-GLEXT-GLBitmap.cpp11
-rw-r--r--games/scorched3d/files/patch-src-GLEXT-GLState.h11
-rw-r--r--games/scorched3d/files/patch-src-GLEXT-GLStateExtension.cpp11
-rw-r--r--games/scorched3d/files/patch-src-client-ClientMain.cpp11
-rw-r--r--games/scorched3d/files/patch-src-client-SoftwareMouse.cpp11
-rw-r--r--games/scorched3d/files/patch-src-client-UniqueIdStore.cpp11
-rw-r--r--games/scorched3d/files/patch-src-common-Clock.cpp11
-rw-r--r--games/scorched3d/files/patch-src-common-Display.h11
-rw-r--r--games/scorched3d/files/patch-src-common-Gamma.cpp11
-rw-r--r--games/scorched3d/files/patch-src-common-Gamma.h11
-rw-r--r--games/scorched3d/files/patch-src-common-KeyStateTranslate.h11
-rw-r--r--games/scorched3d/files/patch-src-common-KeyTranslate.h11
-rw-r--r--games/scorched3d/files/patch-src-common-KeyboardHistory.h11
-rw-r--r--games/scorched3d/files/patch-src-common-Logger.cpp11
-rw-r--r--games/scorched3d/files/patch-src-common-Mouse.h11
-rw-r--r--games/scorched3d/files/patch-src-common-RandomGenerator.cpp11
-rw-r--r--games/scorched3d/files/patch-src-coms-NetBuffer.cpp11
-rw-r--r--games/scorched3d/files/patch-src-coms-NetBuffer.h13
-rw-r--r--games/scorched3d/files/patch-src-coms-NetMessageHandler.h11
-rw-r--r--games/scorched3d/files/patch-src-coms-NetMessagePool.h11
-rw-r--r--games/scorched3d/files/patch-src-engine-MainLoop.cpp11
-rw-r--r--games/scorched3d/files/patch-src-ode-config.h11
-rw-r--r--games/scorched3d/files/patch-src-scorched-MainDialog.cpp13
-rw-r--r--games/scorched3d/files/patch-src-scorched-main.cpp11
-rw-r--r--games/scorched3d/files/patch-src-server-ServerBrowserInfo.h11
-rw-r--r--games/scorched3d/files/patch-src-server-ServerMain.cpp11
29 files changed, 54 insertions, 317 deletions
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 0f7b9bc0c8cd..8ed2bd950400 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -33,6 +33,7 @@ USE_GL= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER= 15
USE_AUTOCONF_VER= 253
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/scorched
AUTOMAKE_ARGS= --foreign
@@ -49,6 +50,39 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" \
.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -E 's,#include.*<SDL/(SDL.*\.h)>,#include <SDL11/\1>,g' \
+ ${WRKSRC}/configure.ac \
+ ${WRKSRC}/src/GLEXT/GLBitmap.cpp \
+ ${WRKSRC}/src/GLEXT/GLState.h \
+ ${WRKSRC}/src/GLEXT/GLStateExtension.cpp \
+ ${WRKSRC}/src/client/ClientMain.cpp \
+ ${WRKSRC}/src/client/SoftwareMouse.cpp \
+ ${WRKSRC}/src/client/UniqueIdStore.cpp \
+ ${WRKSRC}/src/common/Clock.cpp \
+ ${WRKSRC}/src/common/Display.h \
+ ${WRKSRC}/src/common/Gamma.cpp \
+ ${WRKSRC}/src/common/Gamma.h \
+ ${WRKSRC}/src/common/KeyStateTranslate.h \
+ ${WRKSRC}/src/common/KeyTranslate.h \
+ ${WRKSRC}/src/common/KeyboardHistory.h \
+ ${WRKSRC}/src/common/Logger.cpp \
+ ${WRKSRC}/src/common/Mouse.h \
+ ${WRKSRC}/src/common/RandomGenerator.cpp \
+ ${WRKSRC}/src/coms/NetBuffer.cpp \
+ ${WRKSRC}/src/coms/NetBuffer.h \
+ ${WRKSRC}/src/coms/NetMessageHandler.h \
+ ${WRKSRC}/src/coms/NetMessagePool.h \
+ ${WRKSRC}/src/engine/MainLoop.cpp \
+ ${WRKSRC}/src/scorched/MainDialog.cpp \
+ ${WRKSRC}/src/scorched/main.cpp \
+ ${WRKSRC}/src/server/ServerBrowserInfo.h \
+ ${WRKSRC}/src/server/ServerMain.cpp
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,g' \
+ ${WRKSRC}/src/3dsparse/aseFile.tab.cpp \
+ ${WRKSRC}/src/ode/config.h
+
+
pre-configure:
@cd ${WRKSRC}/scripts && ${PERL} createAMMakefile.pl
@cd ${WRKSRC} && ${ACLOCAL}
diff --git a/games/scorched3d/files/patch-configure.ac b/games/scorched3d/files/patch-configure.ac
index 5c94484018ea..fbc27d6bca59 100644
--- a/games/scorched3d/files/patch-configure.ac
+++ b/games/scorched3d/files/patch-configure.ac
@@ -1,13 +1,21 @@
---- ./configure.ac.orig Sat Aug 6 13:57:14 2005
-+++ ./configure.ac Tue Aug 9 23:20:58 2005
-@@ -37,8 +37,8 @@
- have_SDLnet=yes
- if test "x$enable_sdltest" = "xyes" ; then
- AC_TRY_COMPILE([
-- #include <SDL/SDL.h>
-- #include <SDL/SDL_net.h>
-+ #include <SDL11/SDL.h>
-+ #include <SDL11/SDL_net.h>
+--- configure.ac.orig Fri Oct 14 10:18:06 2005
++++ configure.ac Fri Oct 14 10:19:33 2005
+@@ -248,13 +248,13 @@
+ ])
+ fi
+
+-CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
+-CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
+-CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
++CPPFLAGS="$WX_CPPFLAGS $CPPFLAGS"
++CXXFLAGS="$WX_CXXFLAGS_ONLY $CXXFLAGS"
++CFLAGS="$WX_CFLAGS_ONLY $CFLAGS"
+ if test x"$use_static_wx" = x"yes"; then
+- LIBS="$LIBS $WX_LIBS_STATIC"
++ LIBS="$WX_LIBS_STATIC $LIBS"
+ else
+- LIBS="$LIBS $WX_LIBS"
++ LIBS="$WX_LIBS $LIBS"
+ fi
- int main(int argc, char *argv[])
- { return 0; }
+ dnl Check for FreeType2
diff --git a/games/scorched3d/files/patch-src-3dsparse-aseFile.tab.cpp b/games/scorched3d/files/patch-src-3dsparse-aseFile.tab.cpp
deleted file mode 100644
index 2107b3a2b0f9..000000000000
--- a/games/scorched3d/files/patch-src-3dsparse-aseFile.tab.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./src/3dsparse/aseFile.tab.cpp.orig Sat Aug 6 13:57:38 2005
-+++ ./src/3dsparse/aseFile.tab.cpp Tue Aug 9 23:21:13 2005
-@@ -329,10 +329,10 @@
- #include <alloca.h>
- #else /* not sparc */
- #if defined (MSDOS) && !defined (__TURBOC__)
--#include <malloc.h>
-+#include <stdlib.h>
- #else /* not MSDOS, or __TURBOC__ */
- #if defined(_AIX)
--#include <malloc.h>
-+#include <stdlib.h>
- #pragma alloca
- #else /* not MSDOS, __TURBOC__, or _AIX */
- #ifdef __hpux
diff --git a/games/scorched3d/files/patch-src-GLEXT-GLBitmap.cpp b/games/scorched3d/files/patch-src-GLEXT-GLBitmap.cpp
deleted file mode 100644
index 4a82afc04f4f..000000000000
--- a/games/scorched3d/files/patch-src-GLEXT-GLBitmap.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/GLEXT/GLBitmap.cpp.orig Sat Aug 6 13:57:38 2005
-+++ ./src/GLEXT/GLBitmap.cpp Tue Aug 9 23:21:13 2005
-@@ -22,7 +22,7 @@
- #include <math.h>
- #include <GLEXT/GLState.h>
- #include <GLEXT/GLBitmap.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- GLBitmap::GLBitmap() :
- width_(0), height_(0), alpha_(false), newbits_(0)
diff --git a/games/scorched3d/files/patch-src-GLEXT-GLState.h b/games/scorched3d/files/patch-src-GLEXT-GLState.h
deleted file mode 100644
index 1281b8e6efba..000000000000
--- a/games/scorched3d/files/patch-src-GLEXT-GLState.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/GLEXT/GLState.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/GLEXT/GLState.h Tue Aug 9 23:21:14 2005
-@@ -27,7 +27,7 @@
- #define AFX_GLSTATE_H__32B0E2D0_566D_4438_94E4_B12FE82430B1__INCLUDED_
-
- #define WIN32_LEAN_AND_MEAN // Exclude rarely-used stuff from Windows headers
--#include <SDL/SDL_opengl.h>
-+#include <SDL11/SDL_opengl.h>
- #include <common/Defines.h>
-
- class GLState
diff --git a/games/scorched3d/files/patch-src-GLEXT-GLStateExtension.cpp b/games/scorched3d/files/patch-src-GLEXT-GLStateExtension.cpp
deleted file mode 100644
index ec1afad997dd..000000000000
--- a/games/scorched3d/files/patch-src-GLEXT-GLStateExtension.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/GLEXT/GLStateExtension.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/GLEXT/GLStateExtension.cpp Tue Aug 9 23:21:14 2005
-@@ -21,7 +21,7 @@
- #include <GLEXT/GLStateExtension.h>
- #include <GLEXT/GLConsole.h>
- #include <common/OptionsDisplay.h> // Hmm library code pollution
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
- #include <string.h>
- #include <string>
-
diff --git a/games/scorched3d/files/patch-src-client-ClientMain.cpp b/games/scorched3d/files/patch-src-client-ClientMain.cpp
deleted file mode 100644
index 0297cf49023b..000000000000
--- a/games/scorched3d/files/patch-src-client-ClientMain.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/client/ClientMain.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/client/ClientMain.cpp Tue Aug 9 23:21:17 2005
-@@ -70,7 +70,7 @@
- #include <common/Gamma.h>
- #include <common/Clock.h>
- #include <sound/Sound.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- static int mouseEventCount = 0;
- static bool paused = false;
diff --git a/games/scorched3d/files/patch-src-client-SoftwareMouse.cpp b/games/scorched3d/files/patch-src-client-SoftwareMouse.cpp
deleted file mode 100644
index c5a621a032dd..000000000000
--- a/games/scorched3d/files/patch-src-client-SoftwareMouse.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/client/SoftwareMouse.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/client/SoftwareMouse.cpp Tue Aug 9 23:21:17 2005
-@@ -25,7 +25,7 @@
- #include <GLEXT/GLState.h>
- #include <common/Defines.h>
- #include <common/OptionsDisplay.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- SoftwareMouse *SoftwareMouse::instance_ = 0;
-
diff --git a/games/scorched3d/files/patch-src-client-UniqueIdStore.cpp b/games/scorched3d/files/patch-src-client-UniqueIdStore.cpp
deleted file mode 100644
index 9cd53cf4360b..000000000000
--- a/games/scorched3d/files/patch-src-client-UniqueIdStore.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/client/UniqueIdStore.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/client/UniqueIdStore.cpp Tue Aug 9 23:21:17 2005
-@@ -24,7 +24,7 @@
- #include <common/OptionsDisplay.h>
- #include <coms/NetInterface.h>
- #include <XML/XMLFile.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL_net.h>
- #include <stdlib.h>
-
- UniqueIdStore::UniqueIdStore()
diff --git a/games/scorched3d/files/patch-src-common-Clock.cpp b/games/scorched3d/files/patch-src-common-Clock.cpp
deleted file mode 100644
index 6d58c7fdbb1c..000000000000
--- a/games/scorched3d/files/patch-src-common-Clock.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Clock.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Clock.cpp Tue Aug 9 23:21:17 2005
-@@ -20,7 +20,7 @@
-
- #include <common/Defines.h>
- #include <common/Clock.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- Clock::Clock()
- {
diff --git a/games/scorched3d/files/patch-src-common-Display.h b/games/scorched3d/files/patch-src-common-Display.h
deleted file mode 100644
index 1bae05a7376b..000000000000
--- a/games/scorched3d/files/patch-src-common-Display.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Display.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Display.h Tue Aug 9 23:21:18 2005
-@@ -22,7 +22,7 @@
- #define _DISPLAY_H_
-
- #include <stdlib.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- class Display
- {
diff --git a/games/scorched3d/files/patch-src-common-Gamma.cpp b/games/scorched3d/files/patch-src-common-Gamma.cpp
deleted file mode 100644
index 250eb82f3d7d..000000000000
--- a/games/scorched3d/files/patch-src-common-Gamma.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Gamma.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Gamma.cpp Tue Aug 9 23:21:18 2005
-@@ -27,7 +27,7 @@
- #include <common/Gamma.h>
- #include <common/Defines.h>
- #include <math.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- //////////////////////////////////////////////////////////////////////
- // Construction/Destruction
diff --git a/games/scorched3d/files/patch-src-common-Gamma.h b/games/scorched3d/files/patch-src-common-Gamma.h
deleted file mode 100644
index c509cd42c580..000000000000
--- a/games/scorched3d/files/patch-src-common-Gamma.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Gamma.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Gamma.h Tue Aug 9 23:21:18 2005
-@@ -26,7 +26,7 @@
- //
- //////////////////////////////////////////////////////////////////////
-
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- struct GammaSettings
- {
diff --git a/games/scorched3d/files/patch-src-common-KeyStateTranslate.h b/games/scorched3d/files/patch-src-common-KeyStateTranslate.h
deleted file mode 100644
index 3e75b634cea6..000000000000
--- a/games/scorched3d/files/patch-src-common-KeyStateTranslate.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/KeyStateTranslate.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/KeyStateTranslate.h Tue Aug 9 23:21:18 2005
-@@ -19,7 +19,7 @@
- ////////////////////////////////////////////////////////////////////////////////
-
-
--#include <SDL/SDL_keysym.h>
-+#include <SDL11/SDL_keysym.h>
-
- struct KeyStateTranslation
- {
diff --git a/games/scorched3d/files/patch-src-common-KeyTranslate.h b/games/scorched3d/files/patch-src-common-KeyTranslate.h
deleted file mode 100644
index cac529212df2..000000000000
--- a/games/scorched3d/files/patch-src-common-KeyTranslate.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/KeyTranslate.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/KeyTranslate.h Tue Aug 9 23:21:18 2005
-@@ -19,7 +19,7 @@
- ////////////////////////////////////////////////////////////////////////////////
-
- #include <wx/defs.h>
--#include <SDL/SDL_keysym.h>
-+#include <SDL11/SDL_keysym.h>
-
- struct KeyTranslation
- {
diff --git a/games/scorched3d/files/patch-src-common-KeyboardHistory.h b/games/scorched3d/files/patch-src-common-KeyboardHistory.h
deleted file mode 100644
index 138f464f82e7..000000000000
--- a/games/scorched3d/files/patch-src-common-KeyboardHistory.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/KeyboardHistory.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/KeyboardHistory.h Tue Aug 9 23:21:18 2005
-@@ -26,7 +26,7 @@
- #if !defined(AFX_HISTORY_H__EFFEAE97_E779_4737_8DB4_B76AD9431BBC__INCLUDED_)
- #define AFX_HISTORY_H__EFFEAE97_E779_4737_8DB4_B76AD9431BBC__INCLUDED_
-
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- namespace KeyboardHistory
- {
diff --git a/games/scorched3d/files/patch-src-common-Logger.cpp b/games/scorched3d/files/patch-src-common-Logger.cpp
deleted file mode 100644
index 8f4cfba038d3..000000000000
--- a/games/scorched3d/files/patch-src-common-Logger.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Logger.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Logger.cpp Tue Aug 9 23:21:18 2005
-@@ -21,7 +21,7 @@
- #include <common/Defines.h>
- #include <common/Logger.h>
- #include <common/LoggerI.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
- #include <time.h>
- #include <stdio.h>
- #include <stdarg.h>
diff --git a/games/scorched3d/files/patch-src-common-Mouse.h b/games/scorched3d/files/patch-src-common-Mouse.h
deleted file mode 100644
index 7dbc782149ec..000000000000
--- a/games/scorched3d/files/patch-src-common-Mouse.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Mouse.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Mouse.h Tue Aug 9 23:21:18 2005
-@@ -23,7 +23,7 @@
- #define _MOUSE_H_
-
-
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- // Mouse.h: interface for the Mouse class.
- //
diff --git a/games/scorched3d/files/patch-src-common-RandomGenerator.cpp b/games/scorched3d/files/patch-src-common-RandomGenerator.cpp
deleted file mode 100644
index f98925bc2efb..000000000000
--- a/games/scorched3d/files/patch-src-common-RandomGenerator.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/RandomGenerator.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/RandomGenerator.cpp Tue Aug 9 23:21:18 2005
-@@ -20,7 +20,7 @@
-
- #include <common/RandomGenerator.h>
- #include <common/Defines.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL_net.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <limits.h>
diff --git a/games/scorched3d/files/patch-src-coms-NetBuffer.cpp b/games/scorched3d/files/patch-src-coms-NetBuffer.cpp
deleted file mode 100644
index d699c97a3f04..000000000000
--- a/games/scorched3d/files/patch-src-coms-NetBuffer.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/coms/NetBuffer.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/coms/NetBuffer.cpp Tue Aug 9 23:21:19 2005
-@@ -20,7 +20,7 @@
-
-
- #include <coms/NetBuffer.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL_net.h>
- #include <string.h>
-
- NetBuffer NetBufferDefault::defaultBuffer;
diff --git a/games/scorched3d/files/patch-src-coms-NetBuffer.h b/games/scorched3d/files/patch-src-coms-NetBuffer.h
deleted file mode 100644
index edc591087b05..000000000000
--- a/games/scorched3d/files/patch-src-coms-NetBuffer.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/coms/NetBuffer.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/coms/NetBuffer.h Tue Aug 9 23:21:19 2005
-@@ -23,8 +23,8 @@
-
- #include <string>
- #include <common/Vector.h>
--#include <SDL/SDL.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL.h>
-+#include <SDL11/SDL_net.h>
-
- class NetBuffer
- {
diff --git a/games/scorched3d/files/patch-src-coms-NetMessageHandler.h b/games/scorched3d/files/patch-src-coms-NetMessageHandler.h
deleted file mode 100644
index 2c0f9b1d8afa..000000000000
--- a/games/scorched3d/files/patch-src-coms-NetMessageHandler.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/coms/NetMessageHandler.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/coms/NetMessageHandler.h Tue Aug 9 23:21:19 2005
-@@ -23,7 +23,7 @@
- #define __INCLUDE_NetMessageHandlerh_INCLUDE__
-
- #include <coms/NetMessage.h>
--#include <SDL/SDL_thread.h>
-+#include <SDL11/SDL_thread.h>
- #include <list>
-
- class NetMessageHandlerI
diff --git a/games/scorched3d/files/patch-src-coms-NetMessagePool.h b/games/scorched3d/files/patch-src-coms-NetMessagePool.h
deleted file mode 100644
index a369992e6255..000000000000
--- a/games/scorched3d/files/patch-src-coms-NetMessagePool.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/coms/NetMessagePool.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/coms/NetMessagePool.h Tue Aug 9 23:21:19 2005
-@@ -24,7 +24,7 @@
-
- #include <coms/NetMessage.h>
- #include <list>
--#include <SDL/SDL_thread.h>
-+#include <SDL11/SDL_thread.h>
-
- class NetMessagePool
- {
diff --git a/games/scorched3d/files/patch-src-engine-MainLoop.cpp b/games/scorched3d/files/patch-src-engine-MainLoop.cpp
deleted file mode 100644
index da37336cfa88..000000000000
--- a/games/scorched3d/files/patch-src-engine-MainLoop.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/engine/MainLoop.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/engine/MainLoop.cpp Tue Aug 9 23:21:20 2005
-@@ -23,7 +23,7 @@
- #include <common/Defines.h>
- #include <GLEXT/GLState.h>
- #include <GLEXT/GLInfo.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- MainLoop::MainLoop() : exitLoop_(false), lastDrawTime_(0.0f), flip_(false)
- {
diff --git a/games/scorched3d/files/patch-src-ode-config.h b/games/scorched3d/files/patch-src-ode-config.h
deleted file mode 100644
index 160a9f545c26..000000000000
--- a/games/scorched3d/files/patch-src-ode-config.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/ode/config.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/ode/config.h Tue Aug 9 23:21:22 2005
-@@ -36,7 +36,7 @@
- #if defined(__DARWIN__)
- #include <sys/malloc.h>
- #else
--#include <malloc.h> // for alloca under windows
-+#include <stdlib.h> // for alloca under windows
- #endif
-
- #include <string.h>
diff --git a/games/scorched3d/files/patch-src-scorched-MainDialog.cpp b/games/scorched3d/files/patch-src-scorched-MainDialog.cpp
deleted file mode 100644
index 78a19891240c..000000000000
--- a/games/scorched3d/files/patch-src-scorched-MainDialog.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/scorched/MainDialog.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/scorched/MainDialog.cpp Tue Aug 9 23:21:23 2005
-@@ -26,8 +26,8 @@
- #include <wx/msgdlg.h>
- #define WIN32_LEAN_AND_MEAN
- #include <windows.h>
--#include <SDL/SDL.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL.h>
-+#include <SDL11/SDL_net.h>
- #include <scorched/MainDialog.h>
- #include <scorched/HtmlHelpDialog.h>
- #include <scorched/NetDialog.h>
diff --git a/games/scorched3d/files/patch-src-scorched-main.cpp b/games/scorched3d/files/patch-src-scorched-main.cpp
deleted file mode 100644
index 1424c58fe239..000000000000
--- a/games/scorched3d/files/patch-src-scorched-main.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/scorched/main.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/scorched/main.cpp Tue Aug 9 23:21:29 2005
-@@ -20,7 +20,7 @@
-
- #include <wx/wx.h>
- #include <wx/utils.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
- #include <client/ClientMain.h>
- #include <client/ClientSave.h>
- #include <client/ScorchedClient.h>
diff --git a/games/scorched3d/files/patch-src-server-ServerBrowserInfo.h b/games/scorched3d/files/patch-src-server-ServerBrowserInfo.h
deleted file mode 100644
index 1bc731328902..000000000000
--- a/games/scorched3d/files/patch-src-server-ServerBrowserInfo.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/server/ServerBrowserInfo.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/server/ServerBrowserInfo.h Tue Aug 9 23:21:30 2005
-@@ -21,7 +21,7 @@
- #if !defined(__INCLUDE_ServerBrowserInfoh_INCLUDE__)
- #define __INCLUDE_ServerBrowserInfoh_INCLUDE__
-
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL_net.h>
- #include <list>
- #include <string>
-
diff --git a/games/scorched3d/files/patch-src-server-ServerMain.cpp b/games/scorched3d/files/patch-src-server-ServerMain.cpp
deleted file mode 100644
index 613a412ad892..000000000000
--- a/games/scorched3d/files/patch-src-server-ServerMain.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/server/ServerMain.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/server/ServerMain.cpp Tue Aug 9 23:21:30 2005
-@@ -66,7 +66,7 @@
- #include <server/ServerBanned.h>
- #include <server/ScorchedServer.h>
- #include <server/ScorchedServerUtil.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- Clock serverTimer;
-
/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/devel?id=c5b472f3aaa029a9989a4a4ec0bc49d1487137d5'>- Cosmetic change in Makefile dependenciesmnag2006-02-202-4/+4 * BROKEN: Removes X11BASE/share/pixmaps directorykris2006-02-201-0/+2 * Try to remove www/datakris2006-02-203-0/+3 * BROKEN: Incomplete pkg-plistkris2006-02-201-0/+2 * RRDTool::OO is an object-oriented interface to Tobi Oetiker's round robinerwin2006-02-205-0/+53 * Fix the plist on architectures where bktr(4) isn't available.netchild2006-02-202-1/+7 * Remove deprecated USE_REINPLACEehaupt2006-02-192-2/+0 * Update to 0.55erwin2006-02-192-4/+4 * Update to 1.26erwin2006-02-192-4/+4 * Update to 1.1.13tmclaugh2006-02-192-5/+5 * - added RUN_DEPENDSaaron2006-02-193-0/+3 * Adding port devel/p5-Iterator-Misc, Miscellaneous iterator functions.aaron2006-02-195-0/+49 * Adding port devel/p5-Iterator-IO, Filesystem and stream iterators.aaron2006-02-195-0/+44 * Adding port devel/p5-Iterator-Util, Essential utilities for the Iterator class.aaron2006-02-195-0/+49 * Adding port devel/p5-Iterator, a general-purpose iterator class.aaron2006-02-195-0/+56 * Update to 2.103erwin2006-02-193-15/+43 * Adding port devel/p5-Test-RandomResults, allowing one to test non-determinist...aaron2006-02-185-0/+53 * - update from v0.07 to v0.08aaron2006-02-182-5/+5 * - Upgrade to 0.6a10.kuriyama2006-02-183-115/+115 * - Fix breakage when used with openssl from ports due to an openssl API changetmclaugh2006-02-182-4/+60 * - Patch to fix usage with C++mnag2006-02-182-0/+21 * - Update to 20060207mnag2006-02-182-4/+4 * Adding port devel/p5-FSA-Rules, an implementation of Finite State Automataaaron2006-02-185-0/+57 * Hide USE_RC_SUBR behind !defined(DBUS_SLAVE).marcus2006-02-182-1/+2 * Mark as broken on sparc64vd2006-02-171-1/+7 * Correct the expat shlib version from the update that was before this port wasanholt2006-02-171-1/+1 * - retire patch-Temp.pmleeym2006-02-172-13/+1 * - update to 0.3.1garga2006-02-162-4/+7 * Permit EMACS_PORT_NAME to be overwrited changing = to ?=garga2006-02-161-1/+1 * - Transfer all logic from removed devel/pcl-cvs-emacs to here cleaning emacs19garga2006-02-165-5/+129 * Chase updated binaries.lth2006-02-1612-84/+84 * Remove expired port editors/custom-emacs and all dependant portsgarga2006-02-166-165/+0 * Update to 0.33.1.novel2006-02-163-9/+14 * - Fix build on 7-current by avoiding conflict in si_band macro, thatbarner2006-02-162-3/+27 * Libdnsres provides a non-blocking thread-safe API for resolving DNS names. Itgarga2006-02-157-0/+105 * Update to 0.5.6.lawrance2006-02-153-9/+8 * Sync the configure options with devel/dbus.marcus2006-02-151-1/+1 * * Fix creation of the dbus system socketmarcus2006-02-153-41/+19 * - update to 0.56clsung2006-02-153-4/+5 * Update to 1.2.0, and use the new asciidoc port to generate and install manpages.anholt2006-02-153-7/+119 * - fix build on 64bit machines ("-fPIC"-dance) [1]netchild2006-02-153-9/+44 * Register CONFLICTS between ports that install bin/git.anholt2006-02-152-0/+4 * Add some autoconf-fu to please pointyhat (it's because this port is usednetchild2006-02-151-1/+1 * Update the plist to version 1.0.1 also.wes2006-02-152-112/+87 * * Point localstatedir to /var to prevent the creation of /usr/local/varmarcus2006-02-152-2/+4 * Fix build on 4.X.marcus2006-02-151-3/+16 * Commons IO is a library of utilities to assist with developing IO functionality.hq2006-02-144-0/+68 * When the GAM_POLLER option is disabled:jylefort2006-02-142-12/+73 * Update to 1.09.tobez2006-02-142-4/+4 * Update to 1.87.tobez2006-02-142-4/+4 * Update to 2.8.5.marcus2006-02-142-10/+41 * - Update to 0.31leeym2006-02-142-5/+13 * Unbreak compiles on FreeBSD 4.x. Newer Linux headers (gconv.h) containkan2006-02-141-0/+4 * - Update to 1.2.13hq2006-02-142-6/+5 * - Precompile python modules during install to satisfy pointyhatsem2006-02-132-4/+25 * Update to 2.04lth2006-02-132-4/+4 * Update to 1.03lth2006-02-132-4/+4 * Update to 2.97lth2006-02-132-4/+4 * Mark as IGNORE: hs-crypto is incompatible with current GHC, needs updating.vs2006-02-131-4/+1 * Update to 2.04lth2006-02-132-4/+4 * Upgrade to 2.9.2.thierry2006-02-132-6/+6 * BROKEN: Incorrect pkg-plistkris2006-02-131-0/+2 * BROKEN: Does not compilekris2006-02-131-0/+2 * Try to remove cgi-bin dirkris2006-02-131-0/+1 * BROKEN on 7.0: Segfault during buildkris2006-02-131-0/+4 * BROKEN on 7.0: Does not compilekris2006-02-131-0/+4 * BROKEN: Does not buildkris2006-02-132-0/+4 * Add missing LIB_DEPENDS on expat.anholt2006-02-131-0/+1 * Update to 2.08erwin2006-02-132-5/+5 * Update to 0.3.lawrance2006-02-12