aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2012-05-15 02:11:46 +0800
committermva <mva@FreeBSD.org>2012-05-15 02:11:46 +0800
commit2906ff972809094496af6197253e0727ed2fb0b6 (patch)
treea26e7710665bdc02203b6fd26b543c745a8f6af2 /games
parentb621cd15a757478134e5e46903549ea1f47bc2b9 (diff)
downloadfreebsd-ports-gnome-2906ff972809094496af6197253e0727ed2fb0b6.tar.gz
freebsd-ports-gnome-2906ff972809094496af6197253e0727ed2fb0b6.tar.zst
freebsd-ports-gnome-2906ff972809094496af6197253e0727ed2fb0b6.zip
This is an implementation of the sets game.
WWW: http://www.linuxmotors.com/sets/ PR: ports/167237 Submitted by: nemysis@gmx.ch
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/sets/Makefile40
-rw-r--r--games/sets/distinfo2
-rw-r--r--games/sets/files/patch-Makefile10
-rw-r--r--games/sets/pkg-descr3
5 files changed, 56 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 6bf08a926cc7..1086cc46d40d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -804,6 +804,7 @@
SUBDIR += secretmaryochronicles
SUBDIR += secretmaryochronicles-music
SUBDIR += senken
+ SUBDIR += sets
SUBDIR += sex
SUBDIR += sfbol
SUBDIR += shaaft
diff --git a/games/sets/Makefile b/games/sets/Makefile
new file mode 100644
index 000000000000..87164639c203
--- /dev/null
+++ b/games/sets/Makefile
@@ -0,0 +1,40 @@
+# New Ports collection makefile for: sets
+# Date created: 2012-04-21
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= sets
+PORTVERSION= 1.0.0
+CATEGORIES= games
+MASTER_SITES= http://www.linuxmotors.com/sets/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= This is an implementation of the sets game
+
+LICENSE= GPLv3
+
+USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+USE_SDL= sdl image
+
+PLIST_FILES= bin/sets
+
+PORTDOCS= README
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/sets/distinfo b/games/sets/distinfo
new file mode 100644
index 000000000000..9aa7680a730c
--- /dev/null
+++ b/games/sets/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sets-1.0.0.tgz) = 2521ea6352a7925965051897e9c92293cccf72d27968eca142b79b88e6700aab
+SIZE (sets-1.0.0.tgz) = 10108
diff --git a/games/sets/files/patch-Makefile b/games/sets/files/patch-Makefile
new file mode 100644
index 000000000000..b58e98c448a3
--- /dev/null
+++ b/games/sets/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2008-07-30 17:51:49.000000000 +0200
++++ Makefile 2012-04-21 14:25:52.000000000 +0200
+@@ -1,5 +1,5 @@
+-CFLAGS = -O2 -Wall $(shell sdl-config --cflags)
+-LDFLAGS = -lm $(shell sdl-config --libs)
++CFLAGS = $(shell ${SDL_CONFIG} --cflags)
++LDFLAGS = -lm $(shell ${SDL_CONFIG} --libs)
+
+ all: sets
+
diff --git a/games/sets/pkg-descr b/games/sets/pkg-descr
new file mode 100644
index 000000000000..4d38b2a1a19c
--- /dev/null
+++ b/games/sets/pkg-descr
@@ -0,0 +1,3 @@
+This is an implementation of the sets game.
+
+WWW: http://www.linuxmotors.com/sets/