aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-19 13:10:16 +0800
committeredwin <edwin@FreeBSD.org>2002-11-19 13:10:16 +0800
commit296209bedefad7a878078b5104ff989f7a1a0ef0 (patch)
treeb163dca2f882466c439535c1b5235e2688928945 /games
parent68b1e8a25e7038655f61323ef3b1a6a2a2aee275 (diff)
downloadfreebsd-ports-gnome-296209bedefad7a878078b5104ff989f7a1a0ef0.tar.gz
freebsd-ports-gnome-296209bedefad7a878078b5104ff989f7a1a0ef0.tar.zst
freebsd-ports-gnome-296209bedefad7a878078b5104ff989f7a1a0ef0.zip
Update patch-files to build again on -current.
Noticed by: bento
Diffstat (limited to 'games')
-rw-r--r--games/flying/Makefile1
-rw-r--r--games/flying/files/patch-aa11
-rw-r--r--games/flying/files/patch-ac13
3 files changed, 22 insertions, 3 deletions
diff --git a/games/flying/Makefile b/games/flying/Makefile
index e5fb554cdaad..fb3b3296b2d8 100644
--- a/games/flying/Makefile
+++ b/games/flying/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flying
PORTVERSION= 6.20
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/arcade
diff --git a/games/flying/files/patch-aa b/games/flying/files/patch-aa
index 79f7245d1216..bf31279122f0 100644
--- a/games/flying/files/patch-aa
+++ b/games/flying/files/patch-aa
@@ -1,5 +1,5 @@
--- Imakefile.orig Tue Oct 3 16:01:36 1995
-+++ Imakefile Wed Aug 7 20:53:56 1996
++++ Imakefile Tue Nov 19 06:08:52 2002
@@ -1,6 +1,6 @@
XCOMM ##### where to put temporary data and pixmap files ...
@@ -8,6 +8,15 @@
XCOMM ##### parameter type of the system call select(), which usually is
XCOMM ##### fd_set, but at least on HP-UX, it is int ... I am still
+@@ -12,7 +12,7 @@
+ XCOMM ##### There is an optimization bug in gcc-2.7.0. Therefore the CXX_NOOPT
+ XCOMM ##### macro should be set when using gcc-2.7.0 to create target
+ XCOMM ##### pball.o without optimization
+-CXX = gcc
++CXX = g++
+ XCOMM # CXX_NOOPT = -O0
+
+ XCOMM #######################################################################
@@ -30,7 +30,7 @@
CCOPTIONS = #-Wall -g
diff --git a/games/flying/files/patch-ac b/games/flying/files/patch-ac
index 3cd229238fce..5df22e61b4e7 100644
--- a/games/flying/files/patch-ac
+++ b/games/flying/files/patch-ac
@@ -1,5 +1,5 @@
---- xgraph.C.orig Sun Jan 9 01:11:55 2000
-+++ xgraph.C Sun Jan 9 01:12:25 2000
+--- xgraph.C.orig Mon Aug 7 23:26:57 1995
++++ xgraph.C Tue Nov 19 06:05:22 2002
@@ -603,7 +603,7 @@
XSizeHints hints;
XEvent event;
@@ -9,3 +9,12 @@
hints.flags = PPosition | PSize | PAspect | PMinSize | PMaxSize;
hints.x = DisplayWidth(dpy,scr) -offx-width-frame;
+@@ -918,7 +918,7 @@
+ XFillPolygon( dpy,win,gc_current,p,n,0,0);
+
+ if (p!=buffer) delete p;
+- va_end(arg_ptr);
++ va_end(argptr);
+ }
+
+ void FillPoly( int n, Vec2 v[] ) {