aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-26 09:06:38 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-26 09:06:38 +0800
commit2995bf382061966541ff4d903826e01ba089f7ce (patch)
treedb34bd68977c3abe3cf4772e2d7c93001db041c1 /games
parent8bf83d5c520ca20b106dfc148d4bffae9b400dda (diff)
downloadfreebsd-ports-gnome-2995bf382061966541ff4d903826e01ba089f7ce.tar.gz
freebsd-ports-gnome-2995bf382061966541ff4d903826e01ba089f7ce.tar.zst
freebsd-ports-gnome-2995bf382061966541ff4d903826e01ba089f7ce.zip
The Secret Tower is a 2D platform game in which you must save the
princess Ericia, prisoner in the secret citadel. The many floors are only composed of blocks: you can destroy them, move them or build them to climb the levels and fight monsters living in this tower. WWW: https://github.com/dusty141/TheSecretTower
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/secrettower/Makefile55
-rw-r--r--games/secrettower/distinfo2
-rw-r--r--games/secrettower/files/pkg-deinstall.in18
-rw-r--r--games/secrettower/files/secrettower.in7
-rw-r--r--games/secrettower/pkg-descr6
-rw-r--r--games/secrettower/pkg-plist133
7 files changed, 222 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index c0816bf2682a..569c63e9464c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -874,6 +874,7 @@
SUBDIR += searchandrescue-data
SUBDIR += secretmaryochronicles
SUBDIR += secretmaryochronicles-music
+ SUBDIR += secrettower
SUBDIR += senken
SUBDIR += sets
SUBDIR += sex
diff --git a/games/secrettower/Makefile b/games/secrettower/Makefile
new file mode 100644
index 000000000000..bc632da3fac8
--- /dev/null
+++ b/games/secrettower/Makefile
@@ -0,0 +1,55 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= secrettower
+PORTVERSION= 0.2.0
+CATEGORIES= games python
+DIST_SUBDIR= python
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Save princess Ericia in this 2D platform game
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYGAME}
+
+USE_GITHUB= yes
+GH_ACCOUNT= dusty141
+GH_PROJECT= TheSecretTower
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= ecf13e4
+
+USES= shebangfix
+SHEBANG_FILES= TheSecretTower.py server.py
+USE_PYTHON= 2
+
+PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= ${PORTNAME} pkg-deinstall
+
+DESKTOP_ENTRIES="The Secret Tower" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
+do-build:
+ @${PYTHON_CMD} -m compileall ${WRKSRC}
+ @${PYTHON_CMD} -O -m compileall ${WRKSRC}
+
+do-install:
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
+ ${WRKDIR}/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+.for d in data img sound
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+.for f in *.py *.pyc *.pyo
+ @(cd ${WRKSRC} && ${INSTALL_SCRIPT} ${f} ${STAGEDIR}${DATADIR})
+.endfor
+ ${LN} -sf ${DATADIR}/img/perso_small.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ @(cd ${STAGEDIR}${DATADIR} && ${CHMOD} -R 775 data)
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/secrettower/distinfo b/games/secrettower/distinfo
new file mode 100644
index 000000000000..f325edc2fe2b
--- /dev/null
+++ b/games/secrettower/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/secrettower-0.2.0.tar.gz) = 10d3fe08669e8bc9652331901d440bd18f132bd276bb2ab196b85c4bd10b8c67
+SIZE (python/secrettower-0.2.0.tar.gz) = 4019504
diff --git a/games/secrettower/files/pkg-deinstall.in b/games/secrettower/files/pkg-deinstall.in
new file mode 100644
index 000000000000..4b297e3acd1f
--- /dev/null
+++ b/games/secrettower/files/pkg-deinstall.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ echo ""
+ echo ""
+ echo "==============================================================================="
+ echo ""
+ echo "After deinstallation, some files may stay in %%DATADIR%%,"
+ echo "you can delete them with"
+ echo ""
+ echo " /bin/rm -fr %%DATADIR%%"
+ echo ""
+ echo "==============================================================================="
+ echo ""
+fi
diff --git a/games/secrettower/files/secrettower.in b/games/secrettower/files/secrettower.in
new file mode 100644
index 000000000000..a1f8b8aae971
--- /dev/null
+++ b/games/secrettower/files/secrettower.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec %%PYTHON_CMD%% ./TheSecretTower.py
diff --git a/games/secrettower/pkg-descr b/games/secrettower/pkg-descr
new file mode 100644
index 000000000000..5c4f78db4918
--- /dev/null
+++ b/games/secrettower/pkg-descr
@@ -0,0 +1,6 @@
+The Secret Tower is a 2D platform game in which you must save the
+princess Ericia, prisoner in the secret citadel.
+The many floors are only composed of blocks: you can destroy them, move them
+or build them to climb the levels and fight monsters living in this tower.
+
+WWW: https://github.com/dusty141/TheSecretTower
diff --git a/games/secrettower/pkg-plist b/games/secrettower/pkg-plist
new file mode 100644
index 000000000000..260c78058c4a
--- /dev/null
+++ b/games/secrettower/pkg-plist
@@ -0,0 +1,133 @@
+bin/secrettower
+share/pixmaps/secrettower.png
+%%DATADIR%%/TheSecretTower.py
+%%DATADIR%%/TheSecretTower.pyc
+%%DATADIR%%/TheSecretTower.pyo
+%%DATADIR%%/app.py
+%%DATADIR%%/app.pyc
+%%DATADIR%%/app.pyo
+%%DATADIR%%/atelier.py
+%%DATADIR%%/atelier.pyc
+%%DATADIR%%/atelier.pyo
+%%DATADIR%%/bloc.py
+%%DATADIR%%/bloc.pyc
+%%DATADIR%%/bloc.pyo
+%%DATADIR%%/char.py
+%%DATADIR%%/char.pyc
+%%DATADIR%%/char.pyo
+%%DATADIR%%/client.py
+%%DATADIR%%/client.pyc
+%%DATADIR%%/client.pyo
+%%DATADIR%%/const.py
+%%DATADIR%%/const.pyc
+%%DATADIR%%/const.pyo
+%%DATADIR%%/data/map/std/map0
+%%DATADIR%%/data/map/std/map1
+%%DATADIR%%/data/map/std/map10
+%%DATADIR%%/data/map/std/map11
+%%DATADIR%%/data/map/std/map12
+%%DATADIR%%/data/map/std/map13
+%%DATADIR%%/data/map/std/map14
+%%DATADIR%%/data/map/std/map15
+%%DATADIR%%/data/map/std/map16
+%%DATADIR%%/data/map/std/map17
+%%DATADIR%%/data/map/std/map18
+%%DATADIR%%/data/map/std/map19
+%%DATADIR%%/data/map/std/map2
+%%DATADIR%%/data/map/std/map3
+%%DATADIR%%/data/map/std/map4
+%%DATADIR%%/data/map/std/map5
+%%DATADIR%%/data/map/std/map6
+%%DATADIR%%/data/map/std/map7
+%%DATADIR%%/data/map/std/map8
+%%DATADIR%%/data/map/std/map9
+%%DATADIR%%/editeur.py
+%%DATADIR%%/editeur.pyc
+%%DATADIR%%/editeur.pyo
+%%DATADIR%%/element.py
+%%DATADIR%%/element.pyc
+%%DATADIR%%/element.pyo
+%%DATADIR%%/event.py
+%%DATADIR%%/event.pyc
+%%DATADIR%%/event.pyo
+%%DATADIR%%/img/arm_perso.png
+%%DATADIR%%/img/bloc.png
+%%DATADIR%%/img/choix.png
+%%DATADIR%%/img/coeur.png
+%%DATADIR%%/img/coeur_vide.png
+%%DATADIR%%/img/degats.png
+%%DATADIR%%/img/energie.png
+%%DATADIR%%/img/fire.png
+%%DATADIR%%/img/fond1.png
+%%DATADIR%%/img/fond2.png
+%%DATADIR%%/img/fond_chest.png
+%%DATADIR%%/img/fond_inv.png
+%%DATADIR%%/img/fond_menu.png
+%%DATADIR%%/img/font.ttf
+%%DATADIR%%/img/interface.png
+%%DATADIR%%/img/item.png
+%%DATADIR%%/img/lave.png
+%%DATADIR%%/img/mobs.png
+%%DATADIR%%/img/perso.png
+%%DATADIR%%/img/perso_small.png
+%%DATADIR%%/img/pointeur.png
+%%DATADIR%%/img/select.png
+%%DATADIR%%/img/torch.png
+%%DATADIR%%/img/vide.png
+%%DATADIR%%/item.py
+%%DATADIR%%/item.pyc
+%%DATADIR%%/item.pyo
+%%DATADIR%%/jeu.py
+%%DATADIR%%/jeu.pyc
+%%DATADIR%%/jeu.pyo
+%%DATADIR%%/map.py
+%%DATADIR%%/map.pyc
+%%DATADIR%%/map.pyo
+%%DATADIR%%/menu.py
+%%DATADIR%%/menu.pyc
+%%DATADIR%%/menu.pyo
+%%DATADIR%%/mob.py
+%%DATADIR%%/mob.pyc
+%%DATADIR%%/mob.pyo
+%%DATADIR%%/particule.py
+%%DATADIR%%/particule.pyc
+%%DATADIR%%/particule.pyo
+%%DATADIR%%/perso.py
+%%DATADIR%%/perso.pyc
+%%DATADIR%%/perso.pyo
+%%DATADIR%%/server.py
+%%DATADIR%%/server.pyc
+%%DATADIR%%/server.pyo
+%%DATADIR%%/sound/New Text Document.txt
+%%DATADIR%%/sound/click.wav
+%%DATADIR%%/sound/dirt.wav
+%%DATADIR%%/sound/door.wav
+%%DATADIR%%/sound/fire.mp3
+%%DATADIR%%/sound/fire.wav
+%%DATADIR%%/sound/fireworks1.wav
+%%DATADIR%%/sound/fireworks2.wav
+%%DATADIR%%/sound/goblin1.wav
+%%DATADIR%%/sound/goblin2.wav
+%%DATADIR%%/sound/hurt1.wav
+%%DATADIR%%/sound/hurt2.wav
+%%DATADIR%%/sound/keeper1.wav
+%%DATADIR%%/sound/keeper2.wav
+%%DATADIR%%/sound/keeper3.wav
+%%DATADIR%%/sound/step1.wav
+%%DATADIR%%/sound/step2.wav
+%%DATADIR%%/sound/stone1.wav
+%%DATADIR%%/sound/stone2.wav
+%%DATADIR%%/sound/stone3.wav
+%%DATADIR%%/sound/sword1.wav
+%%DATADIR%%/sound/sword2.wav
+%%DATADIR%%/sound/wood1.wav
+%%DATADIR%%/sound/wood2.wav
+%%DATADIR%%/sound/zombie1.wav
+%%DATADIR%%/sound/zombie2.wav
+%%DATADIR%%/sound/zombie3.wav
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/data/map/std
+@dirrm %%DATADIR%%/data/map
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%