aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-03-21 03:50:18 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-03-21 03:50:18 +0800
commit29e6a0334773eea95b9347e68309e9fb40a58fb1 (patch)
treefa7886ae10675041361809cb6c203f0ee40a84ee /games
parentad4aadf999d3d4e44293fded601fb4ef1399362a (diff)
downloadfreebsd-ports-gnome-29e6a0334773eea95b9347e68309e9fb40a58fb1.tar.gz
freebsd-ports-gnome-29e6a0334773eea95b9347e68309e9fb40a58fb1.tar.zst
freebsd-ports-gnome-29e6a0334773eea95b9347e68309e9fb40a58fb1.zip
Add hex-a-hop 1.0.0, a puzzle game based on hexagonal tiles.
PR: 93619 Submitted by: Jamie Jones <jamie@bishopston.net>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/hex-a-hop/Makefile33
-rw-r--r--games/hex-a-hop/distinfo3
-rw-r--r--games/hex-a-hop/pkg-descr9
-rw-r--r--games/hex-a-hop/pkg-plist14
5 files changed, 60 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index c4533ea8fd3f..82e8857b63c1 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -270,6 +270,7 @@
SUBDIR += heretic
SUBDIR += heroes
SUBDIR += hex
+ SUBDIR += hex-a-hop
SUBDIR += highmoon
SUBDIR += hlserver-admin
SUBDIR += hlserver-cs
diff --git a/games/hex-a-hop/Makefile b/games/hex-a-hop/Makefile
new file mode 100644
index 000000000000..09a475dab92c
--- /dev/null
+++ b/games/hex-a-hop/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hex-a-hop
+# Date created: 21 February 2006
+# Whom: jamie
+#
+# $FreeBSD$
+#
+
+PORTNAME= hex-a-hop
+PORTVERSION= 1.0.0
+CATEGORIES= games
+MASTER_SITES= http://ftp.bishopston.net/freebsd/distfiles/ \
+ ftp://ftp.bishopston.net/freebsd/distfiles/
+
+MAINTAINER= jamie@bishopston.net
+COMMENT= A puzzle game based on hexagonal tiles
+
+USE_SDL= sdl
+
+MAKEFILE= Makefile.FreeBSD
+ALL_TARGET= ${PORTNAME}
+
+MAKE_ARGS+= SYSTEM_INSTALL_DIR="${PREFIX}/games/hex-a-hop/"
+DESKTOP_ENTRIES="Hex-a-Hop" "A puzzle game based on hexagonal tiles" \
+ "${PREFIX}/games/hex-a-hop/graphics/icon.bmp" \
+ "hex-a-hop" "Application;LogicGame;Game;" false
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hex-a-hop ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/games/hex-a-hop/graphics/
+ ${INSTALL_DATA} ${WRKSRC}/graphics/* ${PREFIX}/games/hex-a-hop/graphics
+ ${INSTALL_DATA} ${WRKSRC}/levels.dat ${PREFIX}/games/hex-a-hop
+
+.include <bsd.port.mk>
diff --git a/games/hex-a-hop/distinfo b/games/hex-a-hop/distinfo
new file mode 100644
index 000000000000..565e3a1c2f7b
--- /dev/null
+++ b/games/hex-a-hop/distinfo
@@ -0,0 +1,3 @@
+MD5 (hex-a-hop-1.0.0.tar.gz) = 0f8623f061eee8508d8ca78d86ed15e2
+SHA256 (hex-a-hop-1.0.0.tar.gz) = 200b2b88133f532419398224d29d72ca394168fbc7646b7ce50985867ac275a7
+SIZE (hex-a-hop-1.0.0.tar.gz) = 883536
diff --git a/games/hex-a-hop/pkg-descr b/games/hex-a-hop/pkg-descr
new file mode 100644
index 000000000000..27af79d2e9fc
--- /dev/null
+++ b/games/hex-a-hop/pkg-descr
@@ -0,0 +1,9 @@
+Hex-a-hop is a puzzle game based on hexagonal tiles. There is no time limit and
+no real-time elements.
+
+The objective is simply to destroy all the green hexagonal tiles on each of the
+100 levels. As you progress through the game, more types of tiles are introduced
+which make things more difficult and interesting (hopefully).
+
+Author: Tom Beaumont <tombeaumont@yahoo.com>
+WWW: http://www.aceinternet.co.uk/~mokona/
diff --git a/games/hex-a-hop/pkg-plist b/games/hex-a-hop/pkg-plist
new file mode 100644
index 000000000000..80c586862bba
--- /dev/null
+++ b/games/hex-a-hop/pkg-plist
@@ -0,0 +1,14 @@
+bin/hex-a-hop
+games/hex-a-hop/graphics/emi.dat
+games/hex-a-hop/graphics/font.dat
+games/hex-a-hop/graphics/gradient.dat
+games/hex-a-hop/graphics/icon.bmp
+games/hex-a-hop/graphics/map.dat
+games/hex-a-hop/graphics/map_top.dat
+games/hex-a-hop/graphics/tiles.dat
+games/hex-a-hop/graphics/tiles_reflect.dat
+games/hex-a-hop/graphics/title.dat
+games/hex-a-hop/levels.dat
+@dirrm games/hex-a-hop/graphics/
+@dirrm games/hex-a-hop/
+@dirrmtry games/