diff options
author | jbeich <jbeich@FreeBSD.org> | 2016-12-24 08:46:35 +0800 |
---|---|---|
committer | jbeich <jbeich@FreeBSD.org> | 2016-12-24 08:46:35 +0800 |
commit | 2e0a7fe0df3de4f8ab4c59734a93127db59283fb (patch) | |
tree | db0b0a558925977474802413d6f81439288eb001 /games | |
parent | 1121a316f85bf9e73a01bbb6978bf1fd512c8928 (diff) | |
download | freebsd-ports-gnome-2e0a7fe0df3de4f8ab4c59734a93127db59283fb.tar.gz freebsd-ports-gnome-2e0a7fe0df3de4f8ab4c59734a93127db59283fb.tar.zst freebsd-ports-gnome-2e0a7fe0df3de4f8ab4c59734a93127db59283fb.zip |
games/openbor: fix bogus but unused substitution
--- version.sh.bak 2016-11-05 19:01:19 UTC
+++ version.sh
@@ -27,7 +27,7 @@ fi
}
# Support the Bazaar VCS as an alternative to SVN through the bzr-svn plugin
-function get_revnum {
+VERSION_BUILD=4420() {
if test -d "../.svn" || test -d "./.svn"; then
VERSION_BUILD=`svn info | grep "Last Changed Rev" | sed s/Last\ Changed\ Rev:\ //g`
elif test -d ".bzr"; then
Diffstat (limited to 'games')
-rw-r--r-- | games/openbor/Makefile | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile index 32e8291505d8..79ff9f82b61c 100644 --- a/games/openbor/Makefile +++ b/games/openbor/Makefile @@ -95,7 +95,7 @@ post-patch: @${GREP} -Flr 'malloc.h' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \ 's,malloc\.h,stdlib.h,' @${REINPLACE_CMD} -e 's/^function \(.*\) {/\1() {/' \ - -e 's/^get_revnum/VERSION_BUILD=${SVN_REV}/' \ + -e 's/^get_revnum$$/VERSION_BUILD=${SVN_REV}/' \ ${WRKSRC}/version.sh do-configure: |