aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-03 04:23:55 +0800
committerKoop Mast <kwm@FreeBSD.org>2015-08-03 04:23:55 +0800
commit2f0486b64721a1072cdd1b8d2840d6539b2247d2 (patch)
tree36ed89e03b0f2ac4525ba4f4e39af16da597b209 /games
parent05aa1eb8b1e5d76cddd216c787c98b5cfe7db1e9 (diff)
downloadfreebsd-ports-gnome-2f0486b64721a1072cdd1b8d2840d6539b2247d2.tar.gz
freebsd-ports-gnome-2f0486b64721a1072cdd1b8d2840d6539b2247d2.tar.zst
freebsd-ports-gnome-2f0486b64721a1072cdd1b8d2840d6539b2247d2.zip
Part 1 of adding USE_GNOME=intltool to ports that require it.
The reason for this is that in the GNOME 3.16 update, USE_GNOME gtk20 and gtk30 don't pull intltool in anymore. PR: 201980 Exp-run by: antoine@
Diffstat (limited to 'games')
-rw-r--r--games/gbrainy/Makefile2
-rw-r--r--games/gnono/Makefile2
-rw-r--r--games/gtetrinet/Makefile2
-rw-r--r--games/lordsawar/Makefile2
-rw-r--r--games/pioneers/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/games/gbrainy/Makefile b/games/gbrainy/Makefile
index b99e3f3521df..31b8fa809607 100644
--- a/games/gbrainy/Makefile
+++ b/games/gbrainy/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= mautil:${PORTSDIR}/devel/mono-addins \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_GNOME= gtksharp20 gnomesharp20 gnomedocutils
+USE_GNOME= gtksharp20 gnomesharp20 gnomedocutils intltool
USES= gettext gmake mono pathfix pkgconfig \
shebangfix
SHEBANG_FILES= src/Clients/Classical/gbrainy.in
diff --git a/games/gnono/Makefile b/games/gnono/Makefile
index defe3b305180..2d1544e2cfe7 100644
--- a/games/gnono/Makefile
+++ b/games/gnono/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Uno card game
-USE_GNOME= gtk20 libgnomeui
+USE_GNOME= gtk20 libgnomeui intltool
USES= gettext gmake pkgconfig tar:bzip2
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/games/gtetrinet/Makefile b/games/gtetrinet/Makefile
index 9f9dd940b3a1..f3315747b37e 100644
--- a/games/gtetrinet/Makefile
+++ b/games/gtetrinet/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
USES= pathfix gettext gmake pkgconfig tar:bzip2
-USE_GNOME= esound gnomeprefix libgnomeui
+USE_GNOME= esound gnomeprefix intltool libgnomeui
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/lordsawar/Makefile b/games/lordsawar/Makefile
index 67858ee9a90c..fea0c2936a1c 100644
--- a/games/lordsawar/Makefile
+++ b/games/lordsawar/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libtar.so:${PORTSDIR}/devel/libtar \
libgnet-2.0.so:${PORTSDIR}/net/gnet2
USES= gettext gmake pkgconfig
-USE_GNOME= gtkmm24
+USE_GNOME= gtkmm24 intltool
USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-boost-includedir=${LOCALBASE}/include
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index 0e8e1241b8ee..63eeb816dd16 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
RUN_DEPENDS= yelp:${PORTSDIR}/x11/yelp
USES= gettext gmake
-USE_GNOME= gnomeprefix gtk20 libgnome librsvg2
+USE_GNOME= gnomeprefix gtk20 intltool libgnome librsvg2
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes