aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-04-28 11:18:00 +0800
committerdanfe <danfe@FreeBSD.org>2013-04-28 11:18:00 +0800
commit2fd39f75ba591f731c6b4b21b3591accd714aed8 (patch)
treed4fb7a6a08612987aadf1695770d1d01f9f91a35 /games
parentb5a704d335432807f0308662bec785a0a2ec51ff (diff)
downloadfreebsd-ports-gnome-2fd39f75ba591f731c6b4b21b3591accd714aed8.tar.gz
freebsd-ports-gnome-2fd39f75ba591f731c6b4b21b3591accd714aed8.tar.zst
freebsd-ports-gnome-2fd39f75ba591f731c6b4b21b3591accd714aed8.zip
- Convert to modern OPTIONS framework (courtesy of jgh@)
- Trim the header, drop shlib ABI versions, misc. cleanups - Cleanup port description, remove defunct web address
Diffstat (limited to 'games')
-rw-r--r--games/quake2max/Makefile67
-rw-r--r--games/quake2max/pkg-descr42
-rw-r--r--games/quake2max/pkg-plist2
3 files changed, 54 insertions, 57 deletions
diff --git a/games/quake2max/Makefile b/games/quake2max/Makefile
index c26dcf6b2a16..0c8387120b9a 100644
--- a/games/quake2max/Makefile
+++ b/games/quake2max/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: quake2max
-# Date created: 24 Jul 2006
-# Whom: alepulver
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= quake2max
PORTVERSION= 0.45
@@ -18,9 +14,11 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:src \
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= An OpenGL only Quake II engine modification
+COMMENT= OpenGL-only Quake II engine modification
-EXTRACT_DEPENDS=unrar:${PORTSDIR}/archivers/unrar
+LICENSE= GPLv2
+
+EXTRACT_DEPENDS= unrar:${PORTSDIR}/archivers/unrar
USE_BZIP2= yes
USE_GMAKE= yes
@@ -28,35 +26,35 @@ USE_XORG= xxf86dga
ALL_TARGET= release
WRKSRC= ${WRKDIR}/${DISTNAME:S/quake2max/Quake2maX/}
-OPTIONS= CLIENT "Build client" on \
- DEDICATED "Build dedicated server" on \
- GAME "Build a main game .so file" off \
- GLX "Build OpenGL renderer" on \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- SDL "Build SDL client" on \
- SDLGL "Build SDL OpenGL renderer" on
-
+LIBDIR= ${PREFIX}/lib/${PORTNAME}
MAKE_ENV= LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
-LIBDIR= ${PREFIX}/lib/${PORTNAME}
Q2MAX_DATA= ${PORTNAME}.044.rar
-.include "${.CURDIR}/../quake2-data/Makefile.include"
+OPTIONS_DEFINE= CLIENT DEDICATED GAME GLX OPTIMIZED_CFLAGS SDLCLIENT SDLGL
+OPTIONS_DEFAULT= CLIENT DEDICATED GLX OPTIMIZED_CFLAGS SDLCLIENT SDLGL
+
+CLIENT_DESC= Build original client
+DEDICATED_DESC= Build dedicated server
+GAME_DESC= Build main game (default mod)
+GLX_DESC= Build OpenGL renderer
+SDLCLIENT_DESC= Build SDL client
+SDLGL_DESC= Build SDL OpenGL renderer
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GLX) || defined(WITH_SDLGL)
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
+.if ${PORT_OPTIONS:MGLX} || ${PORT_OPTIONS:MSDLGL}
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
-USE_GL= yes
+USE_GL= glu
.endif
-.if defined(WITH_SDL) || defined(WITH_SDLGL)
+.if ${PORT_OPTIONS:MSDLCLIENT} || ${PORT_OPTIONS:MSDLGL}
USE_SDL= yes
.endif
-.if defined(WITH_CLIENT)
+.if ${PORT_OPTIONS:MCLIENT}
MAKE_ENV+= BUILD_QUAKE2MAX=YES
PLIST_SUB+= CLIENT=""
Q2MAX_BIN+= quake2max
@@ -64,7 +62,7 @@ Q2MAX_BIN+= quake2max
PLIST_SUB+= CLIENT="@comment "
.endif
-.if defined(WITH_DEDICATED)
+.if ${PORT_OPTIONS:MDEDICATED}
MAKE_ENV+= BUILD_DEDICATED=YES
PLIST_SUB+= DEDICATED=""
Q2MAX_BIN+= quake2max-ded
@@ -72,14 +70,14 @@ Q2MAX_BIN+= quake2max-ded
PLIST_SUB+= DEDICATED="@comment "
.endif
-.if defined(WITH_GAME)
+.if ${PORT_OPTIONS:MGAME}
MAKE_ENV+= BUILD_GAME=YES
PLIST_SUB+= GAME=""
.else
PLIST_SUB+= GAME="@comment "
.endif
-.if defined(WITH_GLX)
+.if ${PORT_OPTIONS:MGLX}
MAKE_ENV+= BUILD_GLX=YES
PLIST_SUB+= GLX=""
Q2MAX_REF+= glx
@@ -87,19 +85,19 @@ Q2MAX_REF+= glx
PLIST_SUB+= GLX="@comment "
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
MAKE_ENV+= WITH_OPTIMIZED_CFLAGS=YES
.endif
-.if defined(WITH_SDL)
+.if ${PORT_OPTIONS:MSDLCLIENT}
MAKE_ENV+= BUILD_QUAKE2MAX-SDL=YES
-PLIST_SUB+= SDL=""
+PLIST_SUB+= SDLCLIENT=""
Q2MAX_BIN+= quake2max-sdl
.else
-PLIST_SUB+= SDL="@comment "
+PLIST_SUB+= SDLCLIENT="@comment "
.endif
-.if defined(WITH_SDLGL)
+.if ${PORT_OPTIONS:MSDLGL}
MAKE_ENV+= BUILD_SDLGL=YES
PLIST_SUB+= SDLGL=""
Q2MAX_REF+= sdlgl
@@ -116,16 +114,17 @@ post-patch:
${WRKSRC}/ref_gl/gl_image.c
do-install:
- ${MKDIR} ${LIBDIR}/baseq2
+ @${MKDIR} ${LIBDIR}/baseq2
.for f in ${Q2MAX_BIN}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${f} ${PREFIX}/bin
.endfor
.for f in ${Q2MAX_REF}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/rfx_${f}.so ${LIBDIR}
.endfor
-.if defined(WITH_GAME)
+.if ${PORT_OPTIONS:MGAME}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so ${LIBDIR}/baseq2
.endif
${INSTALL_DATA} ${WRKSRC}/_maxpak.pak ${LIBDIR}/baseq2/maxpak.pak
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+.include <bsd.port.mk>
diff --git a/games/quake2max/pkg-descr b/games/quake2max/pkg-descr
index a689a2341c0d..74efe8af24fb 100644
--- a/games/quake2max/pkg-descr
+++ b/games/quake2max/pkg-descr
@@ -1,23 +1,21 @@
-OpenGL only Quake II engine modification with the following features:
+OpenGL-only Quake II engine modification with the following features:
-- Requires id Software's Quake II: Patched to v3.20.
-- OpenGL Only: No software mode; No 3dfx.
-- 32-bit color skin/texture support: .jpg; .tga; .png.
-- Texture Compression: For large textures/skins.
-- Particle Engine: Fast intuitive system; dynamically lit; custom special
- effects.
-- RScript Shaders: Spheremapping; detail textures; animated skins; vertex
- deformation, other custom functions.
-- Enhanced Menus: Mouse support in menus; menus scaled to fixed resolution;
- reorganized menus.
-- Client side 3-D Chase Camera: Accurate aiming system; adjustable viewing
- distance; adjustable viewing angle.
-- Miscellaneous Special Effects: Improved model lighting system; improved
- dynamic shadows system; overbright maps, entities and particles; transparent
- surface vertex lighting.
-- Miscellaneous Game play Enhancements: Decals for blood, bullet marks, and
- impact explosions; mouse FOV autosensitivity; "*.pak" pak loading; CVARlist
- filter parameter.
-- Backwards Compatible: With old mods.
-
-WWW: http://www.quake2max.net/
+ - Requires id Software's Quake II (patched to v3.20)
+ - OpenGL only: no software mode; no 3dfx
+ - 32-bit color skin/texture support: .jpg; .tga; .png.
+ - Texture compression (for large textures/skins)
+ - Particle engine: fast intuitive system; dynamically lit; custom special
+ effects
+ - RScript shaders: spheremapping; detail textures; animated skins; vertex
+ deformation, other custom functions
+ - Enhanced menus: mouse support in menus; menus scaled to fixed resolution;
+ reorganized menus
+ - Client side 3D chase camera: accurate aiming system; adjustable viewing
+ distance; adjustable viewing angle
+ - Miscellaneous special effects: improved model lighting system; improved
+ dynamic shadows system; overbright maps, entities and particles;
+ transparent surface vertex lighting
+ - Miscellaneous gameplay enhancements: decals for blood, bullet marks, and
+ impact explosions; mouse FOV autosensitivity; *.pak loading; CVARlist
+ filter parameter
+ - Backwards compatible with old mods
diff --git a/games/quake2max/pkg-plist b/games/quake2max/pkg-plist
index 1028e9f41547..0f4c38cda5ca 100644
--- a/games/quake2max/pkg-plist
+++ b/games/quake2max/pkg-plist
@@ -1,6 +1,6 @@
%%CLIENT%%bin/quake2max
%%DEDICATED%%bin/quake2max-ded
-%%SDL%%bin/quake2max-sdl
+%%SDLCLIENT%%bin/quake2max-sdl
%%GAME%%%%LIBDIR%%/baseq2/game.so
%%LIBDIR%%/baseq2/maxpak.pak
%%GLX%%%%LIBDIR%%/rfx_glx.so