aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-03-29 00:15:59 +0800
committermiwi <miwi@FreeBSD.org>2008-03-29 00:15:59 +0800
commit35f69cfaa38fa736c68744c3ace88ad01a8f4508 (patch)
tree630ca2e42eeccde78c74b55b218987b7e99d70b6 /games
parent47bb81909a6edd7d01744d3a6cdee0056e04b1f3 (diff)
downloadfreebsd-ports-gnome-35f69cfaa38fa736c68744c3ace88ad01a8f4508.tar.gz
freebsd-ports-gnome-35f69cfaa38fa736c68744c3ace88ad01a8f4508.tar.zst
freebsd-ports-gnome-35f69cfaa38fa736c68744c3ace88ad01a8f4508.zip
- Use SF macro
- Replace X11BASE to LOCALBASE - Add missing xrandr - Bump PORTREVISION
Diffstat (limited to 'games')
-rw-r--r--games/torcs/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index 78e7df37aebb..3ebeb73ea7a1 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -7,27 +7,26 @@
PORTNAME= torcs
DISTVERSION= 1.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= The Open Racing Car Simulator
-BUILD_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
+BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
openal.0:${PORTSDIR}/audio/openal \
alut.1:${PORTSDIR}/audio/freealut
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USE_XORG= xrender xmu ice xext x11 xxf86vm
+USE_XORG= xrender xmu ice xext x11 xxf86vm xrandr
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
REINPLACE_ARGS= -i ""
-CONFIGURE_ARGS= --x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
+CONFIGURE_ARGS= --x-includes=${LOCALBASE}/include --x-libraries=${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= default
INSTALL_TARGET= install datainstall
@@ -51,9 +50,9 @@ BASH2FIX= src/linux/torcs.in src/tools/accc/accc.in \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500041
-CPPFLAGS+= -I${X11BASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
.else
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT" \
LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
.endif