aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-06 18:18:10 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-06 18:18:10 +0800
commit39b60510065266394aefc0274c725e0edeaf2d69 (patch)
treebf6fc90bdf4eaaabe774771af249ad41cc3845b9 /games
parent56f2c2ff05e4b39c4bf0876dae7e6f7cf33a81be (diff)
downloadfreebsd-ports-gnome-39b60510065266394aefc0274c725e0edeaf2d69.tar.gz
freebsd-ports-gnome-39b60510065266394aefc0274c725e0edeaf2d69.tar.zst
freebsd-ports-gnome-39b60510065266394aefc0274c725e0edeaf2d69.zip
- Support staging
- Convert to new OPTIONS framework - Rename test target to regression-test in order for tinderbox to run target automatically
Diffstat (limited to 'games')
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile20
-rw-r--r--games/p5-Games-Bingo-Bot/pkg-plist3
2 files changed, 11 insertions, 12 deletions
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
index faaf738cfedf..c542cfbecee0 100644
--- a/games/p5-Games-Bingo-Bot/Makefile
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -16,17 +16,17 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= Games::Bingo::Bot.3
+PORTEXAMPLES= bingobot.pl
+
+OPTIONS_DEFINE= EXAMPLES
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.ifndef(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing example for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingobot.pl ${EXAMPLESDIR}
-.endif
-
-test:
- @cd ${WRKSRC}; make test
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingobot.pl ${STAGEDIR}${EXAMPLESDIR}
+
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} -s test
.include <bsd.port.mk>
diff --git a/games/p5-Games-Bingo-Bot/pkg-plist b/games/p5-Games-Bingo-Bot/pkg-plist
index 51e8c5924f27..c85658f0dd5e 100644
--- a/games/p5-Games-Bingo-Bot/pkg-plist
+++ b/games/p5-Games-Bingo-Bot/pkg-plist
@@ -1,7 +1,6 @@
%%SITE_PERL%%/Games/Bingo/Bot.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo/Bot/.packlist
-%%PORTDOCS%%%%EXAMPLESDIR%%/bingobot.pl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PERL5_MAN3%%/Games::Bingo::Bot.3.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo/Bot
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games