aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2015-11-07 03:29:42 +0800
committerdim <dim@FreeBSD.org>2015-11-07 03:29:42 +0800
commit41986e28830e4754483484397b7ace72d40f9e15 (patch)
tree1324d9b09172b9e011d46b5eea3feeed278ebe2d /games
parent3c11ca5c0be728465d83eb3e7eac5199105f7b69 (diff)
downloadfreebsd-ports-gnome-41986e28830e4754483484397b7ace72d40f9e15.tar.gz
freebsd-ports-gnome-41986e28830e4754483484397b7ace72d40f9e15.tar.zst
freebsd-ports-gnome-41986e28830e4754483484397b7ace72d40f9e15.zip
Fix a number of uninitialized variable warnings in games/nlarn. Also
reset the maintainer to Torsten Zühlsdorff, and bump the port revision. PR: 202499 MFH: 2015Q4
Diffstat (limited to 'games')
-rw-r--r--games/nlarn/Makefile3
-rw-r--r--games/nlarn/files/patch-Makefile8
-rw-r--r--games/nlarn/files/patch-src-game.c6
-rw-r--r--games/nlarn/files/patch-src-monsters.c28
-rw-r--r--games/nlarn/files/patch-src-player.c28
5 files changed, 65 insertions, 8 deletions
diff --git a/games/nlarn/Makefile b/games/nlarn/Makefile
index 648f93ae5a6d..d90f401f4ba6 100644
--- a/games/nlarn/Makefile
+++ b/games/nlarn/Makefile
@@ -3,10 +3,11 @@
PORTNAME= nlarn
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF
-MAINTAINER= martin@arp242.net
+MAINTAINER= ports@toco-domains.de
COMMENT= Roguelike game and as such a remake of the classic game Larn
LICENSE= GPLv3
diff --git a/games/nlarn/files/patch-Makefile b/games/nlarn/files/patch-Makefile
index 46ae0a44fe9e..54a82d9916f0 100644
--- a/games/nlarn/files/patch-Makefile
+++ b/games/nlarn/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2012-07-06 20:29:35.000000000 +0300
-+++ Makefile 2013-03-09 11:15:05.000000000 +0200
-@@ -102,13 +102,13 @@
+--- Makefile.orig 2012-07-06 17:29:35 UTC
++++ Makefile
+@@ -102,13 +102,13 @@ else
LDFLAGS += $(shell pkg-config --libs glib-2.0)
# Configuration for ncurses
@@ -16,7 +16,7 @@
LDFLAGS += -lncurses -lpanel
endif
endif
-@@ -117,6 +117,8 @@
+@@ -117,6 +117,8 @@ else
# Debian and derivates use lua5.1, the rest of the world lua
ifneq ($(wildcard /etc/debian_version),)
lua = lua5.1
diff --git a/games/nlarn/files/patch-src-game.c b/games/nlarn/files/patch-src-game.c
index c52667d57f1b..01103f8331ac 100644
--- a/games/nlarn/files/patch-src-game.c
+++ b/games/nlarn/files/patch-src-game.c
@@ -1,6 +1,6 @@
---- src/game.c.orig 2012-07-06 20:29:35.000000000 +0300
-+++ src/game.c 2013-03-09 12:23:13.000000000 +0200
-@@ -1353,7 +1354,7 @@
+--- src/game.c.orig 2012-07-06 17:29:35 UTC
++++ src/game.c
+@@ -1353,7 +1353,7 @@ static void game_scores_save(game *g, GL
if (sb == NULL)
{
/* opening the file failed */
diff --git a/games/nlarn/files/patch-src-monsters.c b/games/nlarn/files/patch-src-monsters.c
new file mode 100644
index 000000000000..1e7f40a6b990
--- /dev/null
+++ b/games/nlarn/files/patch-src-monsters.c
@@ -0,0 +1,28 @@
+--- src/monsters.c.orig 2012-07-06 17:29:35 UTC
++++ src/monsters.c
+@@ -2725,6 +2725,11 @@ static position monster_move_serve(monst
+ map_path_element *pe = g_queue_pop_head(path->path);
+ npos = pe->pos;
+ }
++ else
++ {
++ /* ensure npos is initialized */
++ npos = m->pos;
++ }
+
+ if (path != NULL)
+ map_path_destroy(path);
+--- src/monsters.c.orig 2012-07-06 19:29:35.000000000 +0200
++++ src/monsters.c 2015-08-19 23:52:50.496120000 +0200
+@@ -2725,6 +2725,11 @@ static position monster_move_serve(monst
+ map_path_element *pe = g_queue_pop_head(path->path);
+ npos = pe->pos;
+ }
++ else
++ {
++ /* ensure npos is initialized */
++ npos = m->pos;
++ }
+
+ if (path != NULL)
+ map_path_destroy(path);
diff --git a/games/nlarn/files/patch-src-player.c b/games/nlarn/files/patch-src-player.c
new file mode 100644
index 000000000000..3ca1a666f0f1
--- /dev/null
+++ b/games/nlarn/files/patch-src-player.c
@@ -0,0 +1,28 @@
+--- src/player.c.orig 2012-07-06 17:29:35 UTC
++++ src/player.c
+@@ -1605,6 +1605,11 @@ int player_map_enter(player *p, map *l,
+ else
+ pos = map_find_sobject(l, LS_STAIRSUP);
+ }
++ /* doing nothing? */
++ else
++ {
++ pos = p->pos;
++ }
+
+ if (l->nlevel == 0)
+ {
+--- src/player.c.orig 2012-07-06 19:29:35.000000000 +0200
++++ src/player.c 2015-08-19 23:56:03.671153000 +0200
+@@ -1605,6 +1605,11 @@ int player_map_enter(player *p, map *l,
+ else
+ pos = map_find_sobject(l, LS_STAIRSUP);
+ }
++ /* doing nothing? */
++ else
++ {
++ pos = p->pos;
++ }
+
+ if (l->nlevel == 0)
+ {