aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-05-12 19:48:49 +0800
committermakc <makc@FreeBSD.org>2013-05-12 19:48:49 +0800
commit42c3e01f07107a7ded656f841e10cae90815ea5d (patch)
treefcff4e051f035837ff7cab73432d274b96171613 /games
parentc2b64d94e19f83563bdf4236c8047c64f184ed69 (diff)
downloadfreebsd-ports-gnome-42c3e01f07107a7ded656f841e10cae90815ea5d.tar.gz
freebsd-ports-gnome-42c3e01f07107a7ded656f841e10cae90815ea5d.tar.zst
freebsd-ports-gnome-42c3e01f07107a7ded656f841e10cae90815ea5d.zip
- Add global options (DOCS, NLS, etc) to the OPTIONS_DEFINE and partly revert r315222 [1]
- Convert WITH_DEBUG to new options framework - Trim Makefile header - Adjust COMMENTs - Reformat/update description [1] See follow-up discussion: http://lists.freebsd.org/pipermail/svn-ports-head/2013-March/016094.html
Diffstat (limited to 'games')
-rw-r--r--games/darkplaces/Makefile1
-rw-r--r--games/frozenbubble/Makefile8
-rw-r--r--games/toppler/Makefile10
-rw-r--r--games/trigger/Makefile2
-rw-r--r--games/trophy/Makefile4
-rw-r--r--games/warmux/Makefile12
-rw-r--r--games/warmux/pkg-descr30
7 files changed, 32 insertions, 35 deletions
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index 8eb6ffab39c0..484026c16317 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -21,6 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
ALL_TARGET= #
+OPTIONS_DEFINE= DOCS
OPTIONS_MULTI= MODULE
OPTIONS_MULTI_MODULE= CLIENT DEDICATED SDL
OPTIONS_DEFAULT= ${OPTIONS_MULTI_MODULE}
diff --git a/games/frozenbubble/Makefile b/games/frozenbubble/Makefile
index 2ea85c928458..c43ad9b0c0b7 100644
--- a/games/frozenbubble/Makefile
+++ b/games/frozenbubble/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: frozen-bubble
-# Date created: 2002-10-06
-# Whom: Klaus Goger <klaus.goger@reflex.at>
-#
+# Created by: Klaus Goger <klaus.goger@reflex.at>
# $FreeBSD$
-#
PORTNAME= frozenbubble
PORTVERSION= 2.2.0
@@ -30,6 +26,8 @@ MAN6= frozen-bubble-editor.6 frozen-bubble.6
LEXECDIR= ${PREFIX}/libexec/${PORTNAME}
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
index e94ac4e20ecb..809df25c9afe 100644
--- a/games/toppler/Makefile
+++ b/games/toppler/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: toppler
-# Date created: 18 Jan 2002
-# Whom: Dom Mitchell <dom@happygiraffe.net>
-#
+# Created by: Dom Mitchell <dom@happygiraffe.net>
# $FreeBSD$
-#
PORTNAME= toppler
PORTVERSION= 1.1.5
@@ -12,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= makc@FreeBSD.org
-COMMENT= A game where you have to climb the tower and avoid the monsters
+COMMENT= Climb a tower and avoid monsters
USE_SDL= mixer sdl
USES= gettext
@@ -25,6 +21,8 @@ MAN6= ${PORTNAME}.6
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/games/trigger/Makefile b/games/trigger/Makefile
index ed15c7fd603f..02f7ce1c64cb 100644
--- a/games/trigger/Makefile
+++ b/games/trigger/Makefile
@@ -33,6 +33,8 @@ DESKTOP_ENTRIES="Trigger" "${COMMENT}" "" \
PORTDOCS= README-stereo.txt README.txt
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index f214698cb372..4b65bf26a4dc 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= SF
MAINTAINER= makc@FreeBSD.org
-COMMENT= A single player racing game
+COMMENT= Single player racing game
LICENSE= GPLv2
@@ -23,6 +23,8 @@ MAN6= trophy.6
PORTDOCS= AUTHORS COPYING ChangeLog README TODO
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
pre-configure:
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
index a15c193a2ff4..3db9192286f3 100644
--- a/games/warmux/Makefile
+++ b/games/warmux/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: wormux
-# Date created: Thu Dec 16 18:46:55 EET 2004
-# Whom: Anton Yudin <toha@FreeBSD.org>
-#
+# Created by: Anton Yudin <toha@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= warmux
DISTVERSION= 11.04.1
@@ -13,7 +9,7 @@ MASTER_SITES= http://download.gna.org/${PORTNAME}/ \
http://download.gna.org/${PORTNAME}/archive/
MAINTAINER= makc@FreeBSD.org
-COMMENT= Wormux game
+COMMENT= Turn-based artillery game with free software mascots
LIB_DEPENDS= xml++-2.6.2:${PORTSDIR}/textproc/libxml++26 \
curl:${PORTSDIR}/ftp/curl
@@ -30,7 +26,7 @@ USE_DOS2UNIX= fixed_class.h
MANCOMPRESSED= no
MAN6= warmux.6
-OPTIONS_DEFINE= FRIBIDI SERVER NLS
+OPTIONS_DEFINE= FRIBIDI SERVER NLS DEBUG
FRIBIDI_DESC= Enable bi-directional unicode support
SERVER_DESC= Enable dedicated server
@@ -44,7 +40,7 @@ post-patch:
${REINPLACE_CMD} -e "s,warmux_files.desktop,," ${WRKSRC}/data/Makefile.in
${FIND} -d ${WRKSRC}/data/ -name "*.*~" -delete
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug \
--enable-logging
.endif
diff --git a/games/warmux/pkg-descr b/games/warmux/pkg-descr
index 89fe1389365c..71ad5d8afd6f 100644
--- a/games/warmux/pkg-descr
+++ b/games/warmux/pkg-descr
@@ -1,17 +1,17 @@
-Almost everyone has heard of the Worms(R) series of games, developed by Team17.
-Worms was created in 1990, the goal of the game consisting of a several teams of
-"worms" fighting to the death on a 2D map. Wormux is heavily influenced by all
-games in this genre, including Scorched Earth and Liero.
+Almost everyone has heard of the Worms(R) series of games, developed
+by Team17. Worms was created in 1990, the goal of the game consisting
+of a several teams of "worms" fighting to the death on a 2D map.
+WarMUX (WAR of Mascots from UniX) is heavily influenced by all games
+in this genre, including Scorched Earth and Liero.
-Wormux is free software clone of this game concept. Though currently under heavy
-development, it is already very playable, with lots of weapons (Dynamite,
-Baseball Bat, Teleportation, etc.). There are also lots of maps available for
-your battling pleasure! Wormux takes the genre to the next level, with great
-customisation options leading to great gameplay. There is a wide selection of
-teams, from the Aliens to the Chickens. Also, new battlefields can be downloaded
-from the Internet, making strategy an important part of each battle.
+WarMUX is free software clone of this game concept. Though currently
+under heavy development, it is already very playable, with lots of
+weapons (Dynamite, Baseball Bat, Teleportation, etc.). There are
+also lots of maps available for your battling pleasure! WarMUX
+takes the genre to the next level, with great customisation options
+leading to great gameplay. There is a wide selection of teams,
+from the Aliens to the Chickens. Also, new battlefields can be
+downloaded from the Internet, making strategy an important part of
+each battle.
-Renamed to WarMUX (WAR of Mascots from UniX):
-http://www.wormux.org/phpboost/news/news-0-17+wormux-becomes-warmux.php
-
-WWW: http://www.wormux.org/
+WWW: http://sourceforge.net/projects/warmux.mirror/