aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-02-21 07:30:15 +0800
committerpawel <pawel@FreeBSD.org>2013-02-21 07:30:15 +0800
commit42d35c135c7ccdbd9c4fa9ccde99802c449d7c95 (patch)
tree49089b6e888bf556283b6151a7db8b4a54caa4ed /games
parent9845a13b600e3b636511c2656dbea9fdca57ff8c (diff)
downloadfreebsd-ports-gnome-42d35c135c7ccdbd9c4fa9ccde99802c449d7c95.tar.gz
freebsd-ports-gnome-42d35c135c7ccdbd9c4fa9ccde99802c449d7c95.tar.zst
freebsd-ports-gnome-42d35c135c7ccdbd9c4fa9ccde99802c449d7c95.zip
Gigalomania is a 2D real time strategy game that is a clone of Mega-Lo-Mania.
The gameplay consists of researching and developing new technology with which to conquer your enemies, from rocks and sticks to nuclear weapons and spaceships. You can advance through ten different ages, from the stone age to the future. There are 28 different maps to play through. WWW: http://homepage.ntlworld.com/mark.harman/comp_gigalomania.html
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/gigalomania/Makefile50
-rw-r--r--games/gigalomania/distinfo2
-rw-r--r--games/gigalomania/pkg-descr7
-rw-r--r--games/gigalomania/pkg-plist115
5 files changed, 175 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 5d2bb0437a21..dbb051613651 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -303,6 +303,7 @@
SUBDIR += ggz-kde-client
SUBDIR += ggz-sdl-games
SUBDIR += ggz-txt-client
+ SUBDIR += gigalomania
SUBDIR += gillo
SUBDIR += gish-demo
SUBDIR += gl-117
diff --git a/games/gigalomania/Makefile b/games/gigalomania/Makefile
new file mode 100644
index 000000000000..09e265be9931
--- /dev/null
+++ b/games/gigalomania/Makefile
@@ -0,0 +1,50 @@
+# Created by: Pawel Pekala <pawel@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gigalomania
+PORTVERSION= 0.25
+CATEGORIES= games
+MASTER_SITES= https://launchpadlibrarian.net/130757462/
+DISTNAME= ${PORTNAME}src
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= Open source 2D real time strategy god game
+
+USE_ZIP= yes
+USE_SDL= image mixer sdl
+
+PORTDOCS= readme.html
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CC=g++|CC=${CXX}|' \
+ -e '/^CCFLAGS/ s|-O2|${CXXFLAGS}|; s|-O2||' \
+ -e 's|/usr/X11R6|${LOCALBASE}|' \
+ ${WRKSRC}/Makefile
+ @${FIND} ${WRKSRC} -exec ${GREP} -q "__linux" {} \; \
+ -exec ${REINPLACE_CMD} 's|__linux|__FreeBSD__|' {} \;
+ @${REINPLACE_CMD} 's|/opt/gigalomania/||g' \
+ ${WRKSRC}/gigalomania.desktop \
+ ${WRKSRC}/gigalomania_fullscreen.desktop
+ @${REINPLACE_CMD} 's|/usr/share|${LOCALBASE}/share|g' \
+ ${WRKSRC}/game.cpp \
+ ${WRKSRC}/gamestate.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for dir in gfx islands sound
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${DATADIR}
+.endfor
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}_fullscreen.desktop \
+ ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}64.png ${PREFIX}/share/pixmaps
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/gigalomania/distinfo b/games/gigalomania/distinfo
new file mode 100644
index 000000000000..db525d190897
--- /dev/null
+++ b/games/gigalomania/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gigalomaniasrc.zip) = 198c4fc41341cc7e408c3b942600cecdce4d5913903ac1ab0071393837c3c60b
+SIZE (gigalomaniasrc.zip) = 9100433
diff --git a/games/gigalomania/pkg-descr b/games/gigalomania/pkg-descr
new file mode 100644
index 000000000000..1b00874e9d4a
--- /dev/null
+++ b/games/gigalomania/pkg-descr
@@ -0,0 +1,7 @@
+Gigalomania is a 2D real time strategy game that is a clone of Mega-Lo-Mania.
+The gameplay consists of researching and developing new technology with
+which to conquer your enemies, from rocks and sticks to nuclear weapons and
+spaceships. You can advance through ten different ages, from the stone age
+to the future. There are 28 different maps to play through.
+
+WWW: http://homepage.ntlworld.com/mark.harman/comp_gigalomania.html
diff --git a/games/gigalomania/pkg-plist b/games/gigalomania/pkg-plist
new file mode 100644
index 000000000000..d583ddcb74c4
--- /dev/null
+++ b/games/gigalomania/pkg-plist
@@ -0,0 +1,115 @@
+bin/gigalomania
+share/applications/gigalomania.desktop
+share/applications/gigalomania_fullscreen.desktop
+%%DATADIR%%/gfx/attacker_ammo.png
+%%DATADIR%%/gfx/attacker_flying.png
+%%DATADIR%%/gfx/attacker_walking_0_0.png
+%%DATADIR%%/gfx/attacker_walking_0_1.png
+%%DATADIR%%/gfx/attacker_walking_0_2.png
+%%DATADIR%%/gfx/attacker_walking_0_3.png
+%%DATADIR%%/gfx/attacker_walking_10_0.png
+%%DATADIR%%/gfx/attacker_walking_10_1.png
+%%DATADIR%%/gfx/attacker_walking_10_2.png
+%%DATADIR%%/gfx/attacker_walking_10_3.png
+%%DATADIR%%/gfx/attacker_walking_1_0.png
+%%DATADIR%%/gfx/attacker_walking_1_1.png
+%%DATADIR%%/gfx/attacker_walking_1_2.png
+%%DATADIR%%/gfx/attacker_walking_1_3.png
+%%DATADIR%%/gfx/attacker_walking_2_0.png
+%%DATADIR%%/gfx/attacker_walking_2_1.png
+%%DATADIR%%/gfx/attacker_walking_2_2.png
+%%DATADIR%%/gfx/attacker_walking_2_3.png
+%%DATADIR%%/gfx/attacker_walking_3_0.png
+%%DATADIR%%/gfx/attacker_walking_3_1.png
+%%DATADIR%%/gfx/attacker_walking_3_2.png
+%%DATADIR%%/gfx/attacker_walking_3_3.png
+%%DATADIR%%/gfx/attacker_walking_4.png
+%%DATADIR%%/gfx/attacker_walking_5.png
+%%DATADIR%%/gfx/building_factory_4.png
+%%DATADIR%%/gfx/building_factory_5.png
+%%DATADIR%%/gfx/building_factory_6.png
+%%DATADIR%%/gfx/building_factory_7.png
+%%DATADIR%%/gfx/building_factory_8.png
+%%DATADIR%%/gfx/building_lab_5.png
+%%DATADIR%%/gfx/building_lab_6.png
+%%DATADIR%%/gfx/building_lab_7.png
+%%DATADIR%%/gfx/building_lab_8.png
+%%DATADIR%%/gfx/building_mine_3.png
+%%DATADIR%%/gfx/building_mine_4.png
+%%DATADIR%%/gfx/building_mine_5.png
+%%DATADIR%%/gfx/building_mine_6.png
+%%DATADIR%%/gfx/building_mine_7.png
+%%DATADIR%%/gfx/building_mine_8.png
+%%DATADIR%%/gfx/building_tower_0.png
+%%DATADIR%%/gfx/building_tower_1.png
+%%DATADIR%%/gfx/building_tower_2.png
+%%DATADIR%%/gfx/building_tower_3.png
+%%DATADIR%%/gfx/building_tower_4.png
+%%DATADIR%%/gfx/building_tower_5.png
+%%DATADIR%%/gfx/building_tower_6.png
+%%DATADIR%%/gfx/building_tower_7.png
+%%DATADIR%%/gfx/building_tower_8.png
+%%DATADIR%%/gfx/building_tower_9.png
+%%DATADIR%%/gfx/deadtree1_00.png
+%%DATADIR%%/gfx/defenders.png
+%%DATADIR%%/gfx/features.png
+%%DATADIR%%/gfx/font.png
+%%DATADIR%%/gfx/icons.png
+%%DATADIR%%/gfx/icons64.png
+%%DATADIR%%/gfx/log0.png
+%%DATADIR%%/gfx/rock0.png
+%%DATADIR%%/gfx/rock1.png
+%%DATADIR%%/gfx/slabs.png
+%%DATADIR%%/gfx/smallmap_coast.png
+%%DATADIR%%/gfx/starfield.jpg
+%%DATADIR%%/gfx/sunrise.jpg
+%%DATADIR%%/gfx/tree2_00.png
+%%DATADIR%%/gfx/tree2_01.png
+%%DATADIR%%/gfx/tree2_02.png
+%%DATADIR%%/gfx/tree2_03.png
+%%DATADIR%%/gfx/tree3_00.png
+%%DATADIR%%/gfx/tree3_01.png
+%%DATADIR%%/gfx/tree3_02.png
+%%DATADIR%%/gfx/tree3_03.png
+%%DATADIR%%/gfx/tree5_00.png
+%%DATADIR%%/gfx/tree5_01.png
+%%DATADIR%%/gfx/tree5_02.png
+%%DATADIR%%/gfx/tree5_03.png
+%%DATADIR%%/islands/0mega.map
+%%DATADIR%%/islands/alpha.map
+%%DATADIR%%/islands/binary.map
+%%DATADIR%%/islands/castle.map
+%%DATADIR%%/islands/devil.map
+%%DATADIR%%/islands/eep.map
+%%DATADIR%%/islands/final.map
+%%DATADIR%%/islands/font.map
+%%DATADIR%%/islands/globe.map
+%%DATADIR%%/islands/home.map
+%%DATADIR%%/islands/infinity.map
+%%DATADIR%%/islands/just.map
+%%DATADIR%%/islands/koala.map
+%%DATADIR%%/islands/loop.map
+%%DATADIR%%/islands/moon.map
+%%DATADIR%%/islands/ninth.map
+%%DATADIR%%/islands/oxygen.map
+%%DATADIR%%/islands/polar.map
+%%DATADIR%%/islands/quart.map
+%%DATADIR%%/islands/rare.map
+%%DATADIR%%/islands/semi.map
+%%DATADIR%%/islands/toxic.map
+%%DATADIR%%/islands/universal.map
+%%DATADIR%%/islands/vine.map
+%%DATADIR%%/islands/wreath.map
+%%DATADIR%%/islands/x.map
+%%DATADIR%%/islands/yen.map
+%%DATADIR%%/islands/zinc.map
+%%DATADIR%%/sound/bomb.wav
+%%DATADIR%%/sound/misc_menu_3.wav
+%%DATADIR%%/sound/pain1.wav
+%%DATADIR%%/sound/woodbrk.wav
+share/pixmaps/gigalomania64.png
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/islands
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%
+@dirrmtry share/applications