aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-23 19:35:05 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-23 19:35:05 +0800
commit4870fcd2c7c8224afb2f85071dd0b37b7beb77fd (patch)
tree49e77095ec2c3d34aa8d22eed3e5655d0f1874cb /games
parent5d85b8fff14f9a15e9a3c4c45249fd3b531623e7 (diff)
downloadfreebsd-ports-gnome-4870fcd2c7c8224afb2f85071dd0b37b7beb77fd.tar.gz
freebsd-ports-gnome-4870fcd2c7c8224afb2f85071dd0b37b7beb77fd.tar.zst
freebsd-ports-gnome-4870fcd2c7c8224afb2f85071dd0b37b7beb77fd.zip
Unbreak on bento.
PR: 38446 Submitted by: maintainer
Diffstat (limited to 'games')
-rw-r--r--games/etuxracer/Makefile6
-rw-r--r--games/tuxracer-commercial/Makefile6
-rw-r--r--games/tuxracer/Makefile6
3 files changed, 12 insertions, 6 deletions
diff --git a/games/etuxracer/Makefile b/games/etuxracer/Makefile
index 2c712a839745..3f934e46937a 100644
--- a/games/etuxracer/Makefile
+++ b/games/etuxracer/Makefile
@@ -16,8 +16,6 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
MAINTAINER= eanholt@gladstone.uoregon.edu
-BROKEN= "Does not build"
-
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
tcl83.1:${PORTSDIR}/lang/tcl83
@@ -25,6 +23,7 @@ USE_MESA= yes
USE_GMAKE= yes
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_AUTOMAKE= yes
+AUTOMAKE_ARGS= -a
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
THREAD_LIB="${PTHREAD_LIB}"
MAKE_ENV= ${CONFIGURE_ENV}
@@ -37,6 +36,9 @@ CONFIGURE_ARGS= --with-tcl-inc="${LOCALBASE}/include/tcl8.3" \
WORKDATA= ${WRKDIR}/${PORTNAME}-data-${PORTVERSION}
COURSEDIRS= 1 2 3 4 5 6 7 8 9 10 11
+post-extract:
+ ${RM} ${WRKSRC}/missing
+
post-install:
${MKDIR} ${DATADIR}
(cd ${WORKDATA} && ${TAR} -c -f - *) | \
diff --git a/games/tuxracer-commercial/Makefile b/games/tuxracer-commercial/Makefile
index 2c712a839745..3f934e46937a 100644
--- a/games/tuxracer-commercial/Makefile
+++ b/games/tuxracer-commercial/Makefile
@@ -16,8 +16,6 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
MAINTAINER= eanholt@gladstone.uoregon.edu
-BROKEN= "Does not build"
-
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
tcl83.1:${PORTSDIR}/lang/tcl83
@@ -25,6 +23,7 @@ USE_MESA= yes
USE_GMAKE= yes
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_AUTOMAKE= yes
+AUTOMAKE_ARGS= -a
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
THREAD_LIB="${PTHREAD_LIB}"
MAKE_ENV= ${CONFIGURE_ENV}
@@ -37,6 +36,9 @@ CONFIGURE_ARGS= --with-tcl-inc="${LOCALBASE}/include/tcl8.3" \
WORKDATA= ${WRKDIR}/${PORTNAME}-data-${PORTVERSION}
COURSEDIRS= 1 2 3 4 5 6 7 8 9 10 11
+post-extract:
+ ${RM} ${WRKSRC}/missing
+
post-install:
${MKDIR} ${DATADIR}
(cd ${WORKDATA} && ${TAR} -c -f - *) | \
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index 2c712a839745..3f934e46937a 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -16,8 +16,6 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
MAINTAINER= eanholt@gladstone.uoregon.edu
-BROKEN= "Does not build"
-
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
tcl83.1:${PORTSDIR}/lang/tcl83
@@ -25,6 +23,7 @@ USE_MESA= yes
USE_GMAKE= yes
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_AUTOMAKE= yes
+AUTOMAKE_ARGS= -a
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
THREAD_LIB="${PTHREAD_LIB}"
MAKE_ENV= ${CONFIGURE_ENV}
@@ -37,6 +36,9 @@ CONFIGURE_ARGS= --with-tcl-inc="${LOCALBASE}/include/tcl8.3" \
WORKDATA= ${WRKDIR}/${PORTNAME}-data-${PORTVERSION}
COURSEDIRS= 1 2 3 4 5 6 7 8 9 10 11
+post-extract:
+ ${RM} ${WRKSRC}/missing
+
post-install:
${MKDIR} ${DATADIR}
(cd ${WORKDATA} && ${TAR} -c -f - *) | \