aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-17 03:29:36 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-17 03:29:36 +0800
commit4c20854241118663408e6915122fcb5d42e45574 (patch)
tree3e883a718608e403254da92f0b622a4a902d55a9 /games
parentabaa66b74893bd79ef2a5933dfb5f0c424879d48 (diff)
downloadfreebsd-ports-gnome-4c20854241118663408e6915122fcb5d42e45574.tar.gz
freebsd-ports-gnome-4c20854241118663408e6915122fcb5d42e45574.tar.zst
freebsd-ports-gnome-4c20854241118663408e6915122fcb5d42e45574.zip
- Update to 0.3.2
Diffstat (limited to 'games')
-rw-r--r--games/lordsawar/Makefile15
-rw-r--r--games/lordsawar/distinfo6
-rw-r--r--games/lordsawar/files/patch-create-lw-file11
-rw-r--r--games/lordsawar/files/patch-src_MapRenderer.cpp11
-rw-r--r--games/lordsawar/files/patch-src__LocationList.h17
-rw-r--r--games/lordsawar/files/patch-src__setlist.h26
-rw-r--r--games/lordsawar/files/patch-src_armyproto.cpp (renamed from games/lordsawar/files/patch-src__armyproto.cpp)10
-rw-r--r--games/lordsawar/files/patch-src_bigmap.cpp42
-rw-r--r--games/lordsawar/files/patch-src_game-parameters.h10
-rw-r--r--games/lordsawar/files/patch-src_gui_stack-army-button.cpp11
-rw-r--r--games/lordsawar/pkg-plist45
11 files changed, 57 insertions, 147 deletions
diff --git a/games/lordsawar/Makefile b/games/lordsawar/Makefile
index 9f9707a256cc..450a16fab4c4 100644
--- a/games/lordsawar/Makefile
+++ b/games/lordsawar/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= lordsawar
-PORTVERSION= 0.3.1
-PORTREVISION= 5
+PORTVERSION= 0.3.2
CATEGORIES= games
MASTER_SITES= SAVANNAH
@@ -15,11 +14,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= compiler:c++11-lib gettext gmake gnome libarchive pkgconfig \
shebangfix
USE_GNOME= gtkmm30 intltool libxslt
-USE_GSTREAMER= mm
-USE_CXXSTD= c++11
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
SHEBANG_FILES= create-lw-file
bash_CMD= /bin/sh
+OPTIONS_DEFINE= SOUND
+OPTIONS_DEFAULT=SOUND
+
+SOUND_USE= GSTREAMER1=mm,good,ogg,vorbis
+SOUND_CONFIGURE_ENABLE= sound
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|class SetList<T>::|typename SetList<T>::|' \
+ ${WRKSRC}/src/setlist.h
+
.include <bsd.port.mk>
diff --git a/games/lordsawar/distinfo b/games/lordsawar/distinfo
index f2c8bb93df7a..6a1f1eda9229 100644
--- a/games/lordsawar/distinfo
+++ b/games/lordsawar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477596930
-SHA256 (lordsawar-0.3.1.tar.gz) = 9bc75c4c14953e9d70bd4c130a1b8803aac681b97c7616c657241c1e4fe864ab
-SIZE (lordsawar-0.3.1.tar.gz) = 26112514
+TIMESTAMP = 1605219363
+SHA256 (lordsawar-0.3.2.tar.gz) = ee9f8f2f0e07595ae5fbdb6259bfbc1fb9c88d17eeda723c8e23428a0bcda7b1
+SIZE (lordsawar-0.3.2.tar.gz) = 27942317
diff --git a/games/lordsawar/files/patch-create-lw-file b/games/lordsawar/files/patch-create-lw-file
new file mode 100644
index 000000000000..fb808db8960f
--- /dev/null
+++ b/games/lordsawar/files/patch-create-lw-file
@@ -0,0 +1,11 @@
+--- create-lw-file.orig 2020-11-10 14:34:22 UTC
++++ create-lw-file
+@@ -19,7 +19,7 @@ if [ "x$tmpdir" != "x" ]; then
+ done
+ #we want to use --clamp-mtime but it is too new. (requires GNU tar version 1.29)
+ #we want to use --sort=name but it is too new.
+- tar -cvf $tarball $tmpfiles --mtime="@${SOURCE_DATE_EPOCH:-$(date +%s)}" --mode=go=rX,u+rw,a-s --owner=root --group=root --numeric-owner
++ tar -cvf $tarball $tmpfiles
+ if [ "$?" != "0" ]; then
+ exitstatus="1";
+ fi
diff --git a/games/lordsawar/files/patch-src_MapRenderer.cpp b/games/lordsawar/files/patch-src_MapRenderer.cpp
deleted file mode 100644
index 4a1a56aa0335..000000000000
--- a/games/lordsawar/files/patch-src_MapRenderer.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/MapRenderer.cpp.orig 2015-06-10 18:06:19 UTC
-+++ src/MapRenderer.cpp
-@@ -72,7 +72,7 @@ void MapRenderer::render_tile(Vector<int
- }
- else
- {
-- if (style->getImage() == false)
-+ if (!style->getImage())
- {
- printf ("pic for style %d for tile %d at %d,%d is null\n",
- style->getType(), mtile->getType(), tile.x, tile.y);
diff --git a/games/lordsawar/files/patch-src__LocationList.h b/games/lordsawar/files/patch-src__LocationList.h
deleted file mode 100644
index e03ad2771696..000000000000
--- a/games/lordsawar/files/patch-src__LocationList.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/LocationList.h.orig 2010-05-11 08:50:34 UTC
-+++ src/LocationList.h
-@@ -74,8 +74,14 @@
- for (int j = 0; j < s; j++)
- {
- Vector<int> pos = t->getPos() + Vector<int>(i,j);
-+#if defined(_LIBCPP_VERSION)
-+ typename PositionMap::const_iterator it = d_object.find(pos);
-+ if (it != d_object.end())
-+ d_object.erase(it);
-+#else
- if (d_object.find(pos) != d_object.end())
- d_object.erase(d_object.find(pos));
-+#endif
- }
- delete t;
- }
diff --git a/games/lordsawar/files/patch-src__setlist.h b/games/lordsawar/files/patch-src__setlist.h
deleted file mode 100644
index 692ded785f6b..000000000000
--- a/games/lordsawar/files/patch-src__setlist.h
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/setlist.h.orig 2015-07-03 20:03:50 UTC
-+++ src/setlist.h
-@@ -35,7 +35,11 @@ public:
- SetList(Glib::ustring ext){extension=ext;};
- ~SetList()
- {
-+#if defined(_LIBCPP_VERSION)
-+ for (typename SetList<T>::iterator it = this->begin(); it != this->end();
-+#else
- for (class SetList<T>::iterator it = this->begin(); it != this->end();
-+#endif
- it++)
- delete (*it);
- };
-@@ -62,7 +66,11 @@ public:
-
- bool contains(Glib::ustring name) const
- {
-+#if defined(_LIBCPP_VERSION)
-+ for (typename SetList<T>::const_iterator it = this->begin();
-+#else
- for (class SetList<T>::const_iterator it = this->begin();
-+#endif
- it != this->end(); it++)
- if ((*it)->getName() == name)
- return true;
diff --git a/games/lordsawar/files/patch-src__armyproto.cpp b/games/lordsawar/files/patch-src_armyproto.cpp
index 4908051084e5..b8eb541c6483 100644
--- a/games/lordsawar/files/patch-src__armyproto.cpp
+++ b/games/lordsawar/files/patch-src_armyproto.cpp
@@ -1,6 +1,6 @@
---- src/armyproto.cpp.orig 2011-02-12 19:13:14 UTC
+--- src/armyproto.cpp.orig 2020-04-09 19:57:07 UTC
+++ src/armyproto.cpp
-@@ -34,7 +34,7 @@
+@@ -35,9 +35,13 @@ Glib::ustring ArmyProto::d_tag = "armyproto";
ArmyProto::ArmyProto(const ArmyProto& a)
:ArmyProtoBase(a), d_id(a.d_id), d_defends_ruins(a.d_defends_ruins),
@@ -8,4 +8,10 @@
+ d_awardable(a.d_awardable),
d_gender(a.d_gender)
{
++ for (size_t i = 0; i < sizeof(d_image_name)/sizeof(d_image_name[0]); i++) {
++ d_image_name[i] = a.d_image_name[i];
++ }
++
for (unsigned int c = Shield::WHITE; c <= Shield::NEUTRAL; c++)
+ {
+ d_image_name[c] = a.d_image_name[c];
diff --git a/games/lordsawar/files/patch-src_bigmap.cpp b/games/lordsawar/files/patch-src_bigmap.cpp
deleted file mode 100644
index a4ad21c2c393..000000000000
--- a/games/lordsawar/files/patch-src_bigmap.cpp
+++ /dev/null
@@ -1,42 +0,0 @@
---- src/bigmap.cpp.orig 2015-06-10 17:45:00 UTC
-+++ src/bigmap.cpp
-@@ -67,10 +67,10 @@ BigMap::BigMap()
-
- BigMap::~BigMap()
- {
-- if (buffer == true)
-+ if (buffer)
- buffer.clear();
-
-- if (magnified_buffer == true)
-+ if (magnified_buffer)
- magnified_buffer.clear();
-
- delete d_renderer;
-@@ -112,7 +112,7 @@ void BigMap::set_view(Rectangle new_view
- // this represents a 1 tile border around the outside of the picture.
- // it gets rid of the black border.
-
-- if (buffer == true)
-+ if (buffer)
- buffer.clear();
-
- buffer_view.dim = view.dim + Vector<int>(2, 2);
-@@ -122,7 +122,7 @@ void BigMap::set_view(Rectangle new_view
- buffer_gc = Cairo::Context::create(buffer);
-
- //now create the part that will go out to the gtk::image
-- if (outgoing == true)
-+ if (outgoing)
- outgoing.clear();
- outgoing = Cairo::Surface::create(buffer, Cairo::CONTENT_COLOR_ALPHA, image.get_width(), image.get_height());
-
-@@ -174,7 +174,7 @@ void BigMap::draw(Player *player, bool r
- //Glib::RefPtr<Gdk::Pixmap> outgoing;
- if (magnification_factor != 1.0)
- {
-- if (magnified_buffer == true)
-+ if (magnified_buffer)
- magnified_buffer.clear();
- magnified_buffer = magnify(buffer);
- clip_viewable_buffer(magnified_buffer, p, outgoing);
diff --git a/games/lordsawar/files/patch-src_game-parameters.h b/games/lordsawar/files/patch-src_game-parameters.h
deleted file mode 100644
index 357348189895..000000000000
--- a/games/lordsawar/files/patch-src_game-parameters.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/game-parameters.h.orig 2015-06-10 17:55:57 UTC
-+++ src/game-parameters.h
-@@ -117,6 +117,7 @@ public:
- return 8;
- else if (param == GameParameters::Player::OFF)
- return 0; //no equiv.
-+ return 0;
- }
- static GameParameters::Player::Type player_param_string_to_player_param(Glib::ustring s)
- {
diff --git a/games/lordsawar/files/patch-src_gui_stack-army-button.cpp b/games/lordsawar/files/patch-src_gui_stack-army-button.cpp
deleted file mode 100644
index bb3a815d245d..000000000000
--- a/games/lordsawar/files/patch-src_gui_stack-army-button.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gui/stack-army-button.cpp.orig 2015-06-20 22:48:43 UTC
-+++ src/gui/stack-army-button.cpp
-@@ -146,7 +146,7 @@ void StackArmyButton::fill_army_button()
- {
- bool greyed_out = false;
- Stack *active_stack = p->getActivestack();
-- if (active_stack->getArmyById(d_army->getId()) == false)
-+ if (!active_stack->getArmyById(d_army->getId()))
- greyed_out = true;
- army_image->property_pixbuf() =
- gc->getCircledArmyPic(p->getArmyset(), d_army->getTypeId(),
diff --git a/games/lordsawar/pkg-plist b/games/lordsawar/pkg-plist
index 2edd72ac78b1..381d6e733f93 100644
--- a/games/lordsawar/pkg-plist
+++ b/games/lordsawar/pkg-plist
@@ -1,12 +1,10 @@
bin/lordsawar
-bin/lordsawar-editor
bin/lordsawar-game-host-client
bin/lordsawar-game-host-server
bin/lordsawar-game-list-client
bin/lordsawar-game-list-server
bin/lordsawar-import
bin/lordsawar-upgrade-file
-man/man6/lordsawar-editor.6.gz
man/man6/lordsawar-game-host-client.6.gz
man/man6/lordsawar-game-host-server.6.gz
man/man6/lordsawar-game-list-client.6.gz
@@ -14,18 +12,22 @@ man/man6/lordsawar-game-list-server.6.gz
man/man6/lordsawar-import.6.gz
man/man6/lordsawar.6.gz
share/appdata/lordsawar-appdata.xml
-share/applications/lordsawar-editor.desktop
share/applications/lordsawar.desktop
-share/icons/hicolor/32x32/apps/lordsawar-editor.png
+share/icons/hicolor/16x16/apps/lordsawar.png
+share/icons/hicolor/22x22/apps/lordsawar.png
+share/icons/hicolor/24x24/apps/lordsawar.png
share/icons/hicolor/32x32/apps/lordsawar.png
-share/icons/hicolor/64x64/apps/lordsawar-editor.png
+share/icons/hicolor/48x48/apps/lordsawar.png
share/icons/hicolor/64x64/apps/lordsawar.png
share/locale/ca/LC_MESSAGES/lordsawar.mo
share/locale/da/LC_MESSAGES/lordsawar.mo
share/locale/de/LC_MESSAGES/lordsawar.mo
+share/locale/fr/LC_MESSAGES/lordsawar.mo
share/locale/hu/LC_MESSAGES/lordsawar.mo
share/locale/nl/LC_MESSAGES/lordsawar.mo
share/locale/pl/LC_MESSAGES/lordsawar.mo
+share/locale/sv/LC_MESSAGES/lordsawar.mo
+share/locale/tr/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/army/bigdefault.lwa
%%DATADIR%%/army/default.lwa
%%DATADIR%%/army/duel.lwa
@@ -55,18 +57,23 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/glade/editor/armyset-info-dialog.ui
%%DATADIR%%/glade/editor/armyset-window.ui
%%DATADIR%%/glade/editor/backpack-editor-dialog.ui
+%%DATADIR%%/glade/editor/battle-calculator-dialog.ui
%%DATADIR%%/glade/editor/city-editor-dialog.ui
%%DATADIR%%/glade/editor/cityset-info-dialog.ui
%%DATADIR%%/glade/editor/cityset-window.ui
%%DATADIR%%/glade/editor/editor-quit-dialog.ui
+%%DATADIR%%/glade/editor/editor-save-changes-dialog.ui
%%DATADIR%%/glade/editor/editor-splash-window.ui
%%DATADIR%%/glade/editor/fight-order-editor-dialog.ui
%%DATADIR%%/glade/editor/hero-editor-dialog.ui
+%%DATADIR%%/glade/editor/heroes-dialog.ui
%%DATADIR%%/glade/editor/image-editor-dialog.ui
%%DATADIR%%/glade/editor/itemlist-dialog.ui
+%%DATADIR%%/glade/editor/keeper-dialog.ui
%%DATADIR%%/glade/editor/main-window.ui
%%DATADIR%%/glade/editor/map-info-dialog.ui
%%DATADIR%%/glade/editor/masked-image-editor-dialog.ui
+%%DATADIR%%/glade/editor/media-dialog.ui
%%DATADIR%%/glade/editor/new-map-dialog.ui
%%DATADIR%%/glade/editor/players-dialog.ui
%%DATADIR%%/glade/editor/reward-editor-dialog.ui
@@ -76,16 +83,15 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/glade/editor/select-army-dialog.ui
%%DATADIR%%/glade/editor/select-hidden-ruin-dialog.ui
%%DATADIR%%/glade/editor/select-item-dialog.ui
-%%DATADIR%%/glade/editor/select-reward-dialog.ui
%%DATADIR%%/glade/editor/shieldset-info-dialog.ui
%%DATADIR%%/glade/editor/shieldset-window.ui
%%DATADIR%%/glade/editor/signpost-editor-dialog.ui
%%DATADIR%%/glade/editor/smallmap-editor-dialog.ui
%%DATADIR%%/glade/editor/stack-editor-dialog.ui
+%%DATADIR%%/glade/editor/stone-editor-dialog.ui
%%DATADIR%%/glade/editor/switch-sets-dialog.ui
%%DATADIR%%/glade/editor/temple-editor-dialog.ui
%%DATADIR%%/glade/editor/tile-preview-dialog.ui
-%%DATADIR%%/glade/editor/tile-size-editor-dialog.ui
%%DATADIR%%/glade/editor/tileset-explosion-picture-editor-dialog.ui
%%DATADIR%%/glade/editor/tileset-flag-editor-dialog.ui
%%DATADIR%%/glade/editor/tileset-info-dialog.ui
@@ -93,12 +99,11 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/glade/editor/tileset-smallmap-building-colors-dialog.ui
%%DATADIR%%/glade/editor/tileset-window.ui
%%DATADIR%%/glade/editor/tilestyle-organizer-dialog.ui
+%%DATADIR%%/glade/editor/validation-dialog.ui
%%DATADIR%%/glade/fight-order-dialog.ui
%%DATADIR%%/glade/fight-window.ui
%%DATADIR%%/glade/fighter.ui
-%%DATADIR%%/glade/game-button-box-desktop.ui
%%DATADIR%%/glade/game-button-box-large-screen.ui
-%%DATADIR%%/glade/game-button-box-netbook.ui
%%DATADIR%%/glade/game-loaded-dialog.ui
%%DATADIR%%/glade/game-lobby-dialog.ui
%%DATADIR%%/glade/game-options-dialog.ui
@@ -113,6 +118,7 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/glade/history-report-dialog.ui
%%DATADIR%%/glade/item-bonus-dialog.ui
%%DATADIR%%/glade/item-report-dialog.ui
+%%DATADIR%%/glade/load-progress-window.ui
%%DATADIR%%/glade/load-scenario-dialog.ui
%%DATADIR%%/glade/main-preferences-dialog.ui
%%DATADIR%%/glade/medal-awarded-dialog.ui
@@ -129,6 +135,7 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/glade/quest-assigned-dialog.ui
%%DATADIR%%/glade/quest-expired-dialog.ui
%%DATADIR%%/glade/quest-report-dialog.ui
+%%DATADIR%%/glade/quick-help-window.ui
%%DATADIR%%/glade/report-dialog.ui
%%DATADIR%%/glade/ruin-report-dialog.ui
%%DATADIR%%/glade/ruin-rewarded-dialog.ui
@@ -138,17 +145,11 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/glade/sage-dialog.ui
%%DATADIR%%/glade/signpost-change-dialog.ui
%%DATADIR%%/glade/splash-window.ui
-%%DATADIR%%/glade/stack-army-button-desktop.ui
%%DATADIR%%/glade/stack-army-button-large-screen.ui
-%%DATADIR%%/glade/stack-army-button-netbook.ui
%%DATADIR%%/glade/stack-info-dialog.ui
%%DATADIR%%/glade/stack-info-window.ui
-%%DATADIR%%/glade/stack-tile-box-desktop.ui
%%DATADIR%%/glade/stack-tile-box-large-screen.ui
-%%DATADIR%%/glade/stack-tile-box-netbook.ui
-%%DATADIR%%/glade/status-box-desktop.ui
%%DATADIR%%/glade/status-box-large-screen.ui
-%%DATADIR%%/glade/status-box-netbook.ui
%%DATADIR%%/glade/surrender-dialog.ui
%%DATADIR%%/glade/surrender-refused-dialog.ui
%%DATADIR%%/glade/temple-visit-dialog.ui
@@ -180,15 +181,13 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/tilesets/default.lwt
%%DATADIR%%/tilesets/stark.lwt
%%DATADIR%%/tilesets/wesnoth.lwt
-%%DATADIR%%/various/arrows-medium.png
-%%DATADIR%%/various/arrows.png
%%DATADIR%%/various/bag.png
%%DATADIR%%/various/bigmedals.png
-%%DATADIR%%/various/buttons-medium.png
%%DATADIR%%/various/buttons.png
%%DATADIR%%/various/castle_icon.ico
%%DATADIR%%/various/castle_icon.png
%%DATADIR%%/various/city_occupied.png
+%%DATADIR%%/various/commentator.png
%%DATADIR%%/various/cursors.png
%%DATADIR%%/various/diplomacy-large.png
%%DATADIR%%/various/diplomacy-small.png
@@ -202,6 +201,7 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/various/editor/button_bridge.png
%%DATADIR%%/various/editor/button_castle.png
%%DATADIR%%/various/editor/button_erase.png
+%%DATADIR%%/various/editor/button_fight.png
%%DATADIR%%/various/editor/button_move.png
%%DATADIR%%/various/editor/button_port.png
%%DATADIR%%/various/editor/button_road.png
@@ -209,6 +209,7 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/various/editor/button_selector.png
%%DATADIR%%/various/editor/button_signpost.png
%%DATADIR%%/various/editor/button_stack.png
+%%DATADIR%%/various/editor/button_stone.png
%%DATADIR%%/various/editor/button_temple.png
%%DATADIR%%/various/hero-inactive.png
%%DATADIR%%/various/hero-newlevel-female.png
@@ -220,7 +221,6 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/various/movebonus.png
%%DATADIR%%/various/parley_offered.png
%%DATADIR%%/various/parley_refused.png
-%%DATADIR%%/various/prodshieldset-medium.png
%%DATADIR%%/various/prodshieldset.png
%%DATADIR%%/various/recruit_female.png
%%DATADIR%%/various/recruit_male.png
@@ -237,12 +237,15 @@ share/locale/pl/LC_MESSAGES/lordsawar.mo
%%DATADIR%%/various/smallunexploredruin.png
%%DATADIR%%/various/smallunexploredstronghold.png
%%DATADIR%%/various/smallupkeep.png
-%%DATADIR%%/various/splash_screen.jpg
+%%DATADIR%%/various/splash_screen.png
%%DATADIR%%/various/tileset_icon.ico
%%DATADIR%%/various/tileset_icon.png
%%DATADIR%%/various/tilestyles.png
%%DATADIR%%/various/waypoints.png
%%DATADIR%%/various/win.png
%%DATADIR%%/various/xslt/as-0.2.1-0.3.0.xsl
+%%DATADIR%%/various/xslt/c-0.2.1-0.2.2.xsl
%%DATADIR%%/various/xslt/gs-0.2.0-0.2.1.xsl
-%%DATADIR%%/various/xslt/pbm-0.2.0-0.2.1.xsl
+%%DATADIR%%/various/xslt/gs-0.2.1-0.3.2.xsl
+%%DATADIR%%/various/xslt/ss-0.2.1-0.3.2.xsl
+%%DATADIR%%/various/xslt/ts-0.2.1-0.3.2.xsl