aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-16 16:05:11 +0800
committerbapt <bapt@FreeBSD.org>2014-07-16 16:05:11 +0800
commit4d110df2973007f403cd80a057835d869cc1f524 (patch)
tree8565138a516db94da31b12ab4e904d78eae496cc /games
parent705dd5ad58b89489c40788ef768f6c02366036f9 (diff)
downloadfreebsd-ports-gnome-4d110df2973007f403cd80a057835d869cc1f524.tar.gz
freebsd-ports-gnome-4d110df2973007f403cd80a057835d869cc1f524.tar.zst
freebsd-ports-gnome-4d110df2973007f403cd80a057835d869cc1f524.zip
Fix non default LIB_DEPENDS
With hat: portmgr
Diffstat (limited to 'games')
-rw-r--r--games/quakeforge/Makefile4
-rw-r--r--games/ufoai/Makefile2
-rw-r--r--games/wesnoth/Makefile4
3 files changed, 5 insertions, 5 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 8c84f99c9079..abbdef985073 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -62,7 +62,7 @@ PLIST_SUB+= SDL="@comment "
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--with-ogg=${LOCALBASE} --with-vorbis=${LOCALBASE}
PLIST_SUB+= VORBIS=""
.else
@@ -71,7 +71,7 @@ PLIST_SUB+= VORBIS="@comment "
.endif
.if ${PORT_OPTIONS:MXMMS}
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS+= libxmms.so:${PORTSDIR}/multimedia/xmms
CONFIGURE_ARGS+=--with-xmms-prefix=${LOCALBASE}
PLIST_SUB+= XMMS=""
.else
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 7f2ae60701aa..9e3a659c933f 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -70,7 +70,7 @@ PLIST_SUB+= UFO2MAP="@comment "
.if $(PORT_OPTIONS:MUFORADIANT)
CONFIGURE_ARGS+=--enable-uforadiant
USE_GNOME+= gtk20 glib20 gtksourceview2 libxml2
-LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS+= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
RADIANT_FILE= uforadiant
RADIANT_DIRS= bitmaps i18n prefabs sourceviewer
PLIST_SUB+= UFORADIANT=""
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 65a5cb69d10b..6fe287d053fa 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -70,7 +70,7 @@ PLIST_SUB+= CAMPAIGN="@comment "
.if ${PORT_OPTIONS:MFRIBIDI}
CMAKE_ARGS+= -DENABLE_FRIBIDI=on
-LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
.else
CMAKE_ARGS+= -DENABLE_FRIBIDI=off
.endif
@@ -83,7 +83,7 @@ CMAKE_ARGS+= -DENABLE_LOW_MEM=off
.if ${PORT_OPTIONS:MNOTIFY}
CMAKE_ARGS+= -DENABLE_NOTIFICATIONS=on
-LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
.else
CMAKE_ARGS+= -DENABLE_NOTIFICATIONS=off
.endif